Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WLC CONFIGURATION WITH DIFFERENT VLAN & SSID

Hi Everyone,

I have a scenario in which WLC 2504 is connected to Core switch 4507R+E.and access switches are connected to Core switch as well. In these access switches Access points AIR-CAP702I-A-K9.

My question is as follows:

I want to use vlan 104 for office employes with SSID OFFICE-EMPLOYES

I want to use vlan 103 for guest with SSID Office-Guests

Below is what i have configured on core switch 

(config)#interface xx

(config)#description xxx

(config)#switchport mode trunk

(config)#switchport trunk allowed vlan 103,104

Below is what i have configured on access switches

(config)#interface xx

(config)#swithcport mode access

(config)#swithcport access vlan 104

If i am configuring trunk port on access switches and allowing both vlan's 103 & 104 access points are not joining controller.

Right now management IP is from vlan 104 and all access points and clients are getting ip from 104 vlan.

What shall i do in this scenario.I want to use segregate the guest and office employe traffic.

It would be great if any one can help me.

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Hi,

Hi,

I am assuming that AP management vlan is 104 !!!!!

Please check these:

Core switch config for WLC:

interface GigabitEthernet XX
description ***  Cisco WLC ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 103,104
switchport mode trunk
no shutdown
!

Access Switch for Lightweight AP:

interface GigabitEthernet1/0/22
description *** AP ***
switchport access vlan 104 
switchport mode access
no shutdown

Uplink port from core switch to access switch and vice versa must  be configured as trunk port.

Regards

Don't forget to rate helpful posts

5 REPLIES
VIP Purple

Hi,

Hi,

I am assuming that AP management vlan is 104 !!!!!

Please check these:

Core switch config for WLC:

interface GigabitEthernet XX
description ***  Cisco WLC ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 103,104
switchport mode trunk
no shutdown
!

Access Switch for Lightweight AP:

interface GigabitEthernet1/0/22
description *** AP ***
switchport access vlan 104 
switchport mode access
no shutdown

Uplink port from core switch to access switch and vice versa must  be configured as trunk port.

Regards

Don't forget to rate helpful posts

New Member

Sandeep Choudhary is there...

Sandeep Choudhary is there........

So he is right... Thanks Sandeep Choudhary

Thanks and Regards

kafi

New Member

Hi,

Hi,

i HAVE CISCO OUTDOOR ACCESS POINT AIR-CAP1552E-A-K9.

ALSO WE HAVE CONTROLLER AIR -CT5508-50-K9.

THE PROBELM GOES LIKE THIS :

the image in AIR-CAP1552E-A-K9 by factory is " c1520-k9w7-mx.152-2.JB " which is standalone image. As we have controller i am trying to change this image to controller based image .Therefore i have downloaded a controller image file from cisco website  c1520-k9w8-mx.153-3.JD

after uploading the controller based image file on the out door access point succesfully, i am trying to boot the access point from new image "set BOOT flash:/c1520-k9w8-tar.153-3.JD/c1520-k9w8-tar.153-3.JD"  

but i am getting this error 

ap: set BOOT flash:/c1520-k9w8-tar.153-3.JD/c1520-k9w8-tar.153-3.JD

ap: boot
Loading "flash:/c1520-k9w8-tar.153-3.JD/c1520-k9w8-tar.153-3.JD"...flash:/c1520- k9w8-tar.153-3.JD/c1520-k9w8-tar.153-3.JD: no such file or directory

Error loading "flash:/c1520-k9w8-tar.153-3.JD/c1520-k9w8-tar.153-3.JD"

Interrupt within 5 seconds to abort boot process.
Loading "flash:/c1520-k9w7-mx.152-2.JB/c1520-k9w7-mx.152-2.JB"...##############

File "flash:/c1520-k9w7-mx.152-2.JB/c1520-k9w7-mx.152-2.JB" uncompressed and ins talled, entry point: 0x3000
executing...

as you can see in the above error it is showing error loading and again booting from old file which K9W7 standalone image

could please tell me what do or is there any work around for this

New Member

I think that problem began

I think that problem began from message: "no such file or directory", so you have to convert the image c1520-k9w8-tar.153-3.JD with Convertio program of RAR to TAR for that image is correctly upload.

Note: I had the same message to upload ip-phone firmware throught TFTP vs CLI...!!!

Regards,

VQ

New Member

Hi qvictorhu ,

Hi qvictorhu ,

i did the file conversion from tar to rar from convetio program.but the error is same as mentioned above.

and as you requested below is the dir flash:

ap#
ap#dir flash:
Directory of flash:/

2 -rwx 10205 Mar 1 1993 00:07:58 +00:00 event.log
3 -rwx 1048 Mar 1 1993 00:01:07 +00:00 private-multiple-fs
5 drwx 1344 Jan 1 1970 00:09:31 +00:00 c1520-k9w7-mx.152-2.JB
204 -rwx 209 Mar 1 1993 00:01:44 +00:00 env_vars
205 drwx 1600 Jan 1 1970 00:08:22 +00:00 c1520-k9w8-mx.153-3.JD

31610880 bytes total (12558336 bytes free)
ap#

161
Views
5
Helpful
5
Replies