Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

WLC Error - SSID connection is flapping

Hi All,

 

I have a strange and "simple" scenario which is making problems on my wireless connections, lemme explain:

I have two WLC 5508 running a image version 7.6.100.0 and APs 2602E in 3 different place such as Controller + 13 APs on HQ and 9 APs divided by 2 branches.

I do not have VLANs for while, just a basic and flat vlan, two SSIDs without broadcast which one is for Data Collectors and other is for users with WPA2-Personal security. 

APs in HQ are configured as Local Mode and on branches are configured as FlexConnect.

I am losing my connection from Data Collectors or Laptops to the SSIDs (it's just desappearing and returning after 60 seconds +/-). When I look to the WLC log, its showing the errors below:

 

*spamApTask0: Sep 23 12:16:24.149: #APF-3-WLAN_OUT_OF_RANGE: apf_site_override.c:2309 WLAN value 17 is out of range.
*spamApTask0: Sep 23 12:16:24.149: #LWAPP-3-VENDOR_SPEC_ERR: spam_lrad.c:13403 The system has failed decoding vendor specific payload
*spamApTask0: Sep 23 12:16:21.650: #CAPWAP-3-SEM_RELEASE_ERR: capwap_ac_db.c:107 The system could not release exclusive access of AP entry for 18:9c:5d:44:4e:d0 in the database

 

 

Could you please guys help me on this? Could be an Image problem?

I know that my current topology is wrong however it was the only way that I had to put it up regarding business needs.

 

Thank you guys

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Yes, your image is first 7.6

Yes, your image is first 7.6 release & not that good. I would suggest you to move onto 7.6.130.0 (7.6MR3) & test it again. Here is the release notes for this MR3 release

http://www.cisco.com/c/en/us/td/docs/wireless/controller/release/notes/crn76mr03.html

Also make sure your WLC FUS image upgraded to 1.9.0.0

http://www.cisco.com/c/en/us/td/docs/wireless/controller/release/notes/fus_rn_OL-31390-01.html

HTH

Rasika

**** Pls rate all useful responses ****

 

12 REPLIES
VIP Purple

Yes, your image is first 7.6

Yes, your image is first 7.6 release & not that good. I would suggest you to move onto 7.6.130.0 (7.6MR3) & test it again. Here is the release notes for this MR3 release

http://www.cisco.com/c/en/us/td/docs/wireless/controller/release/notes/crn76mr03.html

Also make sure your WLC FUS image upgraded to 1.9.0.0

http://www.cisco.com/c/en/us/td/docs/wireless/controller/release/notes/fus_rn_OL-31390-01.html

HTH

Rasika

**** Pls rate all useful responses ****

 

Hey Rasika, Thanks for your

Hey Rasika,

 

Thanks for your quickly reply. I'm gonna do it today in an appropriate window and will return it to you.

 

Thank you for while.

VIP Purple

Hi,Keep us posted on how

Hi,

Keep us posted on how things once you do this upgrade.

Also rate our responses if you find it useful

Rasika

Hi Rasika, It's seems better

Hi Rasika,

 

It's seems better now, however 40 minutes ago I got the same issue with aditional log. I don't know if it happened due to problem not solved or maybe a problem with one client only. Follow log:

 

*spamApTask1: Sep 24 09:41:00.333: #APF-3-WLAN_OUT_OF_RANGE: apf_site_override.c:2309 WLAN value 17 is out of range.
*spamApTask1: Sep 24 09:41:00.333: #LWAPP-3-VENDOR_SPEC_ERR: spam_lrad.c:13418 The system has failed decoding vendor specific payload
*spamApTask1: Sep 24 09:40:59.395: #CAPWAP-3-SEM_RELEASE_ERR: capwap_ac_db.c:107 The system could not release exclusive access of AP entry for 18:9c:5d:44:4e:d0 in the database
*spamApTask1: Sep 24 09:40:58.195: #LWAPP-3-VALIDATE_ERR: spam_lrad.c:10770 Validation of SPAM_VENDOR_SPECIFIC_PAYLOAD failed - AP  18:9c:5d:44:4e:d0
*spamApTask0: Sep 24 09:40:50.957: #CAPWAP-3-ECHO_ERR: capwap_ac_sm.c:6731 Did not receive heartbeat reply; AP: 18:9c:5d:44:f3:30
*spamApTask0: Sep 24 09:40:50.392: #APF-3-WLAN_OUT_OF_RANGE: apf_site_override.c:2309 WLAN value 17 is out of range.
*spamApTask0: Sep 24 09:40:50.392: #LWAPP-3-VENDOR_SPEC_ERR: spam_lrad.c:13418 The system has failed decoding vendor specific payload
*spamApTask0: Sep 24 09:40:49.145: #CAPWAP-3-SEM_RELEASE_ERR: capwap_ac_db.c:107 The system could not release exclusive access of AP entry for 18:9c:5d:45:04:50 in the database
*spamApTask0: Sep 24 09:40:48.156: #LWAPP-3-VALIDATE_ERR: spam_lrad.c:10770 Validation of SPAM_VENDOR_SPECIFIC_PAYLOAD failed - AP  18:9c:5d:45:04:50
*spamApTask7: Sep 24 09:40:45.655: #LWAPP-3-VALIDATE_ERR: spam_lrad.c:10770 Validation of SPAM_VENDOR_SPECIFIC_PAYLOAD failed - AP  18:9c:5d:44:f3:20
*spamApTask2: Sep 24 09:40:35.753: #CAPWAP-3-ECHO_ERR: capwap_ac_sm.c:6731 Did not receive heartbeat reply; AP: 18:9c:5d:44:54:50
*Dot1x_NW_MsgTask_5: Sep 24 09:37:22.413: #DOT1X-3-INVALID_REPLAY_CTR: 1x_eapkey.c:445 Invalid replay counter from client a8:54:b2:65:f3:d5 - got 00 00 00 00 00 00 00 02, expected 00 00 00 00 00 00 00 03

 

I pinged 3 devices from yesterday (after full upgrade) to today morning and there were ANY downtime. After I back to the office I tried to ping everything and only once it happens as I mentioned above.

 

Thanks,

VIP Purple

Did you upgrade FUS ot 1.9.0

Did you upgrade FUS ot 1.9.0.0 as well ? "show sysinfo" output will tells this

HTH

Rasika

Yes, I have done it. Follow

Yes, I have done it. Follow the output:

 

Manufacturer's Name.............................. Cisco Systems Inc.
Product Name..................................... Cisco Controller
Product Version.................................. 7.6.130.0
Bootloader Version............................... 1.0.20
Field Recovery Image Version..................... 7.6.95.16
Firmware Version................................. FPGA 1.7, Env 1.8, USB console 2.2
Build Type....................................... DATA + WPS

System Name...................................... DCWLController02
System Location..................................
System Contact...................................
System ObjectID.................................. 1.3.6.1.4.1.9.1.1069
Redundancy Mode.................................. Disabled
IP Address....................................... 192.168.25.116
Last Reset....................................... Software reset
System Up Time................................... 0 days 22 hrs 39 mins 11 secs
System Timezone Location......................... (GMT -3:00) Buenos Aires (Agentina)
System Stats Realtime Interval................... 5
System Stats Normal Interval..................... 180

Configured Country............................... BR  - Brazil
Operating Environment............................ Commercial (0 to 40 C)

--More-- or (q)uit
Internal Temp Alarm Limits....................... 0 to 65 C
Internal Temperature............................. +39 C
External Temperature............................. +24 C
Fan Status....................................... OK

State of 802.11b Network......................... Enabled
State of 802.11a Network......................... Enabled
Number of WLANs.................................. 2
Number of Active Clients......................... 25

Burned-in MAC Address............................ 18:E7:28:F5:40:40
Power Supply 1................................... Present, OK
Power Supply 2................................... Present, OK
Maximum number of APs supported.................. 50

 

Thanks,

VIP Purple

HiThanks for that output#APF

Hi

Thanks for that output

#APF-3-WLAN_OUT_OF_RANGE: apf_site_override.c:2309 WLAN value 17 is out of range.

It is strange that above is complaining use of WLAN_ID 17 (look like buggy behavior). What are the WLAN ID numbers are you using ? ("show wlan summary" output)

HTH

Rasika

*** Pls rate all useful responses ****

Hi Rasika, Sorry for the

Hi Rasika,

 

Sorry for the delay. I have just IDs 2 and 3. Follow the output:

 

(Cisco Controller) >show wlan summary

Number of WLANs.................................. 2

WLAN ID  WLAN Profile Name / SSID               Status    Interface Name        PMIPv6 Mobility
-------  -------------------------------------  --------  --------------------  ---------------
2        WMSAP / WMSAP                          Enabled   management            none
3        CIMED / CIMED                          Enabled   management            none

 

Thanks,

VIP Purple

Hi I suspect this is a bug,

Hi 

I suspect this is a bug, better if you could reach TAC & check with them.

Otherwise you can try with 8.0.100.0 code (as trial & error) to see if this is not there in that code. Again that code is too new & do not want to recommend it without reaching TAC

HTH

Rasika

**** Pls rate all useful responses ****

Hey Rasika, Thank you for all

Hey Rasika,

 

Thank you for all support. I was talking to TAC and besides firmware upgrading I have done other 4 things:

 

On CIMED SSID I removed TKIP.

On both SSIDs session timeout was enabled with 30 minutes, then all clients would be dropped. I have disabled it as well inside "advanced tab and unchecking session timeout".

I also disable Aironet IE and MFP, they add more information to every frame.

 

I am gonna send this bug to them (I also sent but will ask just about it) and I wil try to understand it better.

 

Thank you again, I really appreciate your time helping me.

 

Thanks a lot.

 

VIP Purple

Not a problem... Great to see

Not a problem... Great to see that you get TAC support on this. I am sure you will find a solution with TAC support.

Keep us posted once you get a resolution. It may help others.

Rasika

Hey Rasiki, You were right

Hey Rasiki,

 

You were right about the bug, follow Cisco reply:

 

"I checked the error message and it looks this is a cosmetic bug that appears when MFP is set as optional ( it is set with this value by default) or if it is disabled ( as you changed it). The log points only to bug CSCum87504. The bug is just a cosmetic error so you do not have to worry about any performance issue."

 

 

Thank you again for all help.

2684
Views
0
Helpful
12
Replies
CreatePlease login to create content