Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WPA/PSK Auth. Problems with spec. Linux Client

Hello,

I have a client who can not authenticate on an autonomous Cisco wireless AP with his special WLAN client?

Result: Authentication mismatch

If I use a TP-Link or Netgear AP, the specific wireless client can authenticate! No problem.

All other wireless Klients (eg Win7, iPhone, Android, etc.) have no problems with the Cisco AP. The authentication WPA2/PSK working properly.

I have tested it with an AP1142 and 2620i (IOS 12.x and 15.x). The spec. Client can not authenticate?

Do you have experience with such a problem and can you give me tips why.

What debugging commands should I use to see more?

Information of WLAN Client:

OS: embedded Linux based on the kernel 2.6.34

WLAN Stack: mac80211 Stack, after my info has no own version and refers to the kernel version (2.6.34)

Motherboard: They have no commercially available PC but its own system. Motherboard is therefore our CPU module with a Marvell PXA166 processor as the main.

WLAN Stick: Netgear WNA1100 they operate with the driver ath9k_htc

They also use our system to the wpa_supplicant v1.0

Access-Point Conficuration:

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname DOP-AP-1

!

enable secret 5 xxxxxxxx

!

no aaa new-model

!

!

dot11 syslog

dot11 vlan-name Pruefnetz-WLAN vlan 135

!

dot11 ssid DOP-WLAN-Pruefnetz

   vlan 135

   authentication open

   authentication key-management wpa version 2

   mbssid guest-mode

   wpa-psk ascii 7 xxxxxxxxxx

!

!

!

username Cisco password 7 05280F1C2243

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 135 mode ciphers aes-ccm

!

ssid DOP-WLAN-Pruefnetz

!

antenna gain 0

mbssid

speed  basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.

packet retries 128 drop-packet

channel least-congested 2412 2437 2462

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.135

encapsulation dot1Q 135

no ip route-cache

bridge-group 135

bridge-group 135 subscriber-loop-control

bridge-group 135 block-unknown-source

no bridge-group 135 source-learning

no bridge-group 135 unicast-flooding

bridge-group 135 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption vlan 135 mode ciphers aes-ccm

!

ssid DOP-WLAN-Pruefnetz

!

antenna gain 0

no dfs band block

mbssid

channel width 40-below

channel dfs

station-role root

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1.135

encapsulation dot1Q 135

no ip route-cache

bridge-group 135

bridge-group 135 subscriber-loop-control

bridge-group 135 block-unknown-source

no bridge-group 135 source-learning

no bridge-group 135 unicast-flooding

bridge-group 135 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

no keepalive

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.135

encapsulation dot1Q 135

no ip route-cache

bridge-group 135

no bridge-group 135 source-learning

bridge-group 135 spanning-disabled

!

interface BVI1

ip address 10.4.0.72 255.255.0.0

no ip route-cache

!

ip default-gateway 10.4.0.1

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

password 7 070D2E44400C2616001B

login

!

end

Thanks for help

Alexander

279
Views
0
Helpful
0
Replies
CreatePlease login to create content