Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unable to create VDC with Amazon EC2 via MCAK 3.1.1_v7

Hello,

I have MCAK 3.1.1_v7 installed and its cloudsyncing to Amazon EC2 OK and have a POD created. 

For some reason, when creating a new VDC within an EC2 POD, the active form component for Virtual Data Center, is still expecting a cluster and datasource - which are not EC2 entities (i dont think).  Attempting to register a new cluster results in prompt asking to run cloudsync, so this reinforces that the Amazon cloudsync is not to retrieving these entities.  Network drop down periodically populates with the EC2 networks, not consistently.

ec2_vdc_cluster.png

Within SIBDVirtualDataCenter, PODSIName contains "Retrieve Cluster DisplayName" rule which performs an SQL lookup from SiCluster and SiDataCenter - though this returns no value as EC2 doesnt populate the Cluster infrastructure service item.  Can't see any logic in the form to disable these parts of the form if EC2. 

Is there a way of validating the service / active form component contains the correct configuration?

thanks

Roger

Everyone's tags (4)
2 REPLIES
Bronze

Unable to create VDC with Amazon EC2 via MCAK 3.1.1_v7

Looks like a JavaScript event is not happening  that renders the form differently for EC2, perhaps due to a JS error. Probably quickest to resolve via WebEx. Please reach out to me directly to schedule some time to review.

Derek (derevan@cisco.com)

Bronze

Re: Unable to create VDC with Amazon EC2 via MCAK 3.1.1_v7

For others that have encountered this issue, you will want to make sure you have the very latest Prime Service Catalog (Cloud Portal) patches. The problem occurs because JavaScript associated with forms brought in through a service bundle are not executing on form load. Although the problem was fixed in 9.4.1 R2 and a patch to 9.4.1, the problem continues to occur when bundled forms are loaded during Authorization.

The workaround for BOTH the Ordering and Authorization moments is to select the option When the form is loaded (browser-side) for the MultiCloud_Platform_Handler JavaScript in Service Designer. This adds additional overhead to forms that do not require this script, but it is harmless as the code in that script is conditionally executed.

       

82
Views
0
Helpful
2
Replies
CreatePlease login to create content