Cisco Support Community
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

ASA5520 7.2 and AIP-SSM-10 5.0.2

Someone else setup the ASA and gave the SSM module a password that I do not have access to. I have tried to reimage and during the recovery process it just reboots continuously pulling the image from the tftp server everytime.

Has anyone encountered this and fixed the issue?



Cisco Employee

Re: ASA5520 7.2 and AIP-SSM-10 5.0.2

There can be different reasons for this like either the path provided in the configuration is not correct or the image file on the tftpserver is corrupt. SSM is probably unable to pull the image from the server. You can see what is happening on the SSM by providing the command "debug module-boot" on your ASA.

To check the configuration on your ASA you can enter the configure mode via the following command:

- "hw-module module recover configure"

If the configuration looks ok then pl check the file checksum and location wrt the configuration.

Hope this helps.

Cisco Employee

Re: ASA5520 7.2 and AIP-SSM-10 5.0.2

In the ASA console exeute "debug module-boot".

When the module has a ROMMON similar to the ROMMON on the ASA itself. You can't directly access the module's ROMMON, but the debug module-boot will allow you to see the ROMMON commands and output that are being executed as part of the recovery.

You can then look for typos or incorrect entries in the recovery configuration that the ASA sent to the module's ROMMON. And look for any errors that ROMMON may be reporting for the tftp of the file.

Typical cause is a typo in the recovery configuration that was sent to the module.

Re-execute the recover config and correct the entries. Then try another recover boot to get it to use the corrected configuration.

You may have to try reset or recover stop to get it to take the new configuration.

Community Member

Re: ASA5520 7.2 and AIP-SSM-10 5.0.2

I redownloaded the image and it worked that time.


CreatePlease to create content