Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Autoupdate IPS signature not working

I am getting the following on the IPS auto-update

Auto Update Statistics

lastDirectoryReadAttempt = 02:30:00 Eastern Tue Jun 09 2009

= Read directory: http://198.133.219.25/pcgi-bin/tablebuild.pl/ips6-sigup

= Error: http error response: 400

lastDownloadAttempt = N/A

lastInstallAttempt = N/A

nextAttempt = 02:30:00 Eastern Wed Jun 10 2009

Auto Update Statistics

lastDirectoryReadAttempt = 02:13:00 Eastern Wed Jun 10 2009

= Read directory: http://198.133.219.25/pcgi-bin/tablebuild.pl/ips6-sigup

= Error: http error response: 400

lastDownloadAttempt = N/A

lastInstallAttempt = N/A

nextAttempt = 02:13:00 Eastern Thu Jun 11 2009

Can you tell me what I am doing wrong.

  • Intrusion Prevention Systems/IDS
6 REPLIES
Cisco Employee

Re: Autoupdate IPS signature not working

Ensure your SSM can connect to internet, try by pinging from SSM to 4.2.2.2

Also correct the URL..

https://198.133.219.25//cgi-bin/front.x/ida/locator/locator.pl

New Member

Re: Autoupdate IPS signature not working

Thanks for the response. I change the URL and it did not make any difference. I am able to ping 4.2.2.2

I still getting the 400 error. Anything else I need to do.

Cisco Employee

Re: Autoupdate IPS signature not working

is management IP getting routed through ASA inside interface ? if yes then kindly get me the packet captures

access-list abc permit ip host host 198.133.219.25

access-list abc permit ip host 198.133.219.25 host

capture cpi access-l abc interface

Intf.Name-->INterface on ASA which is part of same VLAN as IPS Mngmt IP

Also send me the latest show statistics host

Re: Autoupdate IPS signature not working

To add to the wonderful comment by Ashish, I had the same problem and fixed it by changing the "//" after the IP address to "/".

Please rate useful posts.
New Member

Re: Autoupdate IPS signature not working

What was is the CORRECT current URL which actually works in the real world; NOT lifted off some wrong documentation? I mean working URL - copy and paste from a working setup please?

Thanks

Re: Autoupdate IPS signature not working

Update the Auto Update URL Using the CLI (all other IPS versions)

NOTE: Do not change the double slash (//) at the end of the IP address shown in this configuration.

sensor#config t
sensor(config)#service host
sensor(config-hos)#auto-upgrade
sensor(config-hos-aut)#cisco-server enabled
sensor(config-hos-aut-ena)#cisco-url https://72.163.4.161//cgi-bin/front.x/ida/locator/locator.pl
sensor(config-hos-aut-ena)#exit
sensor(config-hos-aut)#exit
sensor(config-hos)#exit
Apply Changes?[yes]:yes

563
Views
0
Helpful
6
Replies
This widget could not be displayed.