Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cannot communicate with mainApp

Hi,

Whenever we apply the signature update to IPS 4240, it reboot itself normal but gives an error after enter the

username/pasword by using ssh; and not enter the CLI.

"Error: Cannot communicate with mainApp (getVersion). Please contact your system administrator.

Would you like to run cidDump?[no]: "

After rebooting the IPS by power off/power on, it works normal, we enter CLI.

So we could not apply the signature update to IPS 4230.

Any advice about this problem?

Thanks.

IPS# sh ver

Application Partition:

Cisco Intrusion Prevention System, Version 5.1(1)S205.0

Host:

Realm Keys key1.0

Signature Definition:

Signature Update S205.0 2005-11-30

OS Version: 2.4.26-IDS-smp-bigphys

Platform: IPS-4240-K9

Serial Number: JMX0932K00Y

Licensed, expires: 12-Apr-2007 UTC

Sensor up-time is 36 min.

Using 247058432 out of 1984704512 bytes of available memory (12% usage)

system is using 17.3M out of 36.8M bytes of available disk space (47% usage)

application-data is using 45.8M out of 166.8M bytes of available disk space (29% usage)

boot is using 35.0M out of 68.6M bytes of available disk space (54% usage)

MainApp 2005_Nov_15_13.47 (Release) 2005-11-15T14:27:20-0600 Running

AnalysisEngine 2006_Apr_20_14.31 (Release) 2006-04-20T15:14:57-0500 Running

CLI 2005_Nov_15_13.47 (Release) 2005-11-15T14:27:20-0600

Upgrade History:

IPS-K9-min-5.1-1 11:47:00 UTC Tue Nov 15 2005

Recovery Partition Version 1.1 - 5.1(1)

4 REPLIES
Silver

Re: Cannot communicate with mainApp

I suggest you apply the 5.1.1p1 patch. Then apply the latest signature available.

If ever after the update to 5.1.1p1, you get the error still, I sugest you give the sensor a bit of time, before attempting the signature update.

I hope this helps you.

Eric

New Member

Re: Cannot communicate with mainApp

Where could i find this update?

I could not find the version 5.1.1p1. There is only the version 5.1-1e and they did not suggest to apply this version for running 5.1(1).

Thanks for reply.

Regards.

IPS-K9-min-5.1-1e.pkg

IPS Minor Update - NOTE: This upgrade package can only be applied to sensors running version 5.0(x) IPS software. If your sensor(s) is already running version 5.1(1) do not attempt to install this upgrade package.

Silver

Re: Cannot communicate with mainApp

Hi,

From this thread

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Security&topic=Intrusion%20Prevention%20Systems/IDS&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddb4821/4#selected_message

You can request tac for the 511p1 patch.

but if ever you would recover your sensor, the application partition is already on 5.1.1, then just apply the 511p1 patch, then the latest signature on cco.

I hope this helps you.

Cisco Employee

Re: Cannot communicate with mainApp

The engineering patch packages can be downloaded from:

http://www.cisco.com/cgi-bin/tablebuild.pl/ids-patches

1152
Views
0
Helpful
4
Replies