Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CSA Agent not registering with CSA MC

I have downloaded and installed my agent kit on a WinXP machine. But for some reason it is not registering with the CSA MC. Any idea why? The CSAMC is in a different subnet, but 443 is open for communication. Does the MC need other ports open to talk to the agent?

Thanks,

nate

6 REPLIES
Blue

Re: CSA Agent not registering with CSA MC

Are other agents working properly?

What does it show in the log file (csalog.txt) on the host? Try a fast poll and post what it says.

The usual suspect is no licenses on the MC.

Tom S

New Member

Re: CSA Agent not registering with CSA MC

The licenses that were installed on the server were incorrect. Once the correct license file was installed it started working. Thanks everyone for the replies.

New Member

Re: CSA Agent not registering with CSA MC

Edit the Host file on server the agent is installed.

1) Make sure the csa-mc is defined.

2) Make sure the IP address is in the the CSA-MC's registration range.

System / Registration Control

Blue

Re: CSA Agent not registering with CSA MC

A production CSAMC should have a FQDN registered in DNS so that all hosts will be able to find it if DNS is working properly. This eliminates the need to modify hosts files on each host.

The default settings for a new CSAMC is to allow all IP addresses to register. The only reason you'd need to change this is if it was already changed from the default.

Tom

New Member

Re: CSA Agent not registering with CSA MC

I was going to suggest editing the host file as well. Currently, we have several networks that cannot talk to each other, legal reasons, but allow certain communication to pass in order to keep monitoring tools operation. I have no idea what his environment is like, but if for nothing else, modify the file and hit poll.

If it still does not work, I would suggest looking and making sure you have enough valid licenses. *Shrugs* could be an issue.

Silver

Re: CSA Agent not registering with CSA MC

Here is a listing of the various error codes that CSA (used to be Okena) prints when there is a communication issue between an agent and the MC.. Usually the issue is either licensing or CSAMC access restrictions, but this list has all of the causes. Please rate if this helps.

OKENA_STATUS_INVALID_SYSTEM_CONFIGURATION = 2000,

OKENA_STATUS_ICC_FAILED_GET_HANDLE = 2001,

OKENA_STATUS_ICC_FAILED_TO_WRITE = 2002,

OKENA_STATUS_ICC_FAILED_TO_READ = 2003,

OKENA_STATUS_ICC_INVALID_TOPOLOGY = 2004,

OKENA_STATUS_ICC_INVALID_INITIATOR_COMP = 2005,

OKENA_STATUS_ICC_INVALID_PAYLOAD_SIZE = 2006,

OKENA_STATUS_ICC_INVALID_VERSION = 2007,

OKENA_STATUS_ICC_INVALID_COMP_ID = 2008,

OKENA_STATUS_ICC_INVALID_PAYLOAD = 2009,

OKENA_STATUS_GROUP_DOES_NOT_EXIST = 2010,

OKENA_STATUS_INVALID_REGISTRATION_PARAMS = 2011,

OKENA_STATUS_HOST_HAS_REGISTERED_BEFORE = 2012,

OKENA_STATUS_INVALID_CONTACT_INFO = 2013,

OKENA_STATUS_HOST_NOT_REGISTERED = 2014,

OKENA_STATUS_MISSING_CONTACT_INFO_PARAMS = 2015,

OKENA_STATUS_INVALID_REGISTRATION_ID = 2016,

OKENA_STATUS_ICC_INVALID_BYTE_ORDER = 2017,

OKENA_STATUS_ICC_NOT_INITIALIZED = 2018,

OKENA_STATUS_COMP_CONFIGURED = 2019,

OKENA_STATUS_UNDEFINED_MGMT_SERVER = 2020,

OKENA_STATUS_HTTP_TRANSACTION_FAILED = 2021,

OKENA_STATUS_ICC_INVALID_HANDLE = 2022,

OKENA_STATUS_SERVER_IS_REACHABLE = 2023,

OKENA_STATUS_HTTP_TIMEOUT = 2024,

OKENA_STATUS_ICC_NO_CONNECT_MUTEX = 2025,

OKENA_STATUS_FORCE_POLLING_NOW = 2026,

OKENA_STATUS_REGISTRATION_REJECTED = 2027,

OKENA_STATUS_LOAD_CONFIG = 2028,

OKENA_STATUS_DB_ERROR = 2029,

OKENA_STATUS_LICENSE_REACHED_LIMIT = 2030,

OKENA_STATUS_REGISTRATION_NOT_ALLOWED = 2031,

OKENA_STATUS_NOT_ALLOWED_TO_STOP_AGENT = 2032,

OKENA_STATUS_CLIENT_UI_NOT_ALLOWED = 2033,

OKENA_STATUS_FAILED_TO_PRINT_AGENT_REPLY = 2034,

OKENA_STATUS_INVALID_LICENSE = 2035,

OKENA_STATUS_TIMED_OUT = 2036,

OKENA_STATUS_REGISTRATION_BACKOFF = 2037,

OKENA_STATUS_TESTMODE_ON = 2038,

OKENA_STATUS_TESTMODE_OFF = 2039,

OKENA_STATUS_INVALID_SERVER_FQDNS = 2040,

OKENA_STATUS_INVALID_SERVER_IPADDR = 2041,

OKENA_STATUS_SERVER_DNS_NOT_RESOLVABLE = 2042,

OKENA_STATUS_SERVER_IPADDR_NOT_OWN = 2043,

OKENA_STATUS_SERVER_DNS_NOT_OWN = 2044,

OKENA_STATUS_SERVER_NAME_NOT_FQDNS = 2045,

OKENA_STATUS_FAILED_OPEN_PROCESS = 2046,

234
Views
19
Helpful
6
Replies