Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Host not registering with the Management Center

Hello,

We have CSA MC v5.2. I have put a pre-defined CSA on a server (seperate from the CSA MC), which installed successfully and the MC sees the host.

However, although a pre-defined CSA is successfully installed on a host (non-server), I am unable to get the MC to see it. On the host, the CSA simply states that it's, "Not registered with the Management Center."

Please help in resolving this.

Also, is there a Windows Vista fix? Currently, I am unable to get the CSA to install on Vista.

~ Mike

6 REPLIES
Silver

Re: Host not registering with the Management Center

It could be due to :

There is another device registered with the same IP address.

The license runs out.

The license is not correct for the hardware.

if the host is on dfferent subnet

Blue

Re: Host not registering with the Management Center

Wrong OS license is most likely the culprit. CSA 5.2 MC deploys with several server but no desktop OS licenses.

Tom

Silver

Re: Host not registering with the Management Center

If you look at the CSA log file, it will tell you an error code for why the connection is failing. Use the list below to determine what your error code means...

OKENA_STATUS_INVALID_SYSTEM_CONFIGURATION = 2000,

OKENA_STATUS_ICC_FAILED_GET_HANDLE = 2001,

OKENA_STATUS_ICC_FAILED_TO_WRITE = 2002,

OKENA_STATUS_ICC_FAILED_TO_READ = 2003,

OKENA_STATUS_ICC_INVALID_TOPOLOGY = 2004,

OKENA_STATUS_ICC_INVALID_INITIATOR_COMP = 2005,

OKENA_STATUS_ICC_INVALID_PAYLOAD_SIZE = 2006,

OKENA_STATUS_ICC_INVALID_VERSION = 2007,

OKENA_STATUS_ICC_INVALID_COMP_ID = 2008,

OKENA_STATUS_ICC_INVALID_PAYLOAD = 2009,

OKENA_STATUS_GROUP_DOES_NOT_EXIST = 2010,

OKENA_STATUS_INVALID_REGISTRATION_PARAMS = 2011,

OKENA_STATUS_HOST_HAS_REGISTERED_BEFORE = 2012,

OKENA_STATUS_INVALID_CONTACT_INFO = 2013,

OKENA_STATUS_HOST_NOT_REGISTERED = 2014,

OKENA_STATUS_MISSING_CONTACT_INFO_PARAMS = 2015,

OKENA_STATUS_INVALID_REGISTRATION_ID = 2016,

OKENA_STATUS_ICC_INVALID_BYTE_ORDER = 2017,

OKENA_STATUS_ICC_NOT_INITIALIZED = 2018,

OKENA_STATUS_COMP_CONFIGURED = 2019,

OKENA_STATUS_UNDEFINED_MGMT_SERVER = 2020,

OKENA_STATUS_HTTP_TRANSACTION_FAILED = 2021,

OKENA_STATUS_ICC_INVALID_HANDLE = 2022,

OKENA_STATUS_SERVER_IS_REACHABLE = 2023,

OKENA_STATUS_HTTP_TIMEOUT = 2024,

OKENA_STATUS_ICC_NO_CONNECT_MUTEX = 2025,

OKENA_STATUS_FORCE_POLLING_NOW = 2026,

OKENA_STATUS_REGISTRATION_REJECTED = 2027,

OKENA_STATUS_LOAD_CONFIG = 2028,

OKENA_STATUS_DB_ERROR = 2029,

OKENA_STATUS_LICENSE_REACHED_LIMIT = 2030,

OKENA_STATUS_REGISTRATION_NOT_ALLOWED = 2031,

OKENA_STATUS_NOT_ALLOWED_TO_STOP_AGENT = 2032,

OKENA_STATUS_CLIENT_UI_NOT_ALLOWED = 2033,

OKENA_STATUS_FAILED_TO_PRINT_AGENT_REPLY = 2034,

OKENA_STATUS_INVALID_LICENSE = 2035,

OKENA_STATUS_TIMED_OUT = 2036,

OKENA_STATUS_REGISTRATION_BACKOFF = 2037,

OKENA_STATUS_TESTMODE_ON = 2038,

OKENA_STATUS_TESTMODE_OFF = 2039,

OKENA_STATUS_INVALID_SERVER_FQDNS = 2040,

OKENA_STATUS_INVALID_SERVER_IPADDR = 2041,

OKENA_STATUS_SERVER_DNS_NOT_RESOLVABLE = 2042,

OKENA_STATUS_SERVER_IPADDR_NOT_OWN = 2043,

OKENA_STATUS_SERVER_DNS_NOT_OWN = 2044,

OKENA_STATUS_SERVER_NAME_NOT_FQDNS = 2045,

OKENA_STATUS_FAILED_OPEN_PROCESS = 2046,

** please rate if this helps**

New Member

Re: Host not registering with the Management Center

Do you have an eval or fully licensed version of the MC? If it's an eval, the MC only comes with eval server agents, not host agents. If there's no valid license for the host on the MC, it won't register.

I recently ran into this issue.

Hope it helps.

Blue

Re: Host not registering with the Management Center

The fully licensed version of the CSAMC is the same way.

If I remember correctly, the last version to come with 10 desktop licenses was 4.0.

Now they come with three server agents only.

Tom

New Member

Re: Host not registering with the Management Center

Hi Mike,

Make sure the MC is accepting hosts from anywhere.

Also make sure you ahve the mc in DNS or in the agents hostfile.

usually the simple host file entry fixes everything.

Also the agent kit has to be from the csa-mc and cannot be used on any other csa-mc.

145
Views
10
Helpful
6
Replies