Cisco Support Community
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

IDM failed

Dear Cisco

I made a first setup of Cisco AIP-SSM 20 IPS modules for ASA. Then i tried to connect by https to make a first configuration but during the process i receive next message:

Your correct Java memory heap size is less than 256 MB. You must increase the Java memory heap size before launching IDM. Click help for information on changing the the Lava memory size.

I did everthing according to  help section:

a. Click Java.

The Java Control Panel appears.

b. Click the Java tab.

c. Click View under Java Applet Runtime Settings.

The Java Runtime Settings Panel appears.

d. Type -Xmx256m in the Java Runtime Parameters field and then click OK.

e. Click OK and exit the Java Control Panel.

But result is negative. Can you please help me to solve this problem.

Thanks for help,

BR, Maxim

Cisco Employee

Re: IDM failed


Mike here, Couple of important questions,

What is the version of IPS you are running?

What is the java version that you are currently Using?

Are you able to launch it from another PC?

Depending on the java version you may need to do a downgrade or upgrade the IPS version in order to work properly



Community Member

Re: IDM failed

Hi Mike,

IPS version 6.0(3)E1

Java version platform - 1.6,   product - 1.6.0_22

I can't run it from other PC and I also have the same mistake when i am trying to run it from ASDM GUI (Configuration--->IPS)

It seem to me that I am realy need to make downgrade of JAVA. What version I need?

Best regards,


Cisco Employee

Re: IDM failed


Well I wouldnt say go and do a downgrade to the Java, I would recommend you to do an upgrade on the IPS. The version that you are running is very old and there is no more signature updates for the engine that you are running. (E1). Would you please go ahead and upgrade the IPS say 7.0.4 E4? That is the latest.

Let me know.


Community Member

Re: IDM failed

Really the version is very old and I need to make an upgrade. Can I download new version without service contract? In December i will buy IDS 4255, with service contract, should i wait or you can assist me with upgrade now?

Thank you!

CreatePlease to create content