Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Bronze

IME duplicate devices?

I just replaced my PC, and reloading all monitoring software. I loaded IME 6.x, and added 3 devices (ASA AIM-20 Primary and Failover, 4240 sensor).

Then, I remembered there was a newer version (7.0.3), so I downloaded that version, and installed. Everything looked good (software did an uninstall of the old version, then reinstall of the new version), but when I started the IME, there were NO devices listed.

I "added" the devices with no issues, but now the "Event Monitoring" shows both the "Old" and the "New" devices. (I "Named" the devices differently when adding the second time, "AIP-SSM-20 Primary" originally, and "5540-Primary" the second time.) How can I "fix" this issue, other than a full Uninstall and Reinstall of the software?

sensor.jpg

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: IME duplicate devices?

There are a couple of options really. The first option would be to adjust the event monitoring to filter for only the sensor names that you want to see. This can be done from IME under Event Monitoring->Filter->Other Parameters->Sensor names. This will enable you to filter the events for only the sensors that you want. The other option would require you to remove all the old event data. To do this you would need to close IME and stop the IME service. Once this is done you can go to the following location (if installed in the default directory) and delete the contents of the alarmDB directory.

C:\Program Files\Cisco Systems\Cisco IPS Manager Express\MYSQL\data\alarmDB

Once the above is done then you should be able to start the IME service again and the old data should be removed.

5 REPLIES
Cisco Employee

Re: IME duplicate devices?

There are a couple of options really. The first option would be to adjust the event monitoring to filter for only the sensor names that you want to see. This can be done from IME under Event Monitoring->Filter->Other Parameters->Sensor names. This will enable you to filter the events for only the sensors that you want. The other option would require you to remove all the old event data. To do this you would need to close IME and stop the IME service. Once this is done you can go to the following location (if installed in the default directory) and delete the contents of the alarmDB directory.

C:\Program Files\Cisco Systems\Cisco IPS Manager Express\MYSQL\data\alarmDB

Once the above is done then you should be able to start the IME service again and the old data should be removed.

Bronze

Re: IME duplicate devices?

Thanks! That is close to what I had figured already, you helped clear up exactly where to look. The monitor looks a lot better now...

Bronze

Re: IME duplicate devices?

Just an update in case anyone else comes across a similar issue:

I am running Windows 7, and the IME will NOT show the devices if I run it under my User account, even though I am an "Administrator" on the machine.

ONLY when I select "Run as Administrator" on startup will it show all the devices.

Cisco Employee

Re: IME duplicate devices?

FYI, you indicated you are running IME 7.0.3, but IME 7.1.1 was the first (and currently is the latest) version of IME to support MS Windows 7. Per the Release Notes:

"

IME 7.1.1 has the following new features:

• Support for Windows 7

• Support for Windows Server 2008

"

-and-

"If you are using Windows 7 or Windows Server 2008, uninstall any earlier version of IME before upgrading to IME 7.1.1."

I am not sure if that is the cause behind you needing to "Run as Administrator", but moving to IME 7.1.1 would be advisable since it's the first/only IME release to be supported on MS Windows 7 (the prior releases encounter problems).

Bronze

Re: IME duplicate devices?

Not to complain, but "IME 7.1.1, release date Feb 14, 2011".... I posted this original question in July 2010.

How long has W7 been in production release?

I am downloading the upgrade now....

Russ

554
Views
0
Helpful
5
Replies
CreatePlease to create content