Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IOS upgrade error using RME Software Management.

Hi.

I am trying to upgrade IOS of a Router device (3845) using RME 3.5 (CiscoWorks VMS 2.3). It always fail. The error is the next:

Starting Job: ID - 37

Owned by : admin

Job description: Upgrade Job.

Results e-mailed to : Not specified

Time created : 12 Dec 2005 17:39:30 CST

Scheduled time : 12 Dec 2005 17:39:29 CST

Total number of devices in the job: 1

Reboot devices immediately after download : no

Update boot commands in config file: yes

Back up current running image: no

Stop if error detected : no

Use Tftp Fallback for Image Boot : no

Job running on : MXOCCCWK02 (10.26.26.132)

Tftp Root Directory : e:\PROGRA~1\CISCOW~1\tftpboot

Processing Device : 10.26.26.36 (#1 of 1)

Start Time : 12 Dec 2005 17:41:12 CST

Running System S/W : 12.4(3a) IP

Upgrading System S/W : 12.4(2)T1 IP|FIREWALL|VOICE|PLUS|SSH|3DES

Bootldr upgrade not selected or not applicable

Device cannot be locked for exclusive write access.

Software Upgrade cannot be performed on the device

Error Info Code: '4059'

Message: 'Device cannot be locked for exclusive write access. '

Action/Reason: 'Job Manager returned error: Error Code: 1 Message: Error

during authentication:1

. Problem Cause: Device may be used by another

Resource Manager Essentials application.

Recommended Action: Please retry the operation later. If the

problem persists, contact your technical support representative for

assistance.'

Image Upgrade Failed

End Time : 12 Dec 2005 17:41:17 CST

Time Taken: 5 secs

Job encountered error. Job aborted.

End of Job

I don´t have any job pending in Net Config or Config Editor. I tried with other device and the issue is the same. I erased the devices. Next, I added the devices and I tried again and the error appears again.

The flash of the devices has enoguh free memory. I don´t have tftp blocked. The tftp service of CiscoWorks is running. I can backup (add image) the IOS of the device using RME, but the upgrade with RME always fail.

Someone know what is happening?

Thanks.

1 REPLY
Silver

Re: IOS upgrade error using RME Software Management.

If your OS is Windows, try the following:

Close all CW sessions

Go to C:\program files\CSCOpx\bin

type the following commands:

net stop crmdmgtd

perl dbpasswd.pl dsn=cmf encryption=yes npwd=c2ky2k

net start crmdmgtd

Wait for 5 minutes for the processes to start properly

Now, go to RME -> Administration -> Software Management -> Edit Preferences

Put check mark on 'turn debugging on'

Try the job again.

277
Views
0
Helpful
1
Replies