Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

IPS mainAPP not running

Dear Cisco,

I have a problem with my IPS 4240 from (IPS-4240-K9-sys-1.1-a-5.1-5.img) to (IPS-4240-K9-sys-1.1-a-5.1-5-E1.img) but after the installation

my IPS started giving me the attached report pleasefor more details, i followed the README.txt for the installation:

green highlight means installed.

red highlight means could not be installed.

The following files are included as part of this release:

Readme Files

- IPS-5.1-5-E1.readme.txt

- IPS-engine-E1-req-5.1-5.readme.txt

Engine Update Files

- IPS-K9-engine-E1-req-5.1-5.pkg installed

- IPS-CS-MGR-engine-E1-req-5.1-5.zip couldn?t be installed

IPS 5.1-5-E1 Service Pack Files

- IPS-K9-5.1-5-E1.pkg couldn?t be installed

- IPS-CS-MGR-K9-5.1-5-E1.zip couldn?t be installed

System Image Files

- IPS-4240-K9-sys-1.1-a-5.1-5-E1.img couldn?t be installed

Recovery Images

- IPS-K9-r-1.1-a-5.1-5-E1.pkg installed

ISO Image

- IPS-K9-cd-1.1-a-5.1-5-E1.iso couldn?t be installed

Please i need your help ASAP.

BR,

Tareq Fkhideh.

CCSP,CCNP Certified.

5 REPLIES
Cisco Employee

Re: IPS mainAPP not running

The .img file will remimage the sensor to that version leaving the sensor with factory config defaults (normally this is done by interrupting the bootup and using rommon to tftp the .img file to the sensor). The .zip file is only used by VMS/MC or CSM to upgrade a sensor. The .pkg file is for upgrading a sensor from an older version and preserving the pre-upgrade sensor config using CLI or IDM.

If you reimage (.img) to 5.1(5)E1 then you are done. The other packages are of no use.

However, if you were at 5.1(4) and you wanted to upgrade your sensor, then you would use either IPS-K9-5.1-5-E1.pkg (CLI, or IDM) or IPS-CS-MGR-K9-5.1-5-E1.zip (MC or CSM). This would upgrade your sensor to 5.1(5)E1.

If you were at 5.1(5) and no engine level (could consider this to be E0) then you can apply the engine update: IPS-K9-engine-E1-req-5.1-5.pkg (CLI or IDM) or IPS-CS-MGR-engine-E1-req-5.1-5.zip (MC or CSM). This would upgrade your sensor to 5.1(5)E1

Community Member

Re: IPS mainAPP not running

Firstly thank you for helping....

Ok it is great but sensore only give me to enter following:

username:

Password:

after that my big problem starts.... that i could not use IDM or CLI because the sensor give me this message:

((((((( Error: Cannot communicate with mainApp (getVersion). Please contact your system administrator.

Would you like to run cidDump?[no]: yes

Transfer file to remote server or display to screen?[transfer]: display ))))))))

and at finish it is again give me the re-enter username and password only with out entering CLI or IDM.

i don't know what i need to do.

BR,

Cisco Employee

Re: IPS mainAPP not running

I looked at the cidDump output. I saw some networkAccess device errors:

nac[339] Cid/E errTransport Net Device offline at address ...

There were three NAC devices that the sensor had communication problems with.

I would suggest looking that the connectivity to these devices. Then reboot the sensor. If you still cannot log into CLI then you will need to open a Cisco TAC case to investigate further.

Community Member

Re: IPS mainAPP not running

i tried to use hyper teminal there is the same problem with same error message i think it is difficult to solve....yes?

Cisco Employee

Re: IPS mainAPP not running

This may be a NAC configuration issue or a new bug (or combination), but it will not be difficult to solve. Please open up a Cisco/TAC case and they will help you troubleshoot the issue.

1143
Views
0
Helpful
5
Replies
CreatePlease to create content