Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

MARS communicating w/ IPS via SSL/TLS

testing connectivity after adding a IPS 4240 to the Mars gives an error: PN-0001:PnLogger message map not initialized. This seems to have an issue with the setup of communication using https, but I can https to the IPS from other stations.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: MARS communicating w/ IPS via SSL/TLS

If your sensor is 6.1 then this is a cosmetic issue. 6.1 is not officially supported. Have a look at this thread:

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=MARS&topic=Discussions&topicID=.2cc04749&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cc0e637

Please rate if helpful.

Regards

Farrukh

6 REPLIES

Re: MARS communicating w/ IPS via SSL/TLS

Try adding the trusted key of the MARS in IPS. Make sure MARS is added in the access-list of permitted IPs on the sensor (a simple way to test this is to ping the sensor from the MARS cli).

Regards

Farrukh

Community Member

Re: MARS communicating w/ IPS via SSL/TLS

the MARS is in place as a trusted host certificate.

Re: MARS communicating w/ IPS via SSL/TLS

Double check your login credentials entered in MARS, check the ACL, try deleting and re-adding the sensor in MARS.

Regards

Farrukh

Community Member

Re: MARS communicating w/ IPS via SSL/TLS

I have tested the login credentials by logging into the IDM successfully from my laptop.

The ACL has the MARS IP address specifically allowed.

I have already deleted and re-added the device.

From the CLI of the MARS:

[pnadmin]$ telnet 172.16.155.253 443

Trying 172.16.155.253...

Connected to 172.16.155.253.

Escape character is 'off'.

This then will timeout. But it appears the connection occurs.

thanks in advance for your assistance.

Re: MARS communicating w/ IPS via SSL/TLS

Do one thing, just simply ignore the 'test connectivity' bit and let the IPS sensor be added to MARS. Then see if you receive events from it.

Regards

Farrukh

Re: MARS communicating w/ IPS via SSL/TLS

If your sensor is 6.1 then this is a cosmetic issue. 6.1 is not officially supported. Have a look at this thread:

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=MARS&topic=Discussions&topicID=.2cc04749&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cc0e637

Please rate if helpful.

Regards

Farrukh

290
Views
0
Helpful
6
Replies
CreatePlease to create content