Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Troubleshooting "AnalysisEngine is currently busy"

Greetings all. I have a 4215 appliance running 5.0(5)S203.0. I'm attempting to apply IPS-K9-min-5.1-1a.pkg via the 'upgrade' CLI command but keep receiving the "AnalysisEngine is currently busy and unable to process this update. Please wait several minutes before attempting update again." message. I've tried this several times over two days.

The 4215 is running in traditional IDS mode and it's monitoring interface is seeing very little tcp/udp traffic.

- A 'show events alert' shows no events

- A 'top' from the OS level shows the mainApp process using almost no CPU or memory

Anyone have ideas on the best way to troubleshoot this?

  • Intrusion Prevention Systems/IDS
4 REPLIES
New Member

Re: Troubleshooting "AnalysisEngine is currently busy"

Just a quick update for folks...

I stopped and restarted all processes via /etc/init.d/cids stop|start and the update took.

Still curious why Analysis Engine was busy for 2+ days..

New Member

Re: Troubleshooting "AnalysisEngine is currently busy"

Check for an patch update, I ran IDS-K9-PATCH-4.1-4g this correct the problem with the Ana eng.

New Member

Re: Troubleshooting "AnalysisEngine is currently busy"

Thanks for the reply.

The 4215 sensor is actually running v 5.0...

New Member

Re: Troubleshooting "AnalysisEngine is currently busy"

This is other problem that i have, anyone knows what happen. I installed 5.1.1d version.

thanks

202
Views
0
Helpful
4
Replies