Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Upgrading from 5.1(7) E1 to 6.1

I know I need to upgrade to 6.0(1)E1 then to 6.1, but in the instructions say to do the upgrade via the CLI. This isn't a problem, but I was wondering if I can do the upgrade via the ASDM through the IPS update sensor instead.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Upgrading from 5.1(7) E1 to 6.1

Looks like you have SNMP enabled on your sensor.

In version 5.1 the community strings had default values, but this was considered a possible vulnerability since the community strings are considered as passwords. So in version 6.0 and above there are no more default values for the community strings.

If you are not using SNMP then just disable it, and try the upgrade again.

If you do use SNMP, then decide what community strings you want to use specifically for your site, and configure them on the 5.1 sensor.

(NOTE: If you want to keep the default values, then just type the actual values into the field using the CLI. They will then be considered user configured, and can be carried forward into version 6.0).

Once your community strings are configured then try the upgrade again.

3 REPLIES
Cisco Employee

Re: Upgrading from 5.1(7) E1 to 6.1

Yes you can update through ASDM (or IDM).

But you do not have to upgrade to 6.0(1)E1 first.

So long as your sensor is version 5.0(1) or higher, you can upgrade directly to 6.1(1)E1 with the "upgrade" file:

IPS-K9-6.1-1-E1.pkg

http://www.cisco.com/cgi-bin/tablebuild.pl/ips6

New Member

Re: Upgrading from 5.1(7) E1 to 6.1

When I do the upgrade I get the follwoing error. See attachment.

Cisco Employee

Re: Upgrading from 5.1(7) E1 to 6.1

Looks like you have SNMP enabled on your sensor.

In version 5.1 the community strings had default values, but this was considered a possible vulnerability since the community strings are considered as passwords. So in version 6.0 and above there are no more default values for the community strings.

If you are not using SNMP then just disable it, and try the upgrade again.

If you do use SNMP, then decide what community strings you want to use specifically for your site, and configure them on the 5.1 sensor.

(NOTE: If you want to keep the default values, then just type the actual values into the field using the CLI. They will then be considered user configured, and can be carried forward into version 6.0).

Once your community strings are configured then try the upgrade again.

130
Views
0
Helpful
3
Replies