Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Upgrading the CSA on hosts

IS there a clean upgrade of the client from 4.0.3 to 4.5? Does the v 4.0.3 client need to be uninstalled before 4.5 is installed?

Same question for 4.5 to 5.0? How evasive are these client upgrades?

Thanks,

CB

3 REPLIES
Blue

Re: Upgrading the CSA on hosts

Use the migration tool if you are going from 4.0.3 to 4.5 or 5.0. It can either be on the same or a different server. You don't need to uninstall the old client to install the new one.

The first time you upgrade, the 4.0.3 host will need to restart, but after that you can do truly silent upgrades.

New Member

Re: Upgrading the CSA on hosts

Thanks.

New Member

Re: Upgrading the CSA on hosts

Please refer to the Migration section in the ?Installing Management Center for Cisco Security Agents? document found here:

http://www.cisco.com/en/US/products/sw/secursw/ps5057/products_installation_guide_chapter09186a00805aebef.html#wp1000164

Copied from the guide:

??If you're installing CSA MC V5.0 on the same machine running V4.5 or V4.0.x, an xml file containing V4.5 or V4.0.x configuration items and several .dat files containing host information are automatically generated by the installation and ready for importing once the install is complete.

?If you're installing CSA MC V5.0 on a different machine from the system running MC V4.5 or V4.0.x, after installing V5.0, you must copy and manually run an executable file on the V4.5 or V4.0.x machine to create the xml and dat files needed for importing V4.5 or V4.0.x configuration and host information to V5.0. ?

As far as upgrading the CSA agents on the systems, uninstallation is NOT necessary. Installing V5.0 on top of V4.X should be smooth as Tom said.

You can either download and run the agent kit on the target system, Schedule a Software update from the V4.0.x or V4.5 MC server (after running prepare_40_migration.exe on that server), or use SMS or other technologies to install the new V5.0 agent package.

Hope that helps :)

Faisal

132
Views
4
Helpful
3
Replies
CreatePlease to create content