Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WS-SVC-IDS upgrade error

Hello!

I am trying to update WS-SVC-IDS from 4.1 to 5.0(1).

The output:

s(config)#upgrade ftp://x.x.x.x/IPS-K9-maj-5.0-1e-S149.rpm.pkg

User: abc

Password: ****

Warning: Executing this command will apply a major version upgrade to the application partition. The system may be rebooted to complete the upgrade.

Continue with upgrade? :

% Please answer 'yes' or 'no'.

Continue with upgrade? : yes

I get the following error:

Error: idsPackageMgr: digital signature of the update file was not valid, use CCO to replace corrupted file

Can anyone help me please?

Thank you!

4 REPLIES
Cisco Employee

Re: WS-SVC-IDS upgrade error

Lets start with the obvious. Does the md5 sum of your download match what is on CCO?

This might be bug CSCsd17267 where the sensor runs out of disk space to fully decrypt and decompress the update file. As a workaround to that, Log in to the sensor via the service account and remove the files in the following directory:

/usr/cids/idsRoot/var/updates/backups/*

Cisco Employee

Re: WS-SVC-IDS upgrade error

My guess is that the parentheses in the hostname are causing this failure. We are aware of the slash character in the hostname causing a similar issue. Remove the open and close parenthesis characters from your hostname and re-try the upgrade.

Cisco Employee

Re: WS-SVC-IDS upgrade error

Disregard the comment about the parenthesis - I misread your example. They are illegal characters for a sensor hostname anyway.

However, it is true that a slash in the hostname will cause this same upgrade error.

New Member

Re: WS-SVC-IDS upgrade error

The image is according to CCO. I have no files in /usr/cids/idsRoot/var/updates/backups/*.

An output of df command shows that

/dev/hdc1 mounted on / has 357M available and /dev/hdc2 mounted on /usr/cids/idsRoot/var has 12G available.

But the show version command in admin mode shows 97% memory usage, almost 2G.

I restarted the moduled, the memory usage is 5%, the upgrade still doesn't work. The same error.

Thank you!

356
Views
0
Helpful
4
Replies