Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

2 Branch routers, where do we configure SRST?

I have uploaded the overall topology to the SRST Scenario.ppt doc

we currently have two routers per branch to provide redundancy for WAN connection on the major sites and we are looking to provide the PSTN connections to both routers through PRIs.

DHCP for the phones is planned to be configured on the switch stack that is going to be the default gateway for the IP Phones.

The big question is: where do we configure SRST????

I guess we will need to configure two MGCP gateways per office for the PRIs on separate routers, and the Dial Peers for failover have to be in both routers, etc…

BUT! In which router do we configure the SRST?

What other considerations do we need to think about for these two routers Branch sites?

Thank you very much,

15 REPLIES
Hall of Fame Super Silver

Re: 2 Branch routers, where do we configure SRST?

Hello Luisa,

Configure SRST on both in case of failure the phones will register to the HSRP VIP owner.

Using HSRP interface tracking and or object tracking the HSRP active role is of the branch router with the best connections.

On CCM configure to use default gateway as SRST reference

Hope to help

Giuseppe

Re: 2 Branch routers, where do we configure SRST?

One further consideration is the number of endpoints or IP Phones you have at your major remote offices which will require registering to SRST? This will determine how you deploy SRST.

Each platform or gateway has a certain constraints when it comes to the number endpoints that can register.

The following URL lists the supported gateways and the maximum number of sccp/sip phones it can support.

http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/requirements/guide/srs43spc.html

For example, if your remote office has 200 phones, and you have two 2851 MGCP gateways, then each will have to be configured as a seperate SRST reference in order to support 100 phones on each.

Rgds

Allan.

New Member

Re: 2 Branch routers, where do we configure SRST?

we have two 3845 routers per branch and 150 ip phones per branch.

About registering with HSRP, does the ip HRSP stanby router will get to active mode when the VIP HSRP router goes down or when the WAN connection on that router goes down?

Re: 2 Branch routers, where do we configure SRST?

You can effectively rely on both, it is possible to track the WAN interface so that in the event it goes down it decrements the priority so that the standby will the become active.

The principle still remains the same if either router goes down. Both gateway communicate or exchange hellos packets if three of these packets are missed the standby will transition to active.

Refer to the following URL regarding HSRP FAQs:-

http://www.cisco.com/en/US/tech/tk648/tk362/technologies_q_and_a_item09186a00800a9679.shtml#q3

New Member

Re: 2 Branch routers, where do we configure SRST?

Lets say that we configure HSRP with SRST on router 1 and router 2

The switch-stack in the middle of those routers (as in the figure) is the default-gateway for the ip phones.

We configure that default-gateway to be the SRST reference on the CCM.

If router 1 losses connection to WAN, then router 2 will take over and it will immediately register the ip phones on SRST?

Because at that moment as router 2 is also connected to the WAN, it will be able to access the CCM over the WAN, because the default-gateway (switch stack) will still be able to access the CCM, so what happens with HSRP in this moment?

The other scenario could be that if the WAN LINK on Router 1 is down, and WAN Link in Router 2 is up, as the default-gateway can still get to the CCM, ip phones would still be registered to CCM. If the second WAN link goes down and default-gateway cannot get to CCM, How do we say the default gateway to get to SRST mode and on which router?

Re: 2 Branch routers, where do we configure SRST?

Could you kindly post the ppt diagram, it is not visable on the thread.

Thanks

Allan.

New Member

Re: 2 Branch routers, where do we configure SRST?

Here is the ppt scenario.

Thank you for your help

New Member

Re: 2 Branch routers, where do we configure SRST?

Hello!

Definitely we don't want to do HSRP/SRST because we would be “wasting” the standby PRI on the backup router.

Therefore, the default gateway would be the switch stack. As switch stack is the one keeping the keepalive with CCM,

Where do we put SRST?

Thanks

Hall of Fame Super Silver

Re: 2 Branch routers, where do we configure SRST?

Hello Luisa,

in your scenario you will configure the SRST to be the HSRP VIP and you need to put all phones in the same device pool so to inherit this setting.

the usage of use the default GW as SRST is for a simpler scenario where def GW = SRST capable router(s).

Here it is different I hadn't understood the stack was a layer3 device.

By tracking the WAN interface, if at least one router has a live connection it will be the VIP owner, but also it will be able to route to CCM phones keepalives that will not try to register to the SRST reference until they see CCM answers.

If all wan links are down / or CCM cluster is not reachable the HSRP VIP owner will start to receive phones registrations (are the phones to start the fallover) and will serve them as per its configuration.

Each router c3845 can serve 720 phones so you are fine

Hope to help

Giuseppe

New Member

Re: 2 Branch routers, where do we configure SRST?

Thank you for your comments Giuseppe.

The rest of the network team doesn't want to use HSRP.

They say, we cannot afore to have stanby router and PRI connections to PSTN just waiting for failover.

That's were it plays the switch stack on L3.

We are assuming that we are going to L3 on the switch stack and configuring the Switch to be the default-gateway and DHCP for the phones.

Supposing this, the switchstack should be the one keeping the “keepalive” messages with callmanager.

Is this possible?

How do I do this?

New Member

Re: 2 Branch routers, where do we configure SRST?

Hello Guys!

All the team was talking about this subject today.

We decided the following:

We will continue to use Routing EIRG solution for the branches with both routers on the Data point of view.

For voice, we are going to do HSRP/SRST, based on your recommendation; the tracked interfaces for HSRP will be a Voice VLAN L3 where the standby interface will be configured.

The SRST reference on CallManager will be pointed to the standby ip address.

Do you think this is a good idea?

Do you have further recommendation based on this design approach?

Thanks in advance,

Luisa

Re: 2 Branch routers, where do we configure SRST?

Tracking the SVI for the Voice VLAN will not give the results or achieve the fail-over that you are looking for.

The SVI will remain active for as long as there are members within the Voice VLAN.

The SRST Reference should be the VIP for the Voice VLAN across both SR1 and SR2 not the switch stack.

This can be achieved by configuring the router interfaces facing the LAN on SR1 and SR2 as trunk interfaces with a sub-interface for both the voice and data vlans.

This will provide you with a default gateway for both, you can also have SR1 active for Data and SR2 for Voice.

Using HSRP tracking for the Active HSRP instance for both VLANs in the event that the WAN interface goes down.

This will ensure that the forwarding HSRP instance for the Voice-VLAN will transition to the other gateway or vice-versa:-

SR1:

interface FastEthernet0/0

description Branch Office Switch

no ip address

!

interface FastEthernet0/0.1

description Data-VLAN

encapsulation dot1Q 10

ip address 192.168.1.2 255.255.255.0

standby 1 ip 192.168.1.1

standby 1 priority 110

standby 1 preempt

standby 1 track Serial0/0

!

interface FastEthernet0/0.2

description Voice-VLAN

encapsulation dot1Q 20

ip address 192.168.2.2 255.255.255.0

standby 2 ip 192.168.2.1

standby 2 priority 105

standby 2 preempt

SR2:

interface FastEthernet0/0

description Branch Office Switch

no ip address

!

interface FastEthernet0/0.1

description Data-VLAN

encapsulation dot1Q 10

ip address 192.168.1.3 255.255.255.0

standby 1 ip 192.168.1.1

standby 1 priority 105

standby 1 preempt

!

interface FastEthernet0/0.2

description Voice-VLAN

encapsulation dot1Q 20

ip address 192.168.2.3 255.255.255.0

standby 2 ip 192.168.2.1

standby 2 priority 110

standby 2 preempt

standby 2 track Serial0/0

!

Rgds

Allan

Hall of Fame Super Silver

Re: 2 Branch routers, where do we configure SRST?

Hello Allan and Luisa,

I strongly agree with Allan response and suggestions ; tracking the Voice Vlan SVI is meaningless for achieving fault-tolerance.

Using LAN subifs on the routers is the correct choice because only the devices with PSTN links can play the role of SRST gateways.

So the stack can be used as L2 switch.

Hope to help

Giuseppe

Re: 2 Branch routers, where do we configure SRST?

Follow up post to see if you have been successful in implementing HSRP for your SRST remote office?

Were my suggestion of any assistance?

Rgds

Allan.

New Member

Re: 2 Branch routers, where do we configure SRST?

Hello Everyone,

Thank you very much for your recommendations!

very very helpfull!!!

I'm setting a LAB to test the final suggestions before going to production.

I will let you know the results!

362
Views
0
Helpful
15
Replies
CreatePlease to create content