Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2901 vs 2600 - Alcatel Forwarding Issue

Hello,

I have been battling with this issue for a month now and I am completly stumped, I would appreciate some help or advice.

For quite some time I have been running a VoIP PBX that was linked to an Alcatel 4400 PBX via two 2600 routers on an E1 link over 100MB fibre.  THis worked flawlessly

I have now upgraded these to 2901 routers over a 1Gb fibre.  I still have the 2600 in place with a different link to the Alcatel to provide redundancy.

I have an issue in the way that the Alcatel applies a forward, I have narrowed it down to it being something wrong or missing in the 2901 config.

For example - The 2600 routers have an extension range of 2xxx and the 2901 routers have the range 3xxx.

If someone on an Alcatel extension sets a forward to a 2xxx extension, the system gives a fraction of a second ring upto the Voip PBX (causing the end phone to give a little ring) then it hangs up and accepts the forward (all within a split second)

If someone on an Alcatel extension sets a forward to a 3xxx extension, the system rings the 3xxx extension indefinatly.  THe Alcatel system only accepts the forward if the person on the 3xxx phone picks up then hangs up.

If I swap the links from the Alcatel to the routers (3xxx to 2xxx etc) the fault moves. This proves it has nothing to do with the Alcatel or the VoIP PBX but a misconfiguration in one of the 2901 routers.  It's as if the Alcatel is not receiving something back from the remote router (but it is with the 2600's).  As far as I can tell all routers are configured identical.

I have spent many hours with our Alcatel engineer and we've all came to the conclusion that it's an issue on the 2901 routers.

Can someone please advise? (I'm starting to pull my hair out!)

I can post configs if necessary.

Thanks

Everyone's tags (6)
6 REPLIES
Hall of Fame Super Gold

Re: 2901 vs 2600 - Alcatel Forwarding Issue

You explained the issue very well, unofortunately to work on it an Engineer needs more that that. E.g. call flows, configs, traces.

This is also the kind of issue you can have the TAC look at.

New Member

Re: 2901 vs 2600 - Alcatel Forwarding Issue

I though I would take it one step at a time and post the issue first, hoping that someone would come back with....you just need this line......

I'm not a voice expert so any help  appreciated.

Here is a call trace from the 2600 (The working link).  WIth this trace I see error messages, perhapy its the 2600 that has the issue but its a quirk that causes it to work.  Normal calls both ways are fine on all routers.

2w3d: ISDN Se1/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0019

        Sending Complete

        Bearer Capability i = 0xA880

                Standard = ISO/IEC

                Transfer Capability = Unrestricted Digital

                Transfer Mode = Circuit

                Transfer Rate = Packet - not specified

        Channel ID i = 0xAC

        Facility i = 0x9FAA06800100820100A12202022EF20201123019A5090A01001204353030300A0101A5090A0100120432303031

        Calling Party Number i = 0x0081, '5000'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '2001'

                Plan:Unknown, Type:Unknown

2w3d: ISDN Se1/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x8019

        Channel ID i = 0xAC

2600_A_ALCATEL#

2w3d: ISDN Se1/0:15 Q931: TX -> ALERTING pd = 8  callref = 0x8019

        Progress Ind i = 0x8188 - In-band info or appropriate now available

2w3d: ISDN Se1/0:15 Q931: RX <- STATUS pd = 8  callref = 0x0019

        Cause i = 0x80E200 - Message not compatible with call state or not implemented

        Call State i = 0x03

2w3d: ISDN Se1/0:15 **ERROR**: L3_ProcessEvent: UNEXPECTED event - 0x81 state 19

2w3d: ISDN  **ERROR**: Module-l3_sdl_u  Function-U19_BadMsg  Error-Bad message received.

2w3d: ISDN Se1/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x8019

        Cause i = 0x80E5 - Message not compatible with call state

2600_A_ALCATEL#

2w3d: ISDN Se1/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x0019

        Cause i = 0x809080 - Normal call clearing

2600_A_ALCATEL#

And this is the trace from the 2901 (with the issue)

May  1 08:06:32.306: ISDN Se0/1/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0072

        Sending Complete

        Bearer Capability i = 0xA880

                Standard = ISO/IEC

                Transfer Capability = Unrestricted Digital

                Transfer Mode = Circuit

                Transfer Rate = Packet - not specified

        Channel ID i = 0xAC

                Exclusive, Channel 45

        Facility i = 0x9FAA06800100820100A12202022EF20201123019A5090A01001204353030300A0101A5090A0100120433303031

        Calling Party Number i = 0x0081, '5000'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '3001'

                Plan:Unknown, Type:Unknown

C2901_A_ALCATEL#

May  1 08:06:32.310: ISDN Se0/1/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x8072

        Channel ID i = 0xAC

                Exclusive, Channel 101

May  1 08:06:32.334: ISDN Se0/1/0:15 Q931: TX -> ALERTING pd = 8  callref = 0x8072

        Progress Ind i = 0x8188 - In-band info or appropriate now available

May  1 08:06:32.354: ISDN Se0/1/0:15 Q931: RX <- STATUS pd = 8  callref = 0x0072

        Cause i = 0x80E200 - Message not compatible with call state or not implemented

        Call State i = 0x03

C2901_A_ALCATEL#

May  1 08:06:37.698: ISDN Se0/1/0:15 Q931: TX -> CONNECT pd = 8  callref = 0x8072

May  1 08:06:37.718: ISDN Se0/1/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x0072

May  1 08:06:38.238: ISDN Se0/1/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x8072

        Cause i = 0x9090 - Normal call clearing

May  1 08:06:38.278: ISDN Se0/1/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x0072

        Cause i = 0x809080 - Normal call clearing

C2901_A_ALCATEL#

This is a trace from the 2901 of a normal call going from Alcatel to VoIP

May  1 08:19:52.658: ISDN Se0/1/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0073

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA18382

                Preferred, Channel 2

        Calling Party Number i = 0x0081, '5000'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '3099'

                Plan:Unknown, Type:Unknown

        High Layer Compat i = 0x9181

        Locking Shift to Codeset 5

        Codeset 5 IE 0x32  i = 0x81

May  1 08:19:52.662: ISDN Se0/1/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x8073

        Channel ID i = 0xA98382

                Exclusive, Channel 2

C2901_A_ALCATEL#

May  1 08:19:52.690: ISDN Se0/1/0:15 Q931: TX -> ALERTING pd = 8  callref = 0x8073

        Progress Ind i = 0x8188 - In-band info or appropriate now available

May  1 08:19:52.694: ISDN Se0/1/0:15 Q931: TX -> CONNECT pd = 8  callref = 0x8073

        Connected Number i = 0x80, '3099'

May  1 08:19:52.722: ISDN Se0/1/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x0073

C2901_A_ALCATEL#

May  1 08:20:00.414: ISDN Se0/1/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x0073

        Cause i = 0x809080 - Normal call clearing

May  1 08:20:00.414: ISDN Se0/1/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x8073

May  1 08:20:00.446: ISDN Se0/1/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x0073

        Cause i = 0x809080 - Normal call clearing

C2901_A_ALCATEL#

Thanks

New Member

2901 vs 2600 - Alcatel Forwarding Issue

I've been doing more digging and it seems that the Alcatel is sending some form of data packet that the 2600 router does not fully understand hence dropping the call (which causes the forward to apply).  The newer 2901 passes that up the chain because the router at the other end see's this as SPEECH hence it rings the line indefinatly.

Bearer Capability i = 0xA880

                Standard = ISO/IEC

                Transfer Capability = Unrestricted Digital

                Transfer Mode = Circuit

                Transfer Rate = Packet - not specified

        Channel ID i = 0xAC

                Exclusive, Channel 45

        Facility i = 0x9FAA06800100820100A12202022EF20201123019A5090A01001204353030300A0101A5090A0100120

Is there a way to block or drop these unrestricted digital calls or to stop the router from passing them along? - Normal speech calls appear as this:

Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

Hall of Fame Super Gold

2901 vs 2600 - Alcatel Forwarding Issue

Why the PBX would send a data call to the 2600 and not to the 2901 ?

Anyway, when a normal codec g711u is configured, a data call cannot be sent to the terminating router, and you should never see it appear over there.

New Member

Re: 2901 vs 2600 - Alcatel Forwarding Issue

The 2901 is receiving exactly the same data call as the 2600.  The only difference is that the 2600 passes it along but sees an error and drops the call, the 2901 passes it along but there are no errors so the call keeps ringing.  THe end routers see the calls as normal speech calls and not unrestricted digital ones.  Here are my configs (from the 2600 and 2901 that are directly connected to the Alcatel switch):

2600:

version 12.4

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname 2600_A_ALCATEL

!

boot-start-marker

boot-end-marker

!

enable secret

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

voice-card 1

!

ip cef

!

!

!

!

no ip domain lookup

isdn switch-type primary-qsig

!

!

voice call send-alert

voice call convert-discpi-to-prog

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

fax protocol t38 ls-redundancy 3 hs-redundancy 0 fallback none

!

!

voice class codec 1

codec preference 1 g711ulaw

!

!

!

!

!

!

!

!

!

fax interface-type fax-mail

!

!

username privilege 15 secret

!

!

controller E1 1/0

pri-group timeslots 1-31

!

!

!

!

interface FastEthernet0/0

ip address 10.0.0.50 255.255.255.0

duplex auto

speed auto

no cdp enable

!

interface Serial1/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-qsig

isdn timer T203 30000

isdn timer T310 60000

isdn overlap-receiving T302 2000

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

router rip

network 10.0.0.0

!

no ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

dialer-list 1 protocol ip permit

no cdp run

!

!

control-plane

!

!

!

voice-port 1/0:15

!

!

!

!

!

dial-peer voice 1 voip

destination-pattern 20..

voice-class codec 1

session protocol sipv2

session target ipv4:10.0.0.51

session transport udp

!

dial-peer voice 5 pots

destination-pattern 9.+

direct-inward-dial

port 1/0:15

prefix 9

!

dial-peer voice 2 voip

destination-pattern 30..

voice-class codec 1

session protocol sipv2

session target ipv4:10.0.0.51

session transport udp

!

dial-peer voice 6 pots

destination-pattern 4...

direct-inward-dial

port 1/0:15

prefix 4

!

dial-peer voice 7 pots

destination-pattern 5...

direct-inward-dial

port 1/0:15

prefix 5

!

dial-peer voice 8 pots

destination-pattern 7...

direct-inward-dial

port 1/0:15

prefix 7

!

!

line con 0

exec-timeout 0 0

password

logging synchronous

login

line aux 0

line vty 0 4

password

logging synchronous

login

!

!

end

2901:

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname C2901_A_ALCATEL

!

boot-start-marker

boot-end-marker

!

card type e1 0 1

logging buffered 51200 warnings

!

no aaa new-model

network-clock-participate wic 1

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

no ip domain lookup

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-qsig

!

!

crypto pki trustpoint TP-self-signed-1161341155

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1161341155

revocation-check none

rsakeypair TP-self-signed-1161341155

!

!

crypto pki certificate chain TP-self-signed-1161341155

certificate self-signed 01

  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31313631 33343131 3535301E 170D3132 30323238 30313138

  32355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31363133

  34313135 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100D1D8 BF7C6C10 1A6E61B1 DF9CDBBA CE3272FF 45EAC510 70A0033C 045E4F51

  3F8D8A9A ADC2A9AC 2CD69A33 398C3C04 D63C23DF BE314AF9 4DC29B3A 224672A3

  890CF56B 2463440F 20D5E8EC 877925E2 DF27318F 40DE8E00 CD61F4F8 90C757EC

  815A79F4 AA5BE899 BFE12265 B0620937 80FE65E8 028CFFD6 9CFB964E BA3DC7B8

  32A90203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603

  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D

  301F0603 551D2304 18301680 148F66B2 3243A368 DAF4DC4F C26C83BC 4C451BEE

  58301D06 03551D0E 04160414 8F66B232 43A368DA F4DC4FC2 6C83BC4C 451BEE58

  300D0609 2A864886 F70D0101 04050003 818100AE 69703010 C12C298C F5F40F06

  E8BAA8D6 95D8C748 20EF5CDD D1B0E8C3 BDC1160F 90AD7094 9FCB2356 024EF74B

  8C3D93B7 F7E9C39B 9B995EF7 FF25C1EA 015DFB9F 5C74E3C2 E280821B 5ACCF2FD

  F61E54C4 115933F2 93FD82B1 2CE45196 8124B8B4 38FB3684 8DD8EEB2 9F6A6433

  A9CC0C6E 5732F6F4 85A5D088 25C1AA34 0EF535

        quit

voice-card 0

!

!

voice call send-alert

voice call convert-discpi-to-prog

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

fax protocol t38 ls-redundancy 3 hs-redundancy 0 fallback none

!

voice class codec 1

codec preference 1 g711ulaw

!

!

!

!

license udi pid CISCO2901/K9 sn FCZ160990PE

hw-module pvdm 0/0

!

!

!

username privilege 15 secret

!

redundancy

!

!

controller E1 0/1/0

pri-group timeslots 1-31

!

controller E1 0/1/1

!

!

!

!

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.0.0.52 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-qsig

isdn timer T203 30000

isdn timer T310 60000

isdn overlap-receiving T302 2000

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

router rip

network 10.0.0.0

!

no ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

dialer-list 1 protocol ip permit

!

no cdp run

!

!

control-plane

!

!

voice-port 0/1/0:15

!

!

!

!

dial-peer voice 1 voip

destination-pattern 30..

session protocol sipv2

session target ipv4:10.0.0.53

session transport udp

voice-class codec 1

!

dial-peer voice 5 pots

destination-pattern 9.+

direct-inward-dial

port 0/1/0:15

prefix 9

!

dial-peer voice 6 voip

destination-pattern 20..

session protocol sipv2

session target ipv4:10.0.0.53

session transport udp

voice-class codec 1

!

dial-peer voice 7 pots

destination-pattern 4...

direct-inward-dial

port 0/1/0:15

prefix 4

!

dial-peer voice 8 pots

destination-pattern 5...

direct-inward-dial

port 0/1/0:15

prefix 5

!

dial-peer voice 9 pots

destination-pattern 7...

direct-inward-dial

port 0/1/0:15

prefix 7

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

password 7

logging synchronous

login

line aux 0

line vty 0 4

privilege level 15

password 7

logging synchronous

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

end

Hall of Fame Super Gold

2901 vs 2600 - Alcatel Forwarding Issue

One would need to see the complete trace on originating and terminating routers, as well the cch323 trace.

978
Views
0
Helpful
6
Replies
CreatePlease login to create content