cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2208
Views
0
Helpful
8
Replies

2901 with HWIC-4ESW-POE

jeremybrainard
Level 1
Level 1

I have a 2901 (config snippets below) with an HWIC-4ESW-POE in Slot 0.  I also have other switches down stream off of g0/1.  The problem is that I can not get network devices (phones or computers) to work when I plug them in to the HWIC-4ESW-POE in Slot 0.  They work fine when I plug them into an actual switch, but will not obtain an IP Address when plugged into the switch module that is in the router.  Eventually, these ports will be used for IP Phones and possibly an IP Camera.

I'm sure it's something simple, but it seems I've tried everything I can think of.  Thanks in advance!

no ipv6 cef

ip source-route

ip cef

!

ip dhcp excluded-address 10.100.50.0 10.100.50.99

ip dhcp excluded-address 10.100.10.0 10.100.10.99

!

ip dhcp pool LAN

   network 10.100.50.0 255.255.255.0

   update dns

   domain-name jeremysbrain.local

   default-router 10.100.50.1

   dns-server 10.100.50.1 8.8.8.8

   option 150 ip 10.100.10.1

!

ip dhcp pool VOICE

   network 10.100.10.0 255.255.255.0

   default-router 10.100.10.1

   option 150 ip 10.100.10.1

   dns-server 10.100.10.1 8.8.8.8

!

ip domain name jeremysbrain.local

multilink bundle-name authenticated

!

vtp interface gi0/1

vtp version 2

!

redundancy

!

interface GigabitEthernet0/0

description WAN - Connected to cable modem

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/1

description LAN

no ip address

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/1.10

description VOICE

encapsulation dot1Q 10

ip address 10.100.10.1 255.255.255.0

ip helper-address 10.100.100.1

!

interface GigabitEthernet0/1.50

description DATA

encapsulation dot1Q 50

ip address 10.100.50.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface GigabitEthernet0/1.100

description MANAGMENT

encapsulation dot1Q 100

ip address 10.100.100.1 255.255.255.0

!

interface FastEthernet0/3/0

switchport voice vlan 10

!

interface FastEthernet0/3/1

shutdown

!

interface FastEthernet0/3/2

shutdown

!

interface FastEthernet0/3/3

shutdown

!

interface Vlan1

ip nat inside

ip virtual-reassembly in

!

router eigrp 100

network 10.100.0.0 0.0.255.255

!

ip default-gateway 10.100.10.1

ip forward-protocol nd

!

ip dns server

ip nat inside source list NAT interface GigabitEthernet0/0 overload

!

ip access-list extended NAT

permit ip 10.100.50.0 0.0.0.255 any

!

tftp-server flash:SDM_Backup

tftp-server flash:/cme/phones/7970-7971/apps70.8-5-4TH1-6.sbn alias apps70.8-5-4TH1-6.sbn

tftp-server flash:/cme/phones/7970-7971/cnu70.8-5-4TH1-6.sbn alias cnu70.8-5-4TH1-6.sbn

tftp-server flash:/cme/phones/7970-7971/cvm70sccp.8-5-4TH1-6.sbn alias cvm70sccp.8-5-4TH1-6.sbn

tftp-server flash:/cme/phones/7970-7971/dsp70.8-5-4TH1-6.sbn alias dsp70.8-5-4TH1-6.sbn

tftp-server flash:/cme/phones/7970-7971/jar70sccp.8-5-4TH1-6.sbn alias jar70sccp.8-5-4TH1-6.sbn

tftp-server flash:/cme/phones/7970-7971/SCCP70.8-5-4S.loads alias SCCP70.8-5-4S.loads

tftp-server flash:/cme/phones/7970-7971/term70.default.loads alias term70.default.loads

tftp-server flash:/cme/phones/7970-7971/term71.default.loads alias term71.default.loads

tftp-server flash:/cme/phones/7940-7960/P00308010200.bin alias P00308010200.bin

tftp-server flash:/cme/phones/7940-7960/P00308010200.loads alias P00308010200.loads

tftp-server flash:/cme/phones/7940-7960/P00308010200.sb2 alias P00308010200.sb2

tftp-server flash:/cme/phones/7940-7960/P00308010200.sbn alias P00308010200.sbn

!

control-plane

!

gateway

timer receive-rtp 1200

!

gatekeeper

shutdown

!

telephony-service

max-ephones 24

max-dn 48

ip source-address 10.100.10.1 port 2000

auto assign 40 to 48

load 7960-7940 P00308010200.loads

load 7970 SCCP70.8-5-4S.loads

load 7971 SCCP70.8-5-4S.loads

time-zone 5

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp 7960 Nov 20 2010 12:06:24

!

ephone-dn  1  octo-line

number 2001

name Physical

!

ephone-dn  2  dual-line

number 2002

label Virtual

name Virtual

!

ephone  1

description CIPC on Physical PC

mac-address 001A.92DA.C66C

type CIPC

button  1:1

!

ephone  2

description Virtual

mac-address 000C.298D.4D41

type CIPC

button  1:2

!

ephone  100

description Test

mac-address 0030.94C2.D30F

type 7960

!

ntp master

ntp server 209.81.9.7

8 Replies 8

Brandon Buffin
VIP Alumni
VIP Alumni

I'm assuming you are plugging the computer/phone into 0/3/0 as the other ports appear to be shut down. Are VLANs 10 and 50 configured on this device? You can issue "show vlans" to check. Assuming the VLANs are configured, you will need to remove the subinterfaces for Gig0/1 and move this to an SVI config. You can see an example of the config at the link below.

http://www.cisco.rw/en/US/prod/collateral/routers/ps5853/prod_white_paper0900aecd8064c9f4.pdf

Basically, you will have:

interface Vlan10

ip address 10.100.10.1 255.255.255.0

ip nat inside

interface Vlan50

ip address 10.100.50.1 255.255.255.0

ip nat inside

Hope this helps.

Brandon

Got it...

Never used SVI configs before.  Is it similar to using Sub-Interfaces?

You were correct, I did have the VLAN's configured on the router, and I was using Fa0/3/0.

I've adjusted the interfaces (configs below), but I'm still not routing traffic through the router.  I can't even ping the switch that's plugged into Gi0/1 at IP Address 10.100.100.15.  What should I do with Gi0/1;  Does it need an IP Address?

The link you sent was helpful, but slightly cryptic in regards to routing traffic, and actually using SVI.

Thanks Again!

interface GigabitEthernet0/0

description WAN - Connected to cable modem

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/1

description LAN

ip address 10.100.100.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface FastEthernet0/3/0

switchport voice vlan 10

!

interface FastEthernet0/3/1

switchport access vlan 50

!

interface FastEthernet0/3/2

shutdown

!

interface FastEthernet0/3/3

shutdown

!

interface Vlan10

description VOICE

ip address 10.100.10.1 255.255.255.0

ip helper-address 10.100.10.1

ip nat inside

ip virtual-reassembly in

!

interface Vlan50

description DATA

ip address 10.100.50.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

Move the config for gig0/1 to the Vlan1 interface:

interface Vlan1

ip address 10.100.100.1 255.255.255.0

ip nat inside

Brandon

Am I still able to use Gi0/1 to connect to an external switch?  or does everything need to be plugged into the HWIC card in Slot 0?

Thanks Again

You can use gig0/1. You'll want to make it a trunk port if connecting to another switch:

interface gig0/1

switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport mode trunk

Make sure the switch on the other side of the port is set to trunk as well.

Brandon

No Luck...  Unless I'm missing something, the Switchport command is unavaliable on Gi0/1.  Possibly because it's a L3 port?  G0/0 and G0/1 are built in to the router.

Sorry, my mistake. You can either configure the trunk on one of the 4ESW switch ports or reconfigure the subinterfaces such as:

interface GigabitEthernet0/1.10

encapsulation dot1Q 10

ip unnumbered vlan 10

interface GigabitEthernet0/1.50

encapsulation dot1Q 50

ip unnumbered vlan 50

interface GigabitEthernet0/1.100

encapsulation dot1Q 100

ip unnumbered vlan 100

Hope this helps.

Brandon

I used the "ip unnumbered" structure as noted, and the ports on the 4ESW work perfectly.  The switch, a 2960 on Gi0/1 is not.  Is there any modifications I need to make to the configuration of the switch?