Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

2921 withE1andIPtel

hello,

i have a router 2921 with the aproprieted  voice card for E1 and licenses. I would like to know how to configure it for incoming and outcoming calls. I already configured the ephone and SIP phones for internal calls. now i just need to configure it for send and receive external calls.

This is some informations about my cenario!

Router:

IOS:   c2900-universalk9-mz.SPA.153-1.T

CME: 8.0

ISP from India

type: E1

signal: R2 Digital

Channels: 32  

Phone Number Iniital: 61791100-61791130

ephones-dn numbers: 101 to 130

Need to map each line of ISP to internal extensions.

Regards,

ashok danole

Message was edited by: ASHOK DANOLE Hi Jagpreet, My apology for small mismatch in information. We have 4 line IP phone 6941 and 7942 and therefore enough buttons to provide seperate Dial Out line. The second button on each phone are assigned for Direct ISP numbers. (61791100-61791130 ). So how would translation rule form to match 100%? 101 to 130 would be used for internal communication.

4 REPLIES
Cisco Employee

2921 withE1andIPtel

Hi Ashok,

If the phones and the E1R2 lines are configured, you would need to configure dial peers for the call routing to work.

Understanding Dial peers:

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a008010fed1.shtml

In order to translate the DID numbers to route the calls to internal extensions, you can configure translations on the gateway to stip off the initial 5 digits. This translation profile needs to be applied to the incoming dial peer.

Sample rule:

voice translation-rule 1

rule 1 /^617911/ /1/

Understanding Voice translation rules.

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080325e8e.shtml

HTH,

Jagpreet Singh Barmi

Re: 2921 withE1andIPtel

you can assign direct numbers without translation.

make additional ephone-dn numbers

and associate it with ephones lines 2 or 3

but you need dial-peers

put here your config, I will do

Community Member

Re: 2921 withE1andIPtel


User Access Verification

Username: admin
Password:
THA-RTR-CME01#sh run
Building configuration...


Current configuration : 16185 bytes
!
! Last configuration change at 09:01:23 UTC Sat Oct 5 2013 by admin
! NVRAM config last updated at 08:59:58 UTC Sat Oct 5 2013 by admin
! NVRAM config last updated at 08:59:58 UTC Sat Oct 5 2013 by admin
version 15.3
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime
service timestamps log datetime
service password-encryption
service sequence-numbers
!
hostname THA-RTR-CME01
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 0
logging buffered 256000
enable secret 5 $1$PLGt$4aNMG5Y1at4gZOzR6h.qV.
!
no aaa new-model
network-clock-participate wic 0
!
ip cef
!
!
!
ip dhcp excluded-address 192.168.160.1 192.168.160.99
!
ip dhcp pool IP-PHONES
network 192.168.160.0 255.255.255.0
default-router 192.168.160.1
dns-server 192.168.161.43 199.164.18.28 199.164.20.69
netbios-name-server 199.164.18.28 199.164.20.69
domain-name cabot.cabot-corp.com
option 150 ip 192.168.161.14
!
!
!
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
voice call send-alert
voice rtp send-recv
!
voice service pots
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
codec preference 4 g711alaw
!
voice class codec 2
codec preference 1 g729r8
codec preference 2 g729br8
codec preference 3 g711ulaw
codec preference 4 g711alaw
!
voice class h323 1
  h225 timeout tcp establish 2
  h225 timeout setup 2
!
!
!
!
voice translation-rule 10
rule 10 /^912267/ /67/
!
!
voice translation-profile XLATE_PUBLIC_NUM
translate called 10
!
!
!
license udi pid CISCO2921/K9 sn FHK1426F0WA
hw-module pvdm 0/0
!
hw-module sm 1
!
!
!
username admin privilege 15 secret 5 $1$aXGs$/Fo0Q3r4Ew/.GXKk4o1nN1
username monitor secret 5 $1$lW0M$w7TYi50gFnC6wjW3HbTuY1
!
redundancy
!
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.161.14 255.255.255.0
ip pim dense-mode
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.160.14 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
description $ES_LAN$
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
no cdp enable
!
interface Integrated-Service-Engine1/0
no ip address
!Application: CUE Running on NME
no keepalive
!
ip default-gateway 192.168.161.5
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:
!
ip route 0.0.0.0 0.0.0.0 192.168.161.5
!
ip access-list standard SNMPc
permit 192.168.62.19
permit 192.168.232.19
deny   any log
!
!
!
snmp-server community cabot_read RO SNMPc
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps vrrp
snmp-server enable traps ds1
snmp-server enable traps tty
snmp-server enable traps eigrp
snmp-server enable traps ospf state-change
snmp-server enable traps ospf errors
snmp-server enable traps ospf retransmit
snmp-server enable traps ospf lsa
snmp-server enable traps ospf cisco-specific state-change nssa-trans-change
snmp-server enable traps ospf cisco-specific state-change shamlink interface-old
snmp-server enable traps ospf cisco-specific state-change shamlink neighbor
snmp-server enable traps ospf cisco-specific errors
snmp-server enable traps ospf cisco-specific retransmit
snmp-server enable traps ospf cisco-specific lsa
snmp-server enable traps gatekeeper
snmp-server enable traps xgcp
snmp-server enable traps license
snmp-server enable traps envmon
snmp-server enable traps ethernet cfm cc mep-up mep-down cross-connect loop conf                                                                                                                               ig
snmp-server enable traps ethernet cfm crosscheck mep-missing mep-unknown service                                                                                                                               -up
snmp-server enable traps flash insertion removal
snmp-server enable traps c3g
snmp-server enable traps ds3
snmp-server enable traps entity-sensor threshold
snmp-server enable traps adslline
snmp-server enable traps vdsl2line
snmp-server enable traps icsudsu
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps isdn ietf
snmp-server enable traps ds0-busyout
snmp-server enable traps ds1-loopback
snmp-server enable traps energywise
snmp-server enable traps bgp
snmp-server enable traps isis
snmp-server enable traps aaa_server
snmp-server enable traps atm subif
snmp-server enable traps cef resource-failure peer-state-change peer-fib-state-c                                                                                                                               hange inconsistency
snmp-server enable traps memory bufferpeak
snmp-server enable traps cnpd
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps config-ctid
snmp-server enable traps entity
snmp-server enable traps fru-ctrl
snmp-server enable traps resource-policy
snmp-server enable traps event-manager
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server enable traps frame-relay
snmp-server enable traps frame-relay subif
snmp-server enable traps hsrp
snmp-server enable traps ipmulticast
snmp-server enable traps msdp
snmp-server enable traps mvpn
snmp-server enable traps nhrp nhs
snmp-server enable traps nhrp nhc
snmp-server enable traps nhrp nhp
snmp-server enable traps nhrp quota-exceeded
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-messa                                                                                                                               ge
snmp-server enable traps pppoe
snmp-server enable traps cpu threshold
snmp-server enable traps rsvp
snmp-server enable traps syslog
snmp-server enable traps l2tun session
snmp-server enable traps l2tun pseudowire status
snmp-server enable traps vtp
snmp-server enable traps ipsla
snmp-server enable traps dial
snmp-server enable traps dsp card-status
snmp-server enable traps dsp oper-state
snmp-server enable traps rf
snmp-server enable traps ccme
snmp-server enable traps srst
snmp-server enable traps voice
snmp-server enable traps dnis
snmp-server host 192.168.232.19 cabot_read
snmp-server host 192.168.62.19 cabot_read
tftp-server flash:7942-7962-sccp.8-5-3S.tar
tftp-server flash:7942-7962-sccp.8-5-3S.tar alias 7942-7962-sccp.8-5-3S.tar
tftp-server flash:jar42sccp.8-5-3TH1-6.sbn
tftp-server flash://jar42sccp.8-5-3TH1-6.sbn
tftp-server flash://apps42.8-5-3TH1-6.sbn
tftp-server flash://SCCP42.8-5-3S.loads
tftp-server flash://cnu42.8-5-3TH1-6.sbn
tftp-server flash://cvm42sccp.8-5-3TH1-6.sbn
tftp-server flash://dsp42.8-5-3TH1-6.sbn
tftp-server flash://term42.default.loads
tftp-server flash://term62.default.loads
tftp-server flash:SCCP42.8-5-3S.loads
tftp-server flash://SCCP69xx.8-5-3-0.zz
tftp-server flash://BOOT69xx.0-0-0-14.zz
tftp-server flash://BOOT69xx.0-0-0-14.zz.sgn
tftp-server flash://DSP69xx.0-0-0-3.zz
tftp-server flash://DSP69xx.12-4-122-02-121029.zz.sgn
tftp-server flash:cmterm-7915.1-0-4-2.cop.sgn
tftp-server flash:cmterm-7915.1-0-4-2.exe
tftp-server flash:cmterm-7915.1-0-4-2.zip
tftp-server flash:B015-1-0-4-2.SBN
tftp-server flash:B015-1-0-4.SBN
!
control-plane
!
!
voice-port 0/0/0:15
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 192.168.161.14 identifier 1 version 7.0
sccp
!
dspfarm profile 3 mtp
codec g711ulaw
maximum sessions software 20
associate application SCCP
shutdown
!
dial-peer voice 133 pots
destination-pattern 133
port 0/1/0
!
dial-peer voice 10 pots
description OUT to PSTN
destination-pattern .T
direct-inward-dial
port 0/0/0:15
!
dial-peer voice 14 voip
destination-pattern .T
session target ipv4:192.168.161.14
!
dial-peer voice 11 voip
description IN from PSTN
translation-profile incoming XLATE_PUBLIC_NUM
b2bua
modem passthrough nse codec g711alaw
session protocol sipv2
session target ipv4:192.168.161.14
session transport udp
dtmf-relay rtp-nte
codec g711alaw
fax rate disable
fax protocol pass-through g711alaw
no vad
!
!
!
!
gatekeeper
shutdown
!
!
telephony-service
max-ephones 40
max-dn 80
ip source-address 192.168.161.14 port 2000
load 7915-12 B015-1-0-4.SBN
load 7942 -sccp.8-5-3S.tar
load 7962 -sccp.8-5-3S.tar
load 6941 SCCP69xx.9-3-3-2-SR1.loads
date-format dd-mm-yy
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp 7960 Oct 04 2013 10:52:26
!
!
ephone-dn  1  dual-line
number 101
label RECEPTION
description RECEPTION
name RECEPTION
!
!
ephone-dn  2  dual-line
number 102
label Meet Room 1
name Meet Room 1
!
!
ephone-dn  3  dual-line
number 103
label Meet Room 2
name Meet Room 2
!
!
ephone-dn  4  dual-line
number 104
label VACANT
name VACANT
!
!
ephone-dn  5  dual-line
number 105
label vacant
name vacant
!
!
ephone-dn  6  dual-line
number 106
label Mahesh Pawar
name Mahesh Pawar
!
!
ephone-dn  7  dual-line
number 107
label Sukdeb Sil
name Sukdeb Sil
!
!
ephone-dn  8  dual-line
number 108
label vacant
name vacant
!
!
ephone-dn  9  dual-line
number 109
label Thrisara Kumar
name Thrisara Kumar
!
!
ephone-dn  10  dual-line
number 110
label vacant
name vacant
!
!
ephone-dn  11  dual-line
number 111
label vacant
name vacant
!
!
ephone-dn  12  dual-line
number 112
label vacant
name vacant
!
!
ephone-dn  13  dual-line
number 113
label vacant
name vacant
!
!
ephone-dn  14  dual-line
number 114
label vacant
name vacant
!
!
ephone-dn  15  dual-line
number 115
label Venkatesan
name Venkatesan
!
!
ephone-dn  16  dual-line
number 116
label Deb Chand
name Deb Chand
!
!
ephone-dn  17  dual-line
number 117
label Shailesh Vaidya
name Shailesh Vaidya
!
!
ephone-dn  18  dual-line
number 118
label vacant
name vacant
!
!
ephone-dn  19  dual-line
number 119
label vacant
name vacant
!
!
ephone-dn  20  dual-line
number 120
label Manali Waichal
name Manali Waichal
!
!
ephone-dn  21  dual-line
number 121
label vacant
name vacant
!
!
ephone-dn  22  dual-line
number 122
label Sunil Shah
name Sunil Shah
!
!
ephone-dn  23  dual-line
number 123
label Conference Room
name Conference Room
!
!
ephone-dn  24  dual-line
number 124
label Bhavin Desai
name Bhavin Desai
!
!
ephone-dn  25  dual-line
number 125
label Roshan Amin
name Roshan Amin
!
!
ephone-dn  26  dual-line
number 126
label Ashvini Godbole
name Ashvini Godbole
!
!
ephone-dn  27  dual-line
number 127
label VISITOR - 1
name VISITOR - 1
!
!
ephone-dn  28  dual-line
number 128
label VISITOR - 2
name VISITOR - 2
!
!
ephone-dn  29  dual-line
number 129
label Shriram Shrinivasan
name Shriram Shrinivasan
!
!
ephone-dn  30  dual-line
number 130
label Cabin-6
name Cabin-6
!
!
ephone-dn  31  dual-line
number 131
label Philomena Tressler
name Philomena Tressler
!
!
ephone-dn  32  dual-line
number 132
!
!
ephone-dn  33  dual-line
number 133
label Pantry
name Pantry
!
!
ephone-dn  34  dual-line
number 134
label J D Almeida
name J D Almeida
!
!
ephone-dn  35  dual-line
number 135
label Meeting Room 3
name Meeting Room 3
!
!
ephone-dn  36  dual-line
number 61791126
label 61791126
name 61791126
!
!
ephone-dn  37  dual-line
number 61791124
label 61791124
name 61791124
!
!
ephone-dn  38  dual-line
number 61791116
label 61791116
name 61791116
!
!
ephone-dn  39  dual-line
number 61791134
label 61791134
name 61791134
!
!
ephone-dn  40  dual-line
number 61791106
label 61791106
name 61791106
!
!
ephone-dn  41  dual-line
number 61791120
label 61791120
name 61791120
!
!
ephone-dn  42  dual-line
number 61791131
label 61791131
name 61791131
!
!
ephone-dn  43  dual-line
number 61791133
label 61791133
name 61791133
!
!
ephone-dn  44  dual-line
number 61791125
label 61791125
name 61791125
!
!
ephone-dn  45  dual-line
number 61791129
label 61791129
name 61791129
!
!
ephone-dn  46  dual-line
number 61791101
label 61791101
name 61791101
!
!
ephone-dn  47  dual-line
number 61791122
label 61791122
name 61791122
!
!
ephone-dn  48  dual-line
number 61791117
label 61791117
name 61791117
!
!
ephone-dn  49  dual-line
number 61791107
label 61791107
name 61791107
!
!
ephone-dn  50  dual-line
number 61791109
label 61791109
name 61791109
!
!
ephone-dn  51  dual-line
number 61791115
label 61791115
name 61791115
!
!
ephone-dn  52  dual-line
number 61791135
label 61791135
name 61791135
!
!
ephone-dn  53  dual-line
number 61791102
label 61791102
name 61791102
!
!
ephone-dn  54  dual-line
number 61791103
label 61791103
name 61791103
!
!
ephone-dn  55  dual-line
number 61791105
label 61791105
name 61791105
!
!
ephone-dn  56  dual-line
number 61791108
label 61791108
name 61791108
!
!
ephone-dn  57  dual-line
number 61791110
label 61791110
name 61791110
!
!
ephone-dn  58  dual-line
number 61791111
label 61791111
name 61791111
!
!
ephone-dn  59  dual-line
number 61791112
label 61791112
name 61791112
!
!
ephone-dn  60  dual-line
number 61791113
label 61791113
name 61791113
!
!
ephone-dn  61  dual-line
number 61791114
label 61791114
name 61791114
!
!
ephone-dn  62  dual-line
number 61791118
label 61791118
name 61791118
!
!
ephone-dn  63  dual-line
number 61791119
label 61791119
name 61791119
!
!
ephone-dn  64  dual-line
number 61791121
label 61791121
name 61791121
!
!
ephone-dn  65  dual-line
number 61791128
label 61791128
name 61791128
!
!
ephone  1
mac-address 5475.D0DB.1D0D
type 6941
button  1:35 2:52
!
!
!
ephone  2
mac-address C84C.7557.1994
type 6941
button  1:34 2:39
!
!
!
ephone  4
mac-address C84C.7557.1C7F
type 6941
button  1:9 2:50
!
!
!
ephone  6
mac-address D057.4CF6.3C1F
type 7942
button  1:7 2:49
!
!
!
ephone  9
mac-address D057.4CF6.0F21
type 7942
button  1:6 2:40
!
!
!
ephone  11
mac-address D057.4C6A.D098
type 7962 addon 1 7915-12 2 7915-12
button  1:1 2:46
!
!
!
ephone  12
mac-address C84C.7557.240A
type 6941
button  1:22 2:47
!
!
!
ephone  13
mac-address 5475.D0DB.2285
type 6941
button  1:16 2:38
!
!
!
ephone  14
mac-address C84C.7557.1BC7
type 6941
button  1:15 2:51
!
!
!
ephone  16
mac-address 5475.D0DB.1CEA
type 6941
button  1:4
!
!
!
ephone  17
mac-address C84C.759C.AC65
type 6941
button  1:17 2:48
!
!
!
ephone  18
mac-address 5475.D0DB.2817
type 6941
button  1:21 2:64
!
!
!
ephone  19
mac-address 5475.D0DB.1883
type 6941
button  1:20 2:41
!
!
!
ephone  20
mac-address 5475.D0DB.287A
type 6941
button  1:3 2:54
!
!
!
ephone  21
mac-address 5475.D0DB.2298
type 6941
button  1:2 2:53
!
!
!
ephone  22
mac-address C84C.759C.9302
type 6941
button  1:28 2:65
!
!
!
ephone  23
mac-address 5475.D0DB.281B
type 6941
button  1:23
!
!
!
ephone  24
mac-address 5475.D0DB.1D15
type 6941
button  1:26 2:36
!
!
!
ephone  25
mac-address 5475.D0DB.2838
type 6941
button  1:30
!
!
!
ephone  26
mac-address 5475.D0DB.1871
type 6941
button  1:27
!
!
!
ephone  27
mac-address 5475.D0DB.1D06
type 6941
button  1:31 2:42
!
!
!
ephone  30
mac-address 5475.D0DB.1D10
type 6941
button  1:24 2:37
!
!
!
ephone  31
mac-address C84C.759C.92CB
type 6941
button  1:25 2:44
!
!
!
ephone  32
mac-address D057.4CF6.3A95
type 7942
button  1:29 2:45
!
!
!
!
line con 0
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login local
transport preferred telnet
transport input all
line vty 5 15
login local
transport preferred telnet
transport input all
!
scheduler allocate 20000 1000
ntp server 199.164.12.2
!
end

THA-RTR-CME01#

2921 withE1andIPtel

config looks like ok

but how your router connected to PSTN ? E1 or SIP trunk to 192.168.161.14

can you

ping 192.168.161.14

if SIP so add

dial-peer voice 14 voip

destination-pattern .T

session target ipv4:192.168.161.14

session protocol sipv2

put here

sh ephone summ

show dial-peer voice summ

329
Views
0
Helpful
4
Replies
CreatePlease to create content