Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

3500XL to carry voice traffic

I purchased 3500XL switch for my Voice Lab Call Manager 4.1(3)sr8.

It doesn't support POE so I had to purchase external power kit for my (2)7960 IP Phones. Configuration below, I applied to my 3500XL switch, but I couldn't get it to work with IP Phones. The Phones wouldn't get registered to Call Manager, and wouldn't receive IP Address via DHCP. I even configured the phone with static IP Address, but couldn't ping the phone from the Publisher or Subscriber.

To minimize the complexity, I put both servers and IP Phones on the same Vlan.

Ports 1 and 2 are assigned to Pub/Sub, and Ports 14 and 15 assigned to IP Phones.

Config for the Servers:

interface fa0/1

switchport access vlan 10

interface fa0/2

switchport access vlan 10

interface fa0/14

switchport voice vlan 10

switchport mode trunk

switchport priority extend trust

interface fa0/15

switchport voice vlan 10

switchport mode trunk

switchport priority extend trust

Static configuration for Phone:

IP address---- 172.16.1.10

DG--- 172.16.1.1

TFTP--- 172.16.1.2----Publisher

DHCP Server---Disabled

Couldn't ping the phone from the publisher.

Any feedback will be appreciated.

4 REPLIES

Re: 3500XL to carry voice traffic

Abbas,

Did you add VLAN 10 to the VLAN database?

switch#vlan database

switch(vlan)# vlan 10

switch(vlan)# exit

http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.1_6_ea1/command/reference/cli3.html#wp1024811

HTH,

Mark

Community Member

Re: 3500XL to carry voice traffic

Hi All,

If the voice vlan is 10, please configure the ports connecting with IP phone with the following

!

interface FastEthernet0/12

description connect IP phone

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 10

spanning-tree portfast

!

It works fine for me.

Regards,

Michael.

Community Member

Re: 3500XL to carry voice traffic

Yes, I did add the VLAN 10 in the database.

The only command I am missing is "switchport trunk encapsulation dot1q", but that should not stop the Layer 2 connectivity though. I had router on stick configuration on 2600XM router connected to 3500XL switch, and I defined the DHCP pool in a router, but the IP Phone wasn't able to receive the IP address from the pool. I then disabled DHCP Server on the phone, and statically assigned the IP Address below, but I couldn't ping the Publisher/Subscriber from the IP Phone. In a lab, I installed the CCM 4.1(3) sr8, but I don't if I have to enable any services in "Service Activation Menu" May be this is the problem, I guess.

Community Member

Re: 3500XL to carry voice traffic

If we don't define dot1q, the switch will use cisco ISL as default encapsulation.

Did you add the dot1q command for testing?

The Publisher should connect to a port that mode should be configured access mode and don't change it to trunk mode.

Let the Publisher work as DHCP server, it should be work.

Michael.

259
Views
0
Helpful
4
Replies
CreatePlease to create content