Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3750 as DHCP

Hello

after a 2 year break I finially managed to get hold of some kit and decided to go for the last 3 exams of my CCNP Voice. Just started from scract. I have a 3750 which I am configuring as DHCP source. The initial config is below, after doing the initial configuration, I connected a G5 server which got an IP address, virtual servers installed on the G5 got IP addresses too. However I am stuggling to get phone booting up as the phone was factory resetted before.

This is how the devices are conencted to 3750 swicth.

Gi1/0/1 - HP G5 server running CUCM PUB and SUB

Gi1/0/2 - Laptop

Gi1/0/3 - Cisco IP Phone 7961

Phone is stuck at factory reset, so I can't manually configure TFTP in the phone.

Question is - How do I get the phone to talk to CUCM to get the initial config file ?

Any help would be appriciated.

3750 Config

=========

DHCP_SW#sh run

Building configuration...

Current configuration : 6272 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname DHCP_SW

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$iJMc$zgLJ1Z3MVI.sK2gEcaVE.1

!

no aaa new-model

switch 1 provision ws-c3750e-48pd

system mtu routing 1500

ip subnet-zero

ip routing

no ip dhcp use vrf connected

ip dhcp excluded-address 10.125.100.1

ip dhcp excluded-address 10.125.200.1

ip dhcp excluded-address 10.125.100.3

ip dhcp excluded-address 10.125.100.7

!

ip dhcp pool vlan100

   network 10.125.100.0 255.255.255.0

   default-router 10.125.100.1

!

ip dhcp pool vlan200

   network 10.125.200.0 255.255.255.0

   default-router 10.125.200.1

!

ip dhcp pool Voice_DHCP

   option 150 ip 10.125.100.0

!

ip dhcp pool Voice_DHCp

!

!

!

!

crypto pki trustpoint TP-self-signed-1890746624

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1890746624

revocation-check none

rsakeypair TP-self-signed-1890746624

!

!

crypto pki certificate chain TP-self-signed-1890746624

certificate self-signed 01

  30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31383930 37343636 3234301E 170D3933 30333031 30303336

  33345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 38393037

  34363632 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100E8D1 F48AC7EA 5EC82A3F 5E93A8E0 6AF2F92E 51B8FB42 C8496B33 A7C217B3

  73DEBDF9 40A8D20E F2DCD1BC 429A0275 EB1E3EA1 286E63DA 88E04EA8 DF40858D

  6EF1ED56 67FD264E 3DDFFB62 A89A2367 21D532AA 8DCD6294 FCB1E2BC C8CEE3A3

  C5819E43 F9E75EFC 713E42C8 38349498 036885B3 C6F5715C B277C301 DAE875F4

  ABBB0203 010001A3 68306630 0F060355 1D130101 FF040530 030101FF 30130603

  551D1104 0C300A82 08444843 505F5357 2E301F06 03551D23 04183016 80143F98

  B9015E5C 49F193B6 7F589F95 079631C7 2CBD301D 0603551D 0E041604 143F98B9

  015E5C49 F193B67F 589F9507 9631C72C BD300D06 092A8648 86F70D01 01040500

  03818100 6765D542 A7E40331 EF511347 EF6A129E EE791BC4 5E5C0865 DFA3D5AD

  9394795A A13BF857 972B2551 6F1CC63C C4FAA0ED 91948F89 D354C24F 27F73584

  833DF08D 50B99CB1 04E4A7E2 1D9C9A63 E97CF503 E8D5AD94 9AD76914 F163A690

  8481DFCF CD55BD37 9CF95312 E2267AD9 09E0A10E 8813DFBC 691CC0C2 03414A00 BD0EA9BD

  quit

!

!

!

!

!

spanning-tree mode pvst

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

!

interface GigabitEthernet1/0/1

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/2

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/3

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/4

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/5

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/6

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/7

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/8

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/9

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/10

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/11

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/12

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/13

switchport access vlan 200

switchport mode access

speed 100

duplex full

!

interface GigabitEthernet1/0/14

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/15

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/16

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/17

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/18

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/19

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/20

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/21

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/22

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/23

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/24

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/25

switchport access vlan 10

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface GigabitEthernet1/0/29

!

interface GigabitEthernet1/0/30

!

interface GigabitEthernet1/0/31

!

interface GigabitEthernet1/0/32

!

interface GigabitEthernet1/0/33

!

interface GigabitEthernet1/0/34

!

interface GigabitEthernet1/0/35

!

interface GigabitEthernet1/0/36

!

interface GigabitEthernet1/0/37

!

interface GigabitEthernet1/0/38

!

interface GigabitEthernet1/0/39

!

interface GigabitEthernet1/0/40

!

interface GigabitEthernet1/0/41

!

interface GigabitEthernet1/0/42

!

interface GigabitEthernet1/0/43

!

interface GigabitEthernet1/0/44

!

interface GigabitEthernet1/0/45

!

interface GigabitEthernet1/0/46

!

interface GigabitEthernet1/0/47

!

interface GigabitEthernet1/0/48

!

interface GigabitEthernet1/0/49

!

interface GigabitEthernet1/0/50

!

interface GigabitEthernet1/0/51

!

interface GigabitEthernet1/0/52

!

interface TenGigabitEthernet1/0/1

!

interface TenGigabitEthernet1/0/2

!

interface Vlan1

ip address dhcp

!

interface Vlan10

ip address 10.0.0.1 255.255.255.0

!

interface Vlan100

description Voice_DHCP

ip address 10.125.100.1 255.255.255.0

ip helper-address 10.125.100.0

!

interface Vlan200

description Data_DHCP

ip address 10.125.200.1 255.255.255.0

!

ip classless

ip http server

ip http secure-server

!

!

!

!

control-plane

!

!

line con 0

line vty 0 4

password cisco

login

line vty 5 15

login

!

end

  • IP Telephony
Everyone's tags (7)
3 REPLIES
Hall of Fame Super Silver

3750 as DHCP

Your Voice DHCP scope has option 150, but does not have a network specified.

Your voice interface has helper defines, what is it? Do you want to use external DHCP for that?

Alos, all of your ports are not configured for voice vlan, you need to add:

interface GigabitEthernetx/o/x

switchport access vlan 200

switchport voice vlan 100

switchport mode access

Chris

New Member

3750 as DHCP

Hi Chris

Thanks for your reply. I have changed the port config, still no luck. The switch is acting as DHCP, no external DHCP.

Sh run config is below -

DHCP_SW#sh run

Building configuration...

Current configuration : 9586 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname DHCP_SW

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$iJMc$zgLJ1Z3MVI.sK2gEcaVE.1

!

no aaa new-model

switch 1 provision ws-c3750e-48pd

system mtu routing 1500

ip subnet-zero

ip routing

no ip dhcp use vrf connected

ip dhcp excluded-address 10.125.100.1

ip dhcp excluded-address 10.125.200.1

ip dhcp excluded-address 10.125.100.3

ip dhcp excluded-address 10.125.100.7

!

ip dhcp pool vlan100

   network 10.125.100.0 255.255.255.0

   default-router 10.125.100.1

   option 150 ip 10.125.100.7

!

ip dhcp pool vlan200

   network 10.125.200.0 255.255.255.0

   default-router 10.125.200.1

!

!

!

mls qos map policed-dscp  24 26 46 to 0

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos srr-queue input bandwidth 90 10

mls qos srr-queue input threshold 1 8 16

mls qos srr-queue input threshold 2 34 66

mls qos srr-queue input buffers 67 33

mls qos srr-queue input cos-map queue 1 threshold 2 1

mls qos srr-queue input cos-map queue 1 threshold 3 0

mls qos srr-queue input cos-map queue 2 threshold 1 2

mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7

mls qos srr-queue input cos-map queue 2 threshold 3 3 5

mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7

mls qos srr-queue input dscp-map queue 1 threshold 3 32

mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23

mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48

mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56

mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63

mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 2 4

mls qos srr-queue output cos-map queue 4 threshold 2 1

mls qos srr-queue output cos-map queue 4 threshold 3 0

mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47

mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7

mls qos queue-set output 1 threshold 1 138 138 92 138

mls qos queue-set output 1 threshold 2 138 138 92 400

mls qos queue-set output 1 threshold 3 36 77 100 318

mls qos queue-set output 1 threshold 4 20 50 67 400

mls qos queue-set output 2 threshold 1 149 149 100 149

mls qos queue-set output 2 threshold 2 118 118 100 235

mls qos queue-set output 2 threshold 3 41 68 100 272

mls qos queue-set output 2 threshold 4 42 72 100 242

mls qos queue-set output 1 buffers 10 10 26 54

mls qos queue-set output 2 buffers 16 6 17 61

mls qos

!

crypto pki trustpoint TP-self-signed-1890746624

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1890746624

revocation-check none

rsakeypair TP-self-signed-1890746624

!

!

crypto pki certificate chain TP-self-signed-1890746624

certificate self-signed 01

  30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31383930 37343636 3234301E 170D3933 30333031 30303336

  33345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 38393037

  34363632 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100E8D1 F48AC7EA 5EC82A3F 5E93A8E0 6AF2F92E 51B8FB42 C8496B33 A7C217B3

  73DEBDF9 40A8D20E F2DCD1BC 429A0275 EB1E3EA1 286E63DA 88E04EA8 DF40858D

  6EF1ED56 67FD264E 3DDFFB62 A89A2367 21D532AA 8DCD6294 FCB1E2BC C8CEE3A3

  C5819E43 F9E75EFC 713E42C8 38349498 036885B3 C6F5715C B277C301 DAE875F4

  ABBB0203 010001A3 68306630 0F060355 1D130101 FF040530 030101FF 30130603

  551D1104 0C300A82 08444843 505F5357 2E301F06 03551D23 04183016 80143F98

  B9015E5C 49F193B6 7F589F95 079631C7 2CBD301D 0603551D 0E041604 143F98B9

  015E5C49 F193B67F 589F9507 9631C72C BD300D06 092A8648 86F70D01 01040500

  03818100 6765D542 A7E40331 EF511347 EF6A129E EE791BC4 5E5C0865 DFA3D5AD

  9394795A A13BF857 972B2551 6F1CC63C C4FAA0ED 91948F89 D354C24F 27F73584

  833DF08D 50B99CB1 04E4A7E2 1D9C9A63 E97CF503 E8D5AD94 9AD76914 F163A690

  8481DFCF CD55BD37 9CF95312 E2267AD9 09E0A10E 8813DFBC 691CC0C2 03414A00 BD0EA9BD

  quit

!

!

!

!

!

spanning-tree mode pvst

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

class-map match-all AutoQoS-VoIP-RTP-Trust

match ip dscp ef

class-map match-all AutoQoS-VoIP-Control-Trust

match ip dscp cs3  af31

!

!

policy-map AutoQoS-Police-CiscoPhone

class AutoQoS-VoIP-RTP-Trust

  set dscp ef

  police 320000 8000 exceed-action policed-dscp-transmit

class AutoQoS-VoIP-Control-Trust

  set dscp cs3

  police 32000 8000 exceed-action policed-dscp-transmit

!

!

!

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

!

interface GigabitEthernet1/0/1

switchport access vlan 200

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

interface GigabitEthernet1/0/2

switchport access vlan 200

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

interface GigabitEthernet1/0/3

switchport access vlan 200

switchport mode access

switchport voice vlan 100

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

service-policy input AutoQoS-Police-CiscoPhone

!

interface GigabitEthernet1/0/4

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/5

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/6

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/7

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/8

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/9

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/10

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/11

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/12

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/13

switchport access vlan 200

switchport mode access

speed 100

duplex full

!

interface GigabitEthernet1/0/14

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/15

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/16

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/17

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/18

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/19

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/20

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/21

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/22

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/23

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/24

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet1/0/25

switchport access vlan 10

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface GigabitEthernet1/0/29

!

interface GigabitEthernet1/0/30

!

interface GigabitEthernet1/0/31

!

interface GigabitEthernet1/0/32

!

interface GigabitEthernet1/0/33

!

interface GigabitEthernet1/0/34

!

interface GigabitEthernet1/0/35

!

interface GigabitEthernet1/0/36

!

interface GigabitEthernet1/0/37

!

interface GigabitEthernet1/0/38

!

interface GigabitEthernet1/0/39

!

interface GigabitEthernet1/0/40

!

interface GigabitEthernet1/0/41

!

interface GigabitEthernet1/0/42

!

interface GigabitEthernet1/0/43

!

interface GigabitEthernet1/0/44

!

interface GigabitEthernet1/0/45

!

interface GigabitEthernet1/0/46

!

interface GigabitEthernet1/0/47

!

interface GigabitEthernet1/0/48

!

interface GigabitEthernet1/0/49

!

interface GigabitEthernet1/0/50

!

interface GigabitEthernet1/0/51

!

interface GigabitEthernet1/0/52

!

interface TenGigabitEthernet1/0/1

!

interface TenGigabitEthernet1/0/2

!

interface Vlan1

ip address dhcp

!

interface Vlan10

ip address 10.0.0.1 255.255.255.0

!

interface Vlan100

description Voice_DHCP

ip address 10.125.100.1 255.255.255.0

!

interface Vlan200

description Data_DHCP

ip address 10.125.200.1 255.255.255.0

!

ip classless

ip http server

ip http secure-server

!

!

!

!

control-plane

!

!

line con 0

line vty 0 4

password cisco

login

line vty 5 15

login

!

end

Hall of Fame Super Gold

Re: 3750 as DHCP

I think I know why ...

You said your PUB and SUB are in G 1/0/1 right?

If I remembered correctly, should the PUB/SUB be in the Voice VLAN (VLAN 100) instead of VLAN 200?  Shoud the PUB/SUB have the same subnet as the phones?

If this is so, then your Gi1/0/1 should be "switchport access vlan 100".

Post the output to the command "sh ip dhcp bind".

218
Views
0
Helpful
3
Replies