Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3905 phone won't register with srst gateway

Hi Fellows

i got an issue, if you could help me would be great. I have a bunch of 3905 in a remote office and when loses connectivity with the call manager won't register with the local gateway, i check the phone and in the telephony information shows me active server:<ip_publisher> and stand by server: <ip_subscriber> and does not have the option to put a third srst server.

I reviewed the pre requisites in cisco's web site and seems all in order

http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/requirements/guide/srs88spc.html

Version of the firmware phone : 9.2.1.0

Version of SRST : 8.8

Version of GW IoS : 15.2(1)T

Version of CM: 8.5.1 SU2

Thanks in advance

Best Regards

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: 3905 phone won't register with srst gateway

Hi,

Could you please post your SRSTSconfiguration? Since you need SIP SRST in order to re-register these phones to the GW, please check these links:


http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/admin/sccp_sip_srst/configuration/guide/srst_41.html

http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/feature/guide/srst71ft.html

HTH,

--espereir

6 REPLIES
Silver

Re: 3905 phone won't register with srst gateway

Hi,

Could you please post your SRSTSconfiguration? Since you need SIP SRST in order to re-register these phones to the GW, please check these links:


http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/admin/sccp_sip_srst/configuration/guide/srst_41.html

http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/feature/guide/srst71ft.html

HTH,

--espereir

New Member

3905 phone won't register with srst gateway

Thanks you very much espereir, your post clarify me all, i take a look to the documentation that you provide me and i resolve the issue.

Thanks again

New Member

3905 phone won't register with srst gateway

Hi Gramirez

I have the same problem. Could you put the configuration that solved the issue?

TIA

Cristian.

New Member

3905 phone won't register with srst gateway

Hi!!

I have the same issue, Could you send me the gateway configuration please?

Regards!

New Member

3905 phone won't register with srst gateway

Fellows,

The solution was to put configurations related to sip, these are the lines that i added

********* Enable SIP srst register **************

voice register global

system message XXX

max-dn 20

max-pool 20

********** Create the endpoints that are going to register with the gateway ************

voice register pool  1

id mac XXXX.XXXX.XXXX

number 1 711

codec g711alaw

********* SRST related **********

application

global

  service alternate Default

sip-ua

Regards

New Member

Hi Gramirez23,

Hi Gramirez23,

Currently am facing the same issue.. could you please put the router configuration here so that i can compare with mine..

mine is like this...

Building configuration...


Current configuration : 2798 bytes
!
! Last configuration change at 05:47:48 UTC Wed Sep 21 2016 by pyramid
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
enable password pyramid
!
no aaa new-model
!
!
!
!
!
ip dhcp pool sampath
network 192.168.0.0 255.255.255.0
default-router 192.168.0.199
option 150 ip 192.168.0.234
!
!
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice-card 0
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
bind control source-interface GigabitEthernet0/0
bind media source-interface GigabitEthernet0/0
registrar server expires max 1200 min 300
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711alaw
codec preference 3 g711ulaw
!
!
voice register global
mode srst
timeouts interdigit 5
system message Fallback mode is active
max-dn 20
max-pool 10
authenticate presence
authenticate realm cisco.com
timezone 39
mwi unsolicited
!
voice register dn 1
number 100
allow watch
!
voice register pool 2
id mac 0008.2FB6.1628
number 1 dn 1
codec g711ulaw
!
!
!
!
!
!
application
global
service alternate Default
!
!
license udi pid CISCO2901/K9 sn FGL1927239Q
license boot module c2900 technology-package uck9
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
username pyramid password 0 pyramid
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.0.199 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
sip-ua
!
!
!
gatekeeper
shutdown
!
!
credentials
ip source-address 192.168.0.199 port 2000
trustpoint CUCM
!
!
ephone-type 9971
device-id 9971
device-name CISCO IP Phone 9971
num-buttons 1
max-presentation 1
!
!
ephone-type 3905
device-id 3905
device-name CISCO CP3905
device-type SIP
num-buttons 1
max-presentation 1
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login local
transport input all
!
scheduler allocate 20000 1000
!
end

2722
Views
0
Helpful
6
Replies
CreatePlease login to create content