Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

7821 Cisco Phone with SRST Issue

Hello good day 

dears please support me 

i have 7821 ip phone and its SIP phone and its not working with SRST  in branch location . and as ber Cisco Compatibility Information can support from SRST v 8.6 and i'm already upgrade my routers IOS to 15.0 to support SRST 8.6 adn its not working . do you have any idea

 http://www.cisco.com/c/en/us/support/unified-communications/unified-survivable-remote-site-telephony/products-device-support-tables-list.html

Phone 7821

Routers 2801  IOS 15.1

             1861   IOS 15.1

               880   IOS 15.3

 

Thanks & Best Regards,

 

 

 

15 REPLIES
Hall of Fame Super Silver

Please post your SIP SRST

Please post your SIP SRST configuration so we can confirm proper config.

Chris

New Member

Hello, kindly find in the

Hello,

 

kindly find in the below the router configuration 

 

call-manager-fallback
 max-conferences 2 gain -6
 transfer-system full-consult
 ip source-address X.X.X.X port 2000
 max-ephones 5
 max-dn 10
 keepalive 40

 

Thank You :) 

 

Hall of Fame Super Silver

This SCCP SRST config, you

This SCCP SRST config, you need sip SRST for 78xx phones.

chris

New Member

dear Chris, could you please

dear Chris,

 

could you please help me for the SIP configuration please 

 

many thanks

Hall of Fame Super Silver

Here you go:voice register

Here you go:

voice register global
 system message SRST Active
 max-dn 200
 max-pool 10
!
voice register pool  1
 id network 10.x.x.0 mask 255.255.255.0

 

Chris

New Member

hello Chris thanks a lot for

hello Chris

 

thanks a lot for your kind support.

but sorry its not working :(

any extra idea .

 

thanks & Best Regards,

 

the below for your info

======================================================

 

RTR#show voice register pool all
 Pool Tag 1
Config:
  Network address is 10.106.52.1, Mask is 255.255.255.0
  Proxy Ip address is 0.0.0.0
  DTMF Relay is disabled
  kpml signal is enabled
  Lpcor Type is none

  Reason for unregistered state: 
         No registration request since last reboot/unregister

  paging-dn: config 0 [multicast]  effective 0 [multicast]

Dialpeers created:

Statistics:
  Active registrations  : 0

  Total SIP phones registered: 0
  Total Registration Statistics
    Registration requests  : 0
    Registration success   : 0
    Registration failed    : 0
    unRegister requests    : 0
    unRegister success     : 0
    unRegister failed      : 0
    Attempts to register 
           after last unregister : 0 
    Last register request time   : 
    Last unregister request time : 
    Register success time        : 
    Unregister success time      : 

=======================================

 

 

 

Hall of Fame Super Silver

Do you have SRST reference

Do you have SRST reference properly configured in CUCM and assigned to the phones'  device pool?

New Member

Dear Chris, yes SRST

Dear Chris,

 

yes SRST reference assigend to phone device pool as per attached pic.

 

Thanks & Best Regards,

Hall of Fame Super Silver

Can you provide "debug ccsip

Can you provide "debug ccsip all" when the phones are suppose to register. Did you define proper subnets of the phones under the voice register pool?

Chris

New Member

Dear Chris, yes the subnet

Dear Chris,

 

yes the subnet under the voice register poll is correct.

and i'm enabled the Debug CCSIP all 

--------------------------------------------------

INT-RDS-RTR#show debug     
  Persistent variable debugging is currently All


CCSIP SPI: SIP Call Statistics tracing is enabled       (filter is OFF)
CCSIP SPI: SIP Call Message tracing is enabled  (filter is OFF)
CCSIP SPI: SIP Call State Machine tracing is enabled    (filter is OFF)
CCSIP SPI: SIP Call Events tracing is enabled   (filter is OFF)
CCSIP SPI: SIP error debug tracing is enabled   (filter is OFF)
CCSIP SPI: SIP info debug tracing is enabled    (filter is OFF)
CCSIP SPI: SIP media debug tracing is enabled   (filter is OFF)
CCSIP SPI: SIP Call preauth tracing is enabled  (filter is OFF)
CCSIP SPI: SIP Call transport tracing is enabled        (filter is OFF)
CCSIP SPI: SIP DHCP tracing is enabled  (filter is OFF)

 

INT-RDS-RTR#

===========================================

the below FYI

------------------------

  Version 10.0
  Mode is srst
  Max-pool is 5
  Max-dn is 50
  Outbound-proxy is enabled and will use global configured value
  Security Policy: DEVICE-DEFAULT
  Forced Authorization Code Refer is enabled
  System message is SRST Active
  timeout interdigit 10
  network-locale[0] US    (This is the default network locale for this box)
  network-locale[1] US 
  network-locale[2] US 
  network-locale[3] US 
  network-locale[4] US 
  user-locale[0] US    (This is the default user locale for this box)
  user-locale[1] US 
  user-locale[2] US 
  user-locale[3] US 
  user-locale[4] US 
  MWI unsolicited notify is disabled
  Active registrations  : 0

  Total SIP phones registered: 0
  Total Registration Statistics
    Registration requests  : 0
    Registration success   : 0
    Registration failed    : 0
    unRegister requests    : 0
    unRegister success     : 0
    unRegister failed      : 0
    Attempts to register 
           after last unregister : 0 
    Last register request time   : 
    Last unregister request time : 
    Register success time        : 
    Unregister success time      : 

 

===================================

do you need show run for all voice configuration on the router ??

 

Thanks & Bet Regards,

 

Hall of Fame Super Silver

There is nothing showing in

There is nothing showing in the debug implying the phones do not even attempt to register, yes please provide full config,

Chris

New Member

 Dear Chris kindly find the

 

Dear Chris

 

kindly find the attached full config for the router ز

 

Thank you for your interest to help me :]

Best Regards,

 

 

New Member

Try adding: Voice service

Try adding:

 

Voice service voip

 allow-connections sip to sip

 sip

   registrat server

 

New Member

In my case that was the

In my case that was the solution!!

 

Thanks!!

New Member

Dear Sir,

Dear Sir,

We have two Sites .example site A and Site B.call manager Bussiness Edition 6000 is placed in site-A and Site-B phones are registered on this BE 6000 through VPN.In Site-B there is a SRST Router  for  the redundancy 

In site-B there is cisco 7975,7962 ,cp 6921 and cp7861 iphones

After finishing the configuration 7675 and 7962 is able to register on srst router after loss the connectivity of BE 6000.but  cp 6921 and cp7861 iphones are not registering on srst router.Please help me

Find the configuration  of SRST Router. Please let me know what are the changes i should make

Please Please help me


Building configuration...


Current configuration : 4445 bytes
!
! Last configuration change at 12:17:18 UTC Sat Apr 2 2016
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AUH_SRST
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/1
enable password admin
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.50.129
ip dhcp excluded-address 192.168.50.130
!
ip dhcp pool VOICE
import all
network 192.168.50.128 255.255.255.128
default-router 192.168.50.130
option 150 ip 10.10.3.251 10.10.3.250
lease 30
!
!
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
trunk group AUH_FXO
hunt-scheme round-robin
!
cts logging verbose
!
!
voice-card 0
!
!
!
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server expires max 600 min 60
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
!
!
!
voice iec syslog
voice register global
mode esrst
timeouts interdigit 3
system message ETA_FallBack
max-dn 20
max-pool 20
!
voice register pool 1
id network 192.168.50.128 mask 255.255.255.128
no digit collect kpml
dtmf-relay rtp-nte
codec g711ulaw
!
!
!
voice translation-rule 1
rule 1 /[0-9]+/ /9&/
rule 2 /971/ /900971&/
!
!
voice translation-profile FROM_ISP
translate calling 1
!
!
!
license udi pid CISCO2921/K9 sn FCZ193661MR
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
description #MANAGEMENT#
encapsulation dot1Q 10
ip address 192.168.22.5 255.255.255.248
!
interface GigabitEthernet0/0.60
description #vOICE vLAN#
encapsulation dot1Q 60
ip address 192.168.50.130 255.255.255.128
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.50.130
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.50.129
!
!
!
!
control-plane
!
!
voice-port 0/0/0
trunk-group AUH_FXO
translation-profile incoming FROM_ISP
cptone AE
timeouts call-disconnect 5
timeouts wait-release 5
timing guard-out 1000
connection plar opx 5333
caller-id enable
!
voice-port 0/0/1
trunk-group AUH_FXO
translation-profile incoming FROM_ISP
cptone AE
timeouts call-disconnect 5
timeouts wait-release 5
timing guard-out 1000
connection plar opx 5333
caller-id enable
!
voice-port 0/0/2
trunk-group AUH_FXO
translation-profile incoming FROM_ISP
cptone AE
timeouts call-disconnect 5
timeouts wait-release 5
timing guard-out 1000
connection plar opx 5333
caller-id enable
!
voice-port 0/0/3
trunk-group AUH_FXO
translation-profile incoming FROM_ISP
cptone AE
timeouts call-disconnect 5
timeouts wait-release 5
timing guard-out 1000
connection plar opx 5333
caller-id enable
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 1 pots
incoming called-number .
!
dial-peer voice 1000 voip
destination-pattern 5333
session target ipv4:10.10.3.250
incoming called-number .
voice-class codec 1
!
dial-peer voice 1001 voip
destination-pattern 53..
session target ipv4:10.10.3.250
voice-class codec 1
!
!
sip-ua
!
!
!
gatekeeper
shutdown
!
!
call-manager-fallback
secondary-dialtone 9
max-conferences 8 gain -6
transfer-system full-consult
timeouts interdigit 5
ip source-address 192.168.50.130 port 2000
max-ephones 25
max-dn 50 dual-line
system message primary ETA_MELCO_LOCAL
system message secondary ETA_MELCO_LOCAL
transfer-pattern .T
keepalive 20
call-forward pattern .T
call-forward busy 5333
call-forward noan 5333 timeout 45
time-zone 35
date-format dd-mm-yy
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password admin
login
transport input telnet
!
scheduler allocate 20000 1000
!
end

AUH_SRST#

2859
Views
10
Helpful
15
Replies
CreatePlease login to create content