Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

7940 don't respond after upgrade cm

Hi, I install upgrade my call manager from 6.1.3 to 7.1.3(b).

everything working except firmware 7940.

It's strange because ip phone 7940 don'r accept any change on call manager, for example if I change alert display, the change is not replicated on the phone and the phone don't responding to my reset command from call manager, neither restart.

Do you have any idea how resolving this problem?


Thank you


Everyone's tags (1)

Re: 7940 don't respond after upgrade cm


The symptoms that you have mentioned suggest a db replication issue, if you register the 7940 directly with the Publisher do you have the same problem, or do you the changes take effect?  It the later is the case the db replication seem to be your problem which you can verify through the following:-

Within CUCM 7.x there is the Cisco Unified Reporting. It provides detailed reports including Database status, and highlights any inconsistencies within the various aspects assoiciated with replication, such host and sqlhosts files etc..

You can open or select this reporting facility from within the CUCM administration, open the drop down menu where you select the OS admin option, and there you will see 'Cisco Unified Reporting'.

When the Reporting page appears click on the 'System Reports', you will then see the numberous reports available, one of which is the 'Unified CM Database Status'.

Click on this report, and then click on generate report. This will take several minutes to complete. Once complete it will give a comprehensive report, and may highlight what could be possibly wrong.



Hope this helps.

New Member

Re: 7940 don't respond after upgrade cm

Hi,thanx but i have already controlled the database status and in all cluster 1 pub + 3 sub, the status is 2 = good how you can see in the image, i don't

think that's a problem of replication

Re: 7940 don't respond after upgrade cm

It sound like this phone may have bombed out on the firmware upgrade.  Have you tried to powercycle the phone by disconnecting and reconnecting to the network?  This will often fix the problem especially if it is a single device giving you a problem.


Please rate helpful posts!

New Member

Re: 7940 don't respond after upgrade cm

Hi all

The problem is on all phone cluster only on all 7940, meanwhile 7912 work fine.

I've tried to restart the phone but nothing and new phone don't registering and don't upgrade

I've fear there's a problem with new firmware and i've think that i install a different firmware in the cluster


i''ll make this work on tuesday evening and i hope that firmware downgrade help me

if you have any idea is good accepted


Re: 7940 don't respond after upgrade cm

Well, I think you've gotten good ideas; however, it helps to have all the details when you post to the forum.  Saying upfront that ALL 7940's did not register would have changed the scope of what the problem actually is.  So, with that said - here are some key points for you to consider:

1) Did you test the firmware upgrade on a 7940 from your environment before doing the upgrade?  At this point, it's a moot point but I'd highly recommend doing the firmware upgrade independent of the CUCM upgrade whenever possible.

2) Are you phones spinning - i.e., are the 7940's constantly reattempting to register or are they stuck in a failed upgrade state?  In either case, you CANNOT restart or reset a phone from the CUCM admin page if it is not registered.  If the phone isn't registered, it will not respond to SCCP request from the CUCM.  However, if they are spinning then you should be able to load a downgraded firmware and the phones MIGHT try to pull the upgrade firmware file without a power cycle.  I say MIGHT because phones act strangely sometimes when there is a firmware issue at play.

3) If the phones are stuck from a failed upgrade in firmware, then you are going to need to power cycle the phones in one of 2 ways: manually disconnecting/reconnecting every phone after you load the downgraded firmware version OR writing a script to shut/no shut the switch port that each phone is connected to (this is the same as a hard disconnect since it shuts off PoE to the port).  You'd need to shut the port, wait a few seconds, and the enable the port to make sure the phones fully disconnect before proceeding.

You could also use a TFTP client on your local PC to spoof a TFTP request to the CUCM and take a look at the file that is being sent to the phone.  Check the details to see if there are any obvious issues with the TFTP files for the 7940's.

In addition, it would probably be wise to test your "downgrade" theory by loading the downgraded version of firmware and then manually setting a single 7940 to boot using this firmware.  You can do this from the Device configuration page for any phone.  Set the Phone Load version to the downgrade version, power cycle the phone, and see if it comes up.  If it does not, then you may very well have issues elsewhere within the CUCM application and not just with the firmware itself.  If that is the case, you'd be best off to take this up in a TAC case and get specialized help with someone who can remotely access your network.


Please rate helpful posts!

Hall of Fame Super Red

Re: 7940 don't respond after upgrade cm

Hi Allan & Hailey,

I thought both of your answers here were well thought out and deserving

of +5 each. Keep up the great work guys



CreatePlease to create content