Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

7940 IP Phone wont register to CME 8.6, in loop.

I have 2 7940 phones that just wont register, they keep going round in a loop.

Im using a 3550 layer 3 switch as dhcp and a 2801 CME 8.6 router.

Please take a look on the configs:

ROUTER:

Current configuration : 8211 bytes

!

! Last configuration change at 23:42:52 BST Mon Aug 6 2012

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname R2800

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

clock timezone GMT 0 0

clock summer-time BST recurring

dot11 syslog

ip source-route

!

--More--                           !

!

!

!

ip cef

ip name-server 4.2.2.2

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to sip

sip

  registrar server expires max 600 min 60

!

!

--More--                           !

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-875489979

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-875489979

revocation-check none

rsakeypair TP-self-signed-875489979

!

!

crypto pki certificate chain TP-self-signed-875489979

certificate self-signed 01

  3082023B 308201A4 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 38373534 38393937 39301E17 0D313230 38303631 37323530

  375A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F

  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3837 35343839

  39373930 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100

  D2E85DBD F324311E 4691B2D2 C81B3A6F 25A82E33 3A46A3FA 244C50B0 DED9901D

  E4CE5523 77D56F48 C8634BE0 011013E8 9A2D1560 AF22068E 34F905A7 929D28B6

--More--                             9653175C A24B1E4D 301DAC18 E0244636 10192D31 2860DEA8 CB00D314 B020E30F

  3AD207B4 170553AB 4D2188AA C37AF296 9C23A7F6 83BDA5FF 0644D320 5988F35D

  02030100 01A36530 63300F06 03551D13 0101FF04 05300301 01FF3010 0603551D

  11040930 07820552 32383030 301F0603 551D2304 18301680 149FF075 EF5A5FD9

  44F9B17F F0A2D4C1 0C767A46 61301D06 03551D0E 04160414 9FF075EF 5A5FD944

  F9B17FF0 A2D4C10C 767A4661 300D0609 2A864886 F70D0101 04050003 81810051

  A6CEDB53 4CCDF403 DA66E8F1 ED5D9219 1CC2C63C 04FABC74 79BD427A E77DF192

  75698714 91F3ED90 028A805F 1053C08F 4571B8EA BAA01378 6D1D81F3 87904837

  BAA6B08C 7D75780F C9BFC421 EAC10D66 F918B7E8 69BF1F34 6C6572BB 327B135B

  DDAB16ED 0DE61C19 39D95523 87D4A6AD 3ED10F66 DAEA3AC0 3C23B02E 3B5EF2

       quit

!

!

license udi pid CISCO2801 sn FHK085210WV

archive

log config

  hidekeys

!

redundancy

!

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 172.31.100.100 255.255.255.0

!

interface FastEthernet0/0

ip address 172.20.0.2 255.255.0.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.16.5.2 255.255.255.0

duplex auto

speed auto

!

interface Serial0/2/0

ip address 172.18.0.2 255.255.255.252

--More--                            no fair-queue

!

interface Serial0/2/1

ip address 172.19.0.2 255.255.255.252

!

!

router eigrp 1

network 172.16.0.0

network 172.17.0.0

network 172.18.0.0

network 172.19.0.0

network 172.20.0.0

network 172.21.0.0

network 172.26.0.0

network 172.31.0.0

auto-summary

!

ip forward-protocol nd

ip http server

ip http secure-server

!

!

ip route 0.0.0.0 0.0.0.0 172.16.5.1

!

--More--                           !

!

!

!

!

tftp-server flash:P0030801SR02.bin alias P0030801SR02.bin

!

control-plane

!

!

!

!

mgcp profile default

!

!

dial-peer cor custom

name 888call

name localcall

name internationalcall

name mobilecall

name chargenumbers

!

!

dial-peer cor list EMERGENCY

--More--                            member 888call

!

dial-peer cor list LOCAL

member localcall

!

dial-peer cor list MOBILE

member mobilecall

!

dial-peer cor list INTERNATIONAL

member internationalcall

!

dial-peer cor list CHARGENUMBERS

member chargenumbers

!

dial-peer cor list MOLOEM

member 888call

member localcall

member mobilecall

!

dial-peer cor list ALL

member 888call

member localcall

member internationalcall

member mobilecall

--More--                            member chargenumbers

!

!

dial-peer voice 1 voip

description Dial peer to ext on 2600

destination-pattern 600.

session target ipv4:172.18.0.1

dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 11 voip

description Dial peer to ext on 2600

preference 1

destination-pattern 600.

session target ipv4:172.17.0.2

dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 2 voip

corlist outgoing MOBILE

description Dial peer to UK mobiles

destination-pattern 907[1-9]........

session target ipv4:172.18.0.1

incoming called-number 0000000000

--More--                            dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 22 voip

description Dial peer to UK mobiles

preference 1

destination-pattern 907[1-9]........

session target ipv4:172.17.0.2

incoming called-number 0000000000

dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 3 voip

corlist outgoing LOCAL

description Dial peer to UK landline

destination-pattern 90[1-2].........

session target ipv4:172.18.0.1

incoming called-number 0000000000000

dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 33 voip

corlist outgoing LOCAL

description Dial peer to UK landline

--More--                            preference 1

destination-pattern 90[1-2].........

session target ipv4:172.17.0.2

incoming called-number 0000000000000

dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 4 voip

corlist outgoing INTERNATIONAL

description Dial peer to international

destination-pattern 900T

session target ipv4:172.18.0.1

dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 44 voip

corlist outgoing INTERNATIONAL

description Dial peer to international

preference 1

destination-pattern 900T

session target ipv4:172.17.0.2

dtmf-relay h245-alphanumeric

codec g729br8

!

--More--                           dial-peer voice 844 voip

corlist outgoing CHARGENUMBERS

description Dial peer to 0844 numbers

destination-pattern 90844.......

session target ipv4:172.18.0.1

dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 844844 voip

corlist outgoing CHARGENUMBERS

description Dial peer to 844 numbers

preference 1

destination-pattern 90844.......

session target ipv4:172.17.0.2

dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 911 voip

corlist outgoing CHARGENUMBERS

description Dial peer to 0911 numbers

destination-pattern 90911.......

session target ipv4:172.18.0.1

dtmf-relay h245-alphanumeric

codec g729br8

--More--                           !

dial-peer voice 911911 voip

corlist outgoing CHARGENUMBERS

description Dial peer to 0911 numbers

preference 1

destination-pattern 90911.......

dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 5 voip

corlist outgoing EMERGENCY

description Dial peer to emergency

destination-pattern 888

session target ipv4:172.18.0.1

dtmf-relay h245-alphanumeric

codec g729br8

!

dial-peer voice 55 voip

corlist outgoing EMERGENCY

description Dial peer to emergency

preference 1

destination-pattern 888

session target ipv4:172.17.0.2

dtmf-relay h245-alphanumeric

--More--                            codec g729br8

!

!

num-exp 0 5002

!

!

telephony-service

max-ephones 20

max-dn 40

ip source-address 172.31.100.100 port 2000

timeouts ringing 15

cnf-file location flash:

network-locale GB

load 7960-7940 P0030801SR02.loads

time-format 24

date-format dd-mm-yy

max-conferences 4 gain -6

moh piano1.raw

web admin system name geovani secret 5 $1$/bdX$.dVoJQyULiTg3gitqqku7/

transfer-system full-consult

secondary-dialtone 9

create cnf-files version-stamp 7960 Aug 06 2012 23:42:52

!

--More--                           !

ephone-dn  1  dual-line

number 5001

pickup-group 6666

label Geovani 5001

description phone

name Geovani Goncalves

call-forward busy 5002

call-forward noan 6001 timeout 18

corlist incoming MOLOEM

hold-alert 15 originator

!

!

ephone-dn  2  dual-line

number 5002

pickup-group 6666

description Matheus

name Matheus Guedes

corlist incoming EMERGENCY

!

!

ephone  3

device-security-mode none

mac-address 60EB.69F5.72B4

--More--                            button  1:1

!

!

!

!

line con 0

exec-timeout 0 0

password 7 110A1016141D4B

logging synchronous

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

password 7 01100F175804

login

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp master

ntp server 194.35.252.7

ntp server 66.27.60.10

ntp server 200.50.25.62

end

SWITCH:

Current configuration : 7092 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname S3550

!

no aaa new-model

authentication mac-move permit

ip subnet-zero

ip routing

no ip domain-lookup

ip dhcp excluded-address 172.21.1.1 172.21.1.20

ip dhcp excluded-address 172.21.1.100 172.21.1.150

--More--                           ip dhcp excluded-address 172.21.5.1 172.21.5.20

ip dhcp excluded-address 172.21.5.50 172.21.5.100

ip dhcp excluded-address 172.26.10.1 172.26.10.20

ip dhcp excluded-address 172.26.5.1 172.26.5.20

!

ip dhcp pool Vlan100Voice

   import all

   network 172.21.1.0 255.255.255.0

   default-router 172.20.0.2

   dns-server 4.2.2.2

   option 150 ip 172.31.100.100

!

ip dhcp pool Vlan50Data

   import all

   network 172.21.5.0 255.255.255.0

   default-router 172.20.0.2

   dns-server 4.2.2.2

!

ip dhcp pool Vlan10Voice

   import all

   network 172.26.10.0 255.255.255.0

   default-router 172.25.0.2

   dns-server 4.2.2.2

--More--                           !

ip dhcp pool Vlan5Data

   import all

   network 172.26.5.0 255.255.255.0

   default-router 172.25.0.2

   dns-server 4.2.2.2

!

!

!

!

crypto pki trustpoint TP-self-signed-605573248

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-605573248

revocation-check none

rsakeypair TP-self-signed-605573248

!

!

crypto pki certificate chain TP-self-signed-605573248

certificate self-signed 01

  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 36303535 37333234 38301E17 0D393330 33303130 30303130

  305A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F

--More--                             532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3630 35353733

  32343830 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100

  D74F45E5 0E1DA0CF A469A89D 99C572F2 9DEF1211 7FA134BD 98128F8C 61B99069

  8C5E9C96 D3C93EF1 57D3EC2C 8BCAA39E 0A15ED48 1C1775C3 D7ABAC73 86327F4C

  76F2D11C 68E6F22E 6EC039AE 1DF9E7DD 405178AA 916003C3 72122E50 C6309718

  4D50EC65 9DE4E252 A0D8E6BF 99B46572 C6E23A66 93FAC298 821A736B 6BC2E893

  02030100 01A36630 64300F06 03551D13 0101FF04 05300301 01FF3011 0603551D

  11040A30 08820653 33353530 2E301F06 03551D23 04183016 80149AD6 0FFC542F

  7086A508 37405942 5B2C1511 7CFB301D 0603551D 0E041604 149AD60F FC542F70

  86A50837 4059425B 2C15117C FB300D06 092A8648 86F70D01 01040500 03818100

  CAEEBD0D 93A6B508 8B012F6A BAEC7F1A 2CCF8030 705B1938 895B937C B471E477

  8D62ADC5 BA5F9AEA 62541E03 4EFA0F29 57636502 0B606BD0 CB219B56 4233A6B8

  803A4E2E A080D6FF AEF715E9 D850FE69 432914CE E4DD91AE F10A6D2E E35E474B

  74DEF808 F67CA3F4 DF06A65E 2E09EA44 6996B3B6 5932D6A1 FEB34D44 3DE2B9BA

  quit

spanning-tree mode pvst

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

interface Loopback0

ip address 172.31.10.10 255.255.255.0

!

interface FastEthernet0/1

no switchport

ip address 172.25.0.3 255.255.0.0

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 5

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 5

switchport mode access

switchport voice vlan 10

--More--                            spanning-tree portfast

!

interface FastEthernet0/4

switchport access vlan 5

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/5

switchport access vlan 5

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/6

switchport access vlan 5

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/7

switchport access vlan 5

switchport mode access

--More--                            switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/8

switchport access vlan 5

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/9

switchport access vlan 5

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/10

switchport access vlan 5

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/11

switchport access vlan 5

--More--                            switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/12

switchport access vlan 5

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/13

switchport access vlan 50

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/14

switchport access vlan 50

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/15

--More--                            switchport access vlan 50

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/16

switchport access vlan 50

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/17

switchport access vlan 50

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/18

switchport access vlan 50

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

--More--                           interface FastEthernet0/19

switchport access vlan 50

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/20

switchport access vlan 50

switchport mode dynamic desirable

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/21

switchport access vlan 50

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/22

switchport access vlan 50

switchport mode access

switchport voice vlan 100

spanning-tree portfast

--More--                           !

interface FastEthernet0/23

switchport access vlan 50

switchport mode access

switchport voice vlan 100

spanning-tree portfast

!

interface FastEthernet0/24

no switchport

ip address 172.20.0.3 255.255.0.0

!

interface GigabitEthernet0/1

switchport mode dynamic desirable

!

interface GigabitEthernet0/2

switchport mode dynamic desirable

!

interface Vlan1

no ip address

shutdown

!

interface Vlan5

ip address 172.26.5.5 255.255.255.0

--More--                            ip helper-address 172.25.0.2

!

interface Vlan10

ip address 172.26.1.10 255.255.255.0

ip helper-address 172.25.0.2

!

interface Vlan50

ip address 172.21.5.50 255.255.255.0

!

interface Vlan100

ip address 172.21.1.100 255.255.255.0

!

!

router eigrp 1

network 172.16.0.0

network 172.17.0.0

network 172.18.0.0

network 172.19.0.0

network 172.20.0.0

network 172.21.0.0

network 172.26.0.0

network 172.31.0.0

!

--More--                           ip classless

ip route 0.0.0.0 0.0.0.0 172.20.0.2

ip http server

ip http secure-server

!

!

ip sla enable reaction-alerts

!

control-plane

!

!

line con 0

exec-timeout 0 0

logging synchronous

line vty 0 4

exec-timeout 0 0

password cisco

logging synchronous

login

line vty 5 15

login

!

end

--More--                          

Can you please help me out to figure out what's wrong?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: 7940 IP Phone wont register to CME 8.6, in loop.

Not weird, this is wrong.

ip dhcp pool Vlan100Voice

  network 172.21.1.0 255.255.255.0

   default-router 172.20.0.2

default gateway must be always within subnet.

10 REPLIES
Hall of Fame Super Gold

7940 IP Phone wont register to CME 8.6, in loop.

What the phone shows? Do they have SCCP fimrware ?

You can take "debug tftp events" to begin with.

New Member

7940 IP Phone wont register to CME 8.6, in loop.

Hi Paolo,

When telneted into the router, I've tried to debug the tftp events, but nothing came up.

When the phones are powered on, it shows all the steps but it goes on a loop.

The phones are able to pick up an ip address and all the network configuration.

Note that when I point a CIPC to the tftp it register and works fine.

thanks again

Hall of Fame Super Gold

7940 IP Phone wont register to CME 8.6, in loop.

Have "term mon" with any debug command.

If you don't see output, means no or wrong option 150 in DHCP.

New Member

7940 IP Phone wont register to CME 8.6, in loop.

Thanks Paolo again.

Will try it tomorrow.

Does my layer 3 switch and router looks ok to you? Can you see anything wrong?

Not sure what can go wrong with option 150, as long as it is pointing to the right tftp server, and in this case it is.

Thanks

New Member

7940 IP Phone wont register to CME 8.6, in loop.

Paolo,

I have tried using "term mon" with "debug tftp" but nothing came up.

Any other ideas?

The option 150 is on and the phone is picking up the tftp address.

Thanks

Hall of Fame Super Gold

Re: 7940 IP Phone wont register to CME 8.6, in loop.

With the browser, open phone IP address and check logs, may that will reveal something.

New Member

7940 IP Phone wont register to CME 8.6, in loop.

Thanks Paolo,

I cannont access the phone using the browser and i cant ping it neither.

I have just reverted everything back as it was, using rounter on the stick, and the phones are registering just fine.

Weird.

Hall of Fame Super Gold

Re: 7940 IP Phone wont register to CME 8.6, in loop.

Not weird, this is wrong.

ip dhcp pool Vlan100Voice

  network 172.21.1.0 255.255.255.0

   default-router 172.20.0.2

default gateway must be always within subnet.

New Member

7940 IP Phone wont register to CME 8.6, in loop.

Bang on Paolo, many thanks for your help.

It's all working now.

Hall of Fame Super Gold

7940 IP Phone wont register to CME 8.6, in loop.

Thank you for the nice rating and good luck!

2000
Views
0
Helpful
10
Replies
CreatePlease to create content