Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

7940 not resetting

We recently upgraded our CallManager from 4.1 to 8.6 and we have one 7940 phone that was configured for an extension 8774 and we replaced that phone with another 7940 phone and transferred that number to the new phone.  The new phone has the correct extension but so does the old phone.  They both have the same extension. We deleted the phone in the CallManager but when the phone boots it comes up with the same extension and configuration.  It dials and receives calls just like the "new" phone.  I have 2 phones with the exact same configuration and extension but one doesn't want to let go of it and pick up the AutoRegistration numbers.

I have done a factory reset but when it resets it comes up with the same config.

Any ideas?

7 REPLIES
New Member

7940 not resetting

I have seen this kind of problem when you replication issues.  You make a change on the PUB and it is not replicated to the SUB which is what the phone is registering with.  There could be other things, but this one is often the result of an upgrade that didn't go smoothly.  When you did the upgrade did you delete your subscriber(s) and recreate them or upgrade them? 

New Member

7940 not resetting

Truthfully we had a consultant upgrade us from 4.1 to 6 (I believe) and then to version 8, so i am not exactly sure if he had problems with the upgrade.  Is there a place that you recommend I look at to try and find a fix?

New Member

7940 not resetting

The best way that I know of to check replications is to issue the following command on each call manager's console command line:

show perf query class "Number of Replicates Created and State of Replication"

Here's an example:

***

Last login: Fri Nov 18 22:59:52 2011 from 172.17.77.1

   Welcome to the Platform Command Line Interface

admin:show perf query class "Number of Replicates Created and State of Replication"

==>query class :

- Perf class (Number of Replicates Created and State of Replication) has instances and values:

    ReplicateCount  -> Number of Replicates Created   = 393

    ReplicateCount  -> Replicate_State                = 2

admin:

***

You are looking for a state of 2.  Do this on each Call Manager you have in your cluster, either from the server console or you can use a terminal emulator that supports SSH to log on from a machine on your network.  If you are suffering from the problem that I had you will have something other than a 2 on your subscriber.

Here's a troubleshooting article from Cisco:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/trouble/7_0_1/tbsystem.html#wp1173648

Thanks, Gene Starr CCIE #8313

If you find the answer useful, please rate it.

New Member

7940 not resetting

gstarr thanks for the replies and on both publisher and subscriber I get the following.

- Perf class (Number of Replicates Created and State of Replication) has instances and values:
    ReplicateCount  -> Number of Replicates Created   = 541
    ReplicateCount  -> Replicate_State                = 2

Although on the RTMT I get an Alert 2 days ago for DBReplicationFailure so it seems like there is a failure but only intermittently and would this cause the phones to continue with their "old configs"?

Super Bronze

7940 not resetting

Or on recent CUCMs:

utils dbreplication runtimestate

Nice and concise :-)

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

7940 not resetting

Here is what I get on both pub and subscriber so it seems like they are replicating properly

Cluster Detailed View from PUB (2 Servers):

                                PING            REPLICATION     REPL.   DBver& REPL.    REPLICATION SETUP
SERVER-NAME     IP ADDRESS      (msec)  RPC?    STATUS          QUEUE   TABLES LOOP?    (RTMT) & details
-----------     ------------    ------  ----    -----------     -----   ------------    -----------------
TBFCMPUB        X.X.X.X  0.054   Yes     Connected       0       match  Yes      (2) PUB Setup Completed
TBFCMSUB1       X.X.X.Y  0.133   Yes     Connected       0       match  Yes      (2) Setup Completed

New Member

7940 not resetting

Good deal - doesn't look like replication is your problem.  So let's make sure I understand the symptoms:  You have two 7940 phones registered with CM with the extension of 8774.  You delete one of the phone records from Call Manager but when the phone that was deleted registers the next time it keeps it's old configuration and once again matches the new phone. That sound right?

422
Views
0
Helpful
7
Replies
CreatePlease login to create content