Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

7960 not receiving dhcp

Hi all!

Cisco phone 7960 is not receiving an ip add. We have tried a factory reset but both methods do not seem to work. DHCP requests sent to the router from this phone are ignored. Other phones are all functioning properly. Port configurations are correct. please help troubleshoot

interface FastEthernet0/6

description To Internal voice and Data

!

switchport access vlan 131

switchport mode access

switchport voice vlan 11

mls qos trust device cisco-phone

spanning-tree portfast

!

DHCP settings for the router:

ip dhcp excluded-address 10.32.222.251 10.32.222.254

!

ip dhcp pool ITS

   network 10.32.222.0 255.255.255.0

   option 150 ip 10.32.222.251

   default-router 10.32.222.251

   lease 30

!

Aug 22 14:22:22.088: DHCP: Received a BOOTREP pkt Not for us..:  xid: 0x331A59DF

First Method:

Reset the 7940 and 7960 IP Phones to the Factory Default

In order to perform a factory reset of a phone if the password is set, complete these steps:

  • •1.     Unplug the power cable from the phone, and then plug in the cable again.

The phone begins its power up cycle.

  • •2.     Immediately press and hold # and while the Headset, Mute, and Speaker buttons begin to flash in sequence, release #.

The Headset, Mute, and Speaker buttons flash in sequence in order to indicate that the phone waits for you to enter the key sequence for the reset.

  • •3.     Press 123456789*0# within 60 seconds after the Headset, Mute, and Speaker buttons begin to flash.

If you repeat a key within the sequence, for example, if you press 1223456789*0#, the sequence is still accepted and the phone resets.

If you do not complete this key sequence or do not press any keys, after 60 seconds, the Headset, Mute, and Speaker buttons no longer flash, and the phone continues with its normal startup process. The phone does not reset.

If you enter an invalid key sequence, the buttons no longer flash, and the phone continues with its normal startup process. The phone does not reset.

If you enter this key sequence correctly, the phone displays this prompt:

Keep network cfg? 1 = yes 2 = no

  • •4.     In order to maintain the current network configuration settings for the phone when the phone resets, press 1. In order to reset the network configuration settings when the phone resets, press 2.

If you press another key or do not respond to this prompt within 60 seconds, the phone continues with its normal startup process and does not reset. Otherwise, the phone goes through the factory reset process.

Second Method:

Method 2

Complete these steps:

  • •1.    Choose the main Date/Time window.
  • •2.    Press **# in order to unlock the Network Configuration on the phone.
  • •3.    Press Settings.
  • •4.    The Network Configuration lock symbol must be unlocked. If not, exit to the main window and press ** # again.
  • •5.    Press 3 on the keypad (or scroll down) for Network Configuration.
  • •6.    Press 33 on the keypad (or scroll down) to Erase Configuration.
  • •7.    Press the Yes softkey.
  • •8.    Press the Save softkey.
  • IP Telephony
Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Green

7960 not receiving dhcp

Faith,

I had a similar problem as this years ago with 7940/60s.

The phone had stopped sending tagged packets within the voice vlan.

Try these adjustments to your config

!

switchport access vlan 131

shut

no switchport voice vlan 11

switchport access vlan 11

no shut

!

See if the phone then finds an address and registers with the CME.

Then put the port on the switch back to normal

!

switchport access vlan 131

shut

no switchport access vlan 11

switchport mode access

switchport access vlan 1

switchport voice vlan 11

no shut

!

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
5 REPLIES
VIP Super Bronze

7960 not receiving dhcp

Is the phone in a seperate VLAN from the DHCP server? If so have you configured ip helper-address on the phone's vlan

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Green

7960 not receiving dhcp

Faith,

I had a similar problem as this years ago with 7940/60s.

The phone had stopped sending tagged packets within the voice vlan.

Try these adjustments to your config

!

switchport access vlan 131

shut

no switchport voice vlan 11

switchport access vlan 11

no shut

!

See if the phone then finds an address and registers with the CME.

Then put the port on the switch back to normal

!

switchport access vlan 131

shut

no switchport access vlan 11

switchport mode access

switchport access vlan 1

switchport voice vlan 11

no shut

!

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
New Member

7960 not receiving dhcp

Hi Alex!

Thank you. I will try this in the morning and let you know if it helped.

New Member

7960 not receiving dhcp

Hi aokanlawon!

I think it's safe to say that the dhcp configurations on the router are correct since there are several other phones in the branch and all are connected to that one switch which is connected to the call manager!

But yes, the issue is with the ip adds. The phone was connected to a different subnet before. Tat was why I tried doing the factory reset! This helped because now when I do a show cep nei command on the switch, the ip address is gone! But the phone still cannot Get the right configurations.

We also tried changing the FTP server but we were unable to do it even after following the instructions on Cisco com

New Member

7960 not receiving dhcp

Alex!

Thank you!!! It worked. At the end of it all, i changed the access vlan back to 131.

2203
Views
0
Helpful
5
Replies