Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

7960 SIP Registration Rejected

Hi, I'm running Callmanager 5.0(4)

I can autoregister and manually add 7960's as SCCP phones with no problem.

When I try to autoregister or add them as SIP phones I receive a 'Registration Rejected' error.

I can register 3rd party SIP phones with no problems.

I'm not associating any users or digest authentication on the 7960's, I don't think this should be necessary?

The Callmanager has been installed with a default configuration.

Does anyone know what is causing this?

Thanks!

1 REPLY
New Member

Re: 7960 SIP Registration Rejected

I finally figured out the problem with the phones when I was waiting for my train last night- it turned out it wasn?t actually anything to do with SIP. The way things had gone led me down that path and I needed to get away from the office before I could think straight about it.

I?d added the phones as SCCP with autoregistration. I then tried to add a SIP phone manually but this failed. It took the SIP firmware okay but was coming up as ?Registration Rejected.? I thought I had maybe misconfigured authentication or something so the next thing I tried was to autoregister the phones with SIP. SIP autoregistration came up as ?Registration Rejected? as well though. This had me thinking that there was something wrong with SIP phones registering, maybe a configuration issue or missing parameter. It was something a lot more simple though- I?d configured the autoregistration range for existing phones and the directory numbers had been taken when the phones registered with SCCP. When I deleted the SCCP phones their directory numbers were still in the system, so there were no numbers available when they tried to autoregister with SIP.

When I came in this morning I deleted the DN?s from the system and SIP autoregistration worked fine. I also added a SIP phone manually this morning. I?m not sure why I couldn?t do that last night as I double-checked the MAC address was correct. I?m still not sure what the problem was there but never mind everything?s working fine now.

948
Views
0
Helpful
1
Replies