Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

7970 Factory reset and firmware.

We are testing out a 7970 phone on our Call manager 4.1 system, the phone has been gather dust in the corner of room so we knew that the firmware was going to be out of date..

the phone intially seemed to pick up an generic phone address correctly and we could ping it on the network, however it did not seem to register on Call manager..

After browsing through the firmware downloads, we loaded on the 8.2 version onto the phone..

We now have two problems..

1/ The display does not seem to work anymore..

2/ the usual default factory reset # then 123456789*0# does not reset the phone anymore.. The line button just continually flashes in sequence after you press the buttons to reset...

Does any one know if there is another way we can reset the phone back to default... or will downloading an older firmware version and try tftping that to the phone solve this display issue ??

Cheers in advance for any suggestions.

Hall of Fame Super Red

Re: 7970 Factory reset and firmware.

Hi Jon,

If this phone had a really old firmware on it, the upgrade to 8.x loads would be a two step process. Can you try going to a 7.x load and then to 8.2?

Hope this helps!


Community Member

Re: 7970 Factory reset and firmware.

Thanks for the reply..

yep, thats what Im attempting to do..

problem is.. can I do it without doing a factory reset on the phone first ( which is currenlty not working ! )


can I simply load an older version of firmware onto call manager ( 7x as suggested ) and let the tftp do its business ??..

Hall of Fame Super Red

Re: 7970 Factory reset and firmware.

Hi Jon,

Not sure :(

Have you tried this alternate reset sequence?

Power off the phone.

Hold down the # key.

While holding #, connect an AC adaptor to the phone.

Continue to hold # until the line buttons blink amber.

Release the # key.

Enter 3491672850*#

The lights should change color from amber to red. When this occurs, the phone is resetting to factory defaults.

Note: It is important to try this procedure with a external power supply.

Hope this helps!


Community Member

Re: 7970 Factory reset and firmware.

Good morning Rob,

I have exactly the same problem like Jon.

After the "1234..."-Factoryreset the Display is dark and it seems, that reboot-sequence starts again and again.

Even the "3491..."-Reset doesn't work.

Do you have an idea, how to "switch-on" the Display again???

Thanks a lot and kind regards from Germany


Community Member

Re: 7970 Factory reset and firmware.

Hi guys.. Still no luck on this.

Thanks for you help on this but I am still having not luck with reseting this phone..

I have tried both reset sequences but the line button remain flashing.. and nothing appears on the display

Is it possible to force the phone to a older firmware version via CM if you cant see it registered but you can ping the phones IP address on the network ??..



Hall of Fame Super Gold

Re: 7970 Factory reset and firmware.


when the reset sequence appears to not work, most likely something is wrong with DHCP and TFTP. So you have to monitor these services and make sure the necessary files are available to the phones. Note depending on the model it can take even like 10 minutes for the phone to reflash without any display activity (off).

Community Member

Re: 7970 Factory reset and firmware.

The DHCP and TFTPs services are fine because we set up our standard 7960s and 7940s everyday..

I have downloaded ver6 of the firmware for this 7970.. The problem is trying to get it on the phone if I cant see whats on screen and I cant reset the phone back..

Are there any other alternative ways of getting the firmware on with out going via CM ??..


CreatePlease to create content