Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

8945 - Messages button not auto dialing VM

Just installed the cmterm-devicepack8.6.2.24097-1 device pak for 8831 functionality in our 8.6.2 system.  Since that install, our 8945 phones do not auto dial the VM pilot number when the messages key is pressed.  Instead, a visual menu appears that says "Voicemail".  If I press the "Open" softkey, then it dials the pilot number and funtions as normal.

Any ideas why the messages key no longer auto dials the pilot number when pressed?

1 ACCEPTED SOLUTION

Accepted Solutions

8945 - Messages button not auto dialing VM

Can you confirm your CUCM full version.

Believe this is due to CSCug20251

regards

Please Kudos/rate if this help!

Please Kudos/rate if this help!
15 REPLIES
Cisco Employee

8945 - Messages button not auto dialing VM

This happens when the messages button changes from being set to Application:Cisco/Voicemail to the URL

http://publisherhostname:8080/ccmcip/getmessagesmenu.jsp.  If you check the phone's web page after enabled web access what do you see under network configuration for messages URL?

Community Member

Re: 8945 - Messages button not auto dialing VM

That field is blank and according to documentation, CUCM does not use this field.

Community Member

Re: 8945 - Messages button not auto dialing VM

A little more info...

I have confirmed that the issue we are seeing is with the firmware version that was contained in the device pak.  That firmware is the latest SCCP8941_8945.9-3-4-17.  I downgraded the firmware on one phone to SCCP8941_8945.9-3-2-11 and functionality was restored.

I also discovered that it has to do with the phone services option on the phone.  If I change the “Services Provisioning” field on the phone itself to “Internal”, then the messages button works OK.  However, that breaks any external XML services being used.  Perhaps the added functionality in the latest firmware of visual voicemail for the 8945’s broke this feature.

TAC case open.

8945 - Messages button not auto dialing VM

Can you confirm your CUCM full version.

Believe this is due to CSCug20251

regards

Please Kudos/rate if this help!

Please Kudos/rate if this help!
Community Member

8945 - Messages button not auto dialing VM

System version: 8.6.2.22900-9

Can't view bug, "Insufficient Permissions to View Bug".

8945 - Messages button not auto dialing VM

hi,

Bug was actully create for version of 9.1,

But the bug resides on the firmware, so pretty sure its the same bug ID.

regarding now been able to check the bug details, its because there is something up with your account. You proably need your Account Manager check in to this, or you can always call cisco Customer service (not tac) to check your account permissions.

Please Kudos/rate if this help!

Please Kudos/rate if this help!
Community Member

Re: 8945 - Messages button not auto dialing VM

Seems the bug is Cisco internal only.  I've had several peers try as well with same results.

"This bug contains proprietary information and is not yet publicly available."

Community Member

8945 - Messages button not auto dialing VM

Wanted to update everyone that it is a new bug.

https://tools.cisco.com/bugsearch/bug/CSCul85579

As I mentioned earlier, if your default "Services Provisioning" setting is "internal" or the phone is manually set to "internal", then you do not see the behavior.  However, if you are using extenal services as well, then your only current option is to downgrade the firmware.

The bug really only adds one extra step to retrieving voicemail, but users are then no longer able to press the "forward all" softkey and the "messages" button to forward phone to voice mail.  They would have to "forward all" and the VM pilot number.

8945 - Messages button not auto dialing VM

Hi,

I think you can give a try by setting service provisioning to "Both" (either device level or globally in enterprise parameter) and check the result.

Regards,

Nishant Savalia

Regards, Nishant Savalia
Community Member

8945 - Messages button not auto dialing VM

You CANNOT use the "Both" option.  It was tested.  The only configuration that works is "Internal".  If you use "Internal", it breaks any external services you are using.

I'm sure has to do with the Visual Voicemail feature that was added to the 8945 in this release.

Community Member

8945 - Messages button not auto dialing VM

Any traction on this one? I'm seeing the same thing in 9.4.1 (supposedly the 'fixed-in' version) and I'm running CUCM 8.6.2 which according to the bug is not affected anyway.

Community Member

8945 - Messages button not auto dialing VM

jimander wrote:

Any traction on this one? I'm seeing the same thing in 9.4.1 (supposedly the 'fixed-in' version) and I'm running CUCM 8.6.2 which according to the bug is not affected anyway.

Was not aware of the 9.4.1 firmware.  I will download and try tomorrow.  I too am running 8.6.2.

8945 - Messages button not auto dialing VM

I have seen TAC publish specific ES versions of firmware for 8945 to fix this issue, so i would sugges engaging TAC to get the ES as well as check why its still not fixed in ver 9.4.1, bug applies to CME though.

https://tools.cisco.com/bugsearch/bug/CSCuj85589/?reffering_site=dumpcr

Symptom:

The "messages" button on a Cisco 8941 or 8945 IP  phone will stop working when registered to a Cisco Unified  Communications Manager Express (CME) system.

Conditions:

The  problem is observed when the Cisco 8941 or 8945 IP phone is running  firmware versions 9-3-4-10 or 9-3-4-17 and only when registered to a CME  system. Problem is not observed when the same phone model is registered  to a Cisco Unified Communications Manager cluster (using the same  firmware versions).

Workaround:

Downgrade the 8941/8945 phone firmware to 9-2-3-5.

Manually dial the voicemail pilot number.

HTH

Manish

Community Member

8945 - Messages button not auto dialing VM

Manish Gogna wrote:

I have seen TAC publish specific ES versions of firmware for 8945 to fix this issue, so i would sugges engaging TAC to get the ES as well as check why its still not fixed in ver 9.4.1, bug applies to CME though.

https://tools.cisco.com/bugsearch/bug/CSCuj85589/?reffering_site=dumpcr

The bug is not just a CME bug. 

My original bug https://tools.cisco.com/bugsearch/bug/CSCul85579 is being redirected to the bug you list and says, "

Bug CSCul85579 is a duplicate of the bug displayed below".  However, the bugs are not duplicates and there are differences.

jimander

- I upgraded a phone to SCCP 9-4-1-9 and am still seeing the issue with the messages button.  I have re-engaged TAC to have them re-open my bug and get it fixed.

At this time, the only work around is to downgrade (I used SCCP 9-3-2-11) or have users manually dial the pilot number.  I much prefer the former option.

1558
Views
10
Helpful
15
Replies
CreatePlease to create content