Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

911 Dial-Peer Issue

I seem to be having an issue with dialing 911.  User is getting dialtone after dialing 911.  Here is my config.

dial-peer cor custom

name PSTN

name PBX

name VOIP

!                

dial-peer cor list TargetPSTN

member PSTN

!        

dial-peer cor list TargetPBX

member PBX

!        

dial-peer cor list TargetVOIP

member VOIP

!   

dial-peer voice 98 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

destination-pattern 911

incoming called-number 911

port 0/0/1:23

forward-digits 3

!        

dial-peer voice 99 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

destination-pattern 911

incoming called-number 911

port 0/0/0:23

forward-digits all

Thanks in advance. 

1 ACCEPTED SOLUTION

Accepted Solutions
Green

911 Dial-Peer Issue

Mike

Can you remove the COR

and test again

!        

dial-peer voice 98 pots

no corlist incoming TargetPBX

no corlist outgoing TargetPSTN

!

!       

dial-peer voice 99 pots

no corlist incoming TargetPBX

no corlist outgoing TargetPSTN

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
11 REPLIES
Green

911 Dial-Peer Issue

Mike,

Can you post

debug isdn q931 of a failed call

Also the config or info about your sytem

CUCM or CME

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
New Member

911 Dial-Peer Issue

Actually its a temporary Gateway that we have between an NEC and the PSTN , so we can strip DIDs off as people migrate to CUCM.  I will work on getting a debug.

Thanks.

911 Dial-Peer Issue

Hi Mike,

Can you post a debug voip dial-peer and the q931 mentioned above.

Try adding direct-inward-dial to your dial-peers 98 & 99

HTH,

Chris

New Member

911 Dial-Peer Issue

Here is the debug.

*Jul 19 10:18:15.507: ISDN Se0/0/1:23 Q931: RX <- CALL_PROC pd = 8  callref = 0xDFAE

        Channel ID i = 0xA98397

                Exclusive, Channel 23

*Jul 19 10:18:17.167: ISDN Se0/0/1:23 Q931: RX <- ALERTING pd = 8  callref = 0xDFAE

        Progress Ind i = 0x8488 - In-band info or appropriate now available

*Jul 19 10:18:17.175: ISDN Se0/1/0:23 Q931: TX -> ALERTING pd = 8  callref = 0x8100

        Progress Ind i = 0x8488 - In-band info or appropriate now available

*Jul 19 10:18:20.831: ISDN Se0/1/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0200

        Bearer Capability i = 0x8090A2

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA9838D

                Exclusive, Channel 13

        Progress Ind i = 0x8181 - Call not end-to-end ISDN, may have in-band info 

        Calling Party Number i = 0xA1, '651XXXXXXX'

                Plan:ISDN, Type:National

        Called Party Number i = 0xA1, '911'

                Plan:ISDN, Type:National

*Jul 19 10:18:20.843: %ISDN-6-CONNECT: Interface Serial0/1/0:12 is now connected to 651XXXXXXX N/A

*Jul 19 10:18:20.847: ISDN Se0/1/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8200

        Channel ID i = 0xA9838D

                Exclusive, Channel 13

*Jul 19 10:18:20.847: ISDN Se0/1/0:23 Q931: TX -> CONNECT pd = 8  callref = 0x8200

*Jul 19 10:18:20.931: ISDN Se0/1/0:23 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x0200

*Jul 19 10:18:31.439: ISDN Se0/1/1:23 Q931: RX <- DISCONNECT pd = 8  callref = 0xDF9F

        Cause i = 0x8190 - Normal call clearing

*Jul 19 10:18:31.439: %ISDN-6-DISCONNECT: Interface Serial0/1/1:0  disconnected from 4525 , call lasted 942 seconds

*Jul 19 10:18:31.443: ISDN Se0/1/1:23 Q931: TX -> RELEASE pd = 8  callref = 0x5F9F

*Jul 19 10:18:31.447: %ISDN-6-DISCONNECT: Interface Serial0/0/1:0  disconnected from 612XXXXXXX , call lasted 942 seconds

*Jul 19 10:18:31.451: ISDN Se0/0/1:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8091

        Cause i = 0x8090 - Normal call clearing

*Jul 19 10:18:31.499: ISDN Se0/0/1:23 Q931: RX <- RELEASE pd = 8  callref = 0x0091

*Jul 19 10:18:31.503: ISDN Se0/0/1:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8091

*Jul 19 10:18:31.539: ISDN Se0/1/1:23 Q931: RX <- RELEASE_COMP pd = 8  callref = 0xDF9F

Green

911 Dial-Peer Issue

Mike,

We see the call is incoming on
S0/1/0:23
*Jul 19 10:18:20.831: ISDN Se0/1/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0200

Which dial peer do calls on PORT 0/1/0:23 match

Think you will need to provide more or all of show run

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
New Member

911 Dial-Peer Issue

network-clock-participate wic 0

network-clock-participate wic 1

network-clock-select 1 T1 0/0/0

network-clock-select 2 T1 0/0/1

!

!

ip cef

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

isdn switch-type primary-ni

!

voice-card 0

no dspfarm

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to sip

h323

modem passthrough nse codec g711ulaw

sip

!

!

!

!

!

!

!

!

!

!

voice translation-rule 3

rule 1 /7029/ /6515237029/

!

!

voice translation-profile profile1

translate calling 3

!

!

!

!

!

!

controller T1 0/0/0

framing esf

linecode b8zs

pri-group timeslots 1-24

description PRI coming from the PSTN

!

controller T1 0/0/1

framing esf

linecode b8zs

pri-group timeslots 1-24

description PRI coming from the PSTN

!

controller T1 0/1/0

framing esf

clock source internal

linecode b8zs

pri-group timeslots 1-24

description To Switch

!

controller T1 0/1/1

framing esf

clock source internal

linecode b8zs

pri-group timeslots 1-24

description To Switch

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.220.41.99 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Serial0/0/1:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Serial0/1/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn protocol-emulate network

isdn incoming-voice voice

no cdp enable

!

interface Serial0/1/1:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn protocol-emulate network

isdn incoming-voice voice

no cdp enable

!

ip default-gateway 10.220.41.1

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.220.41.1

!

!

ip http server

no ip http secure-server

!

logging 10.1.1.95

snmp-server community OSIMonitor RO 5

!

!

!

control-plane

!

!

!

voice-port 0/0/0:23

!

voice-port 0/1/0:23

!

voice-port 0/0/1:23

!

voice-port 0/1/1:23

!

!

!

!

dial-peer cor custom

name PSTN

name PBX

name VOIP

!

!

dial-peer cor list TargetPSTN

member PSTN

!

dial-peer cor list TargetPBX

member PBX

!

dial-peer cor list TargetVOIP

member VOIP

!

!

dial-peer voice 6 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

description Outbound

destination-pattern [2-9].........$

incoming called-number [1-7]...$

direct-inward-dial

port 0/0/0:23

forward-digits 10

!

dial-peer voice 7 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

description Outbound

destination-pattern [2-9].........$

incoming called-number [1-7]...$

direct-inward-dial

port 0/0/1:23

forward-digits 10

!

dial-peer voice 8 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

description Outbound

destination-pattern [2-9]......T

incoming called-number [1-7]...$

direct-inward-dial

port 0/0/1:23

forward-digits 7

!

dial-peer voice 9 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

description Outbound

destination-pattern [2-9]......T

incoming called-number [1-7]...$

direct-inward-dial

port 0/0/0:23

forward-digits 7

!        

dial-peer voice 10 pots

corlist incoming TargetPSTN

corlist outgoing TargetPBX

description Inbound Dialin

translation-profile incoming Outbound

destination-pattern [1-7]...

incoming called-number .

no digit-strip

direct-inward-dial

port 0/1/0:23

!        

dial-peer voice 11 pots

corlist incoming TargetPSTN

corlist outgoing TargetPBX

description Inbound Dialin

translation-profile incoming Outbound

destination-pattern [1-7]...

incoming called-number .

no digit-strip

direct-inward-dial

port 0/1/1:23

!        

dial-peer voice 22 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

description Outbound LD

destination-pattern 1..........

no digit-strip

port 0/0/0:23

!        

dial-peer voice 23 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

description Outbound LD

destination-pattern 1..........

no digit-strip

port 0/0/1:23

!        

dial-peer voice 98 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

destination-pattern 911

incoming called-number 911

port 0/0/1:23

forward-digits 3

!        

dial-peer voice 99 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

destination-pattern 911

incoming called-number 911

port 0/0/0:23

forward-digits all

!        

dial-peer voice 411 pots

corlist incoming TargetPBX

corlist outgoing TargetPSTN

destination-pattern 411

incoming called-number 411

port 0/0/1:23

forward-digits all

!        

dial-peer voice 36 voip

description Connection to CUCM

destination-pattern 6787

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!        

dial-peer voice 35 voip

description Connection to CUCM

destination-pattern 7029

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!

dial-peer voice 37 voip

description Connection to CUCM

destination-pattern 6631

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!

dial-peer voice 38 voip

description Connection to CUCM

destination-pattern 6701

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!

dial-peer voice 39 voip

description Connection to CUCM

destination-pattern 6618

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!

dial-peer voice 40 voip

description Connection to CUCM

destination-pattern 6703

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!

dial-peer voice 41 voip

description Connection to CUCM

destination-pattern 6612

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!

dial-peer voice 42 voip

description Connection to CUCM

destination-pattern 6660

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!

dial-peer voice 43 voip

description Connection to CUCM

destination-pattern 6641

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!

dial-peer voice 44 voip

description Connection to CUCM

destination-pattern 6684

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!

dial-peer voice 45 voip

description Connection to CUCM

destination-pattern 6705

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

!

dial-peer voice 46 voip

description Connection to CUCM

destination-pattern 6663

session protocol sipv2

session target ipv4:10.1.100.31

dtmf-relay h245-alphanumeric

Green

911 Dial-Peer Issue

Mike

Can you add the following as Chris showed earlier:-

!        
!
dial-peer voice 98 pots
direct-inward-dial
!        
!
dial-peer voice 99 pots
direct-inward-dial
!

Test again

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
New Member

911 Dial-Peer Issue

Still failing.  Here is the debug.  Thanks.

*Jul 19 11:37:42.339: ISDN Se0/1/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0100

        Bearer Capability i = 0x8090A2

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98382

                Exclusive, Channel 2

        Progress Ind i = 0x8181 - Call not end-to-end ISDN, may have in-band info 

        Calling Party Number i = 0xA1, '651XXXXXX'

                Plan:ISDN, Type:National

        Called Party Number i = 0xA1, '911'

                Plan:ISDN, Type:National

*Jul 19 11:37:42.355: ISDN Se0/1/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8100

        Channel ID i = 0xA98382

                Exclusive, Channel 2

*Jul 19 11:37:42.363: ISDN Se0/1/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8100

        Cause i = 0x8281 - Unallocated/unassigned number

*Jul 19 11:37:42.471: ISDN Se0/1/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x0100

        Cause i = 0x8190 - Normal call clearing

*Jul 19 11:37:42.475: ISDN Se0/1/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8100

*Jul 19 11:37:50.431: ISDN Se0/1/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0100

*Jul 19 11:37:42.339: ISDN Se0/1/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0100

        Bearer Capability i = 0x8090A2

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98382

                Exclusive, Channel 2

        Progress Ind i = 0x8181 - Call not end-to-end ISDN, may have in-band info 

        Calling Party Number i = 0xA1, '651XXXXXXX'

                Plan:ISDN, Type:National

        Called Party Number i = 0xA1, '911'

                Plan:ISDN, Type:National

*Jul 19 11:37:42.355: ISDN Se0/1/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8100

        Channel ID i = 0xA98382

                Exclusive, Channel 2

*Jul 19 11:37:42.363: ISDN Se0/1/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8100

        Cause i = 0x8281 - Unallocated/unassigned number

*Jul 19 11:37:42.471: ISDN Se0/1/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x0100

        Cause i = 0x8190 - Normal call clearing

*Jul 19 11:37:42.475: ISDN Se0/1/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8100

*Jul 19 11:37:50.431: ISDN Se0/1/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0100

Green

911 Dial-Peer Issue

Mike

Can you remove the COR

and test again

!        

dial-peer voice 98 pots

no corlist incoming TargetPBX

no corlist outgoing TargetPSTN

!

!       

dial-peer voice 99 pots

no corlist incoming TargetPBX

no corlist outgoing TargetPSTN

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
New Member

911 Dial-Peer Issue

That did it. Thanks. 

Is there a resource for Dial-Peer config?  Its either a practice thing or compreshension for me.

Green

911 Dial-Peer Issue

Mike,

glad it helped.

There are many sources of information for dial peers
here are a couple

http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/dial_peer/dpeer_c.html

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a008010fed1.shtml

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
640
Views
5
Helpful
11
Replies
CreatePlease to create content