Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

AAR not working " network congestion rerouted" its not rerouting out of pstn

Hi

I'm trying to setup AAR fucntionality but its not working

I did the right steps but after testing i can see the call goes out of the gateway but i hear a busy tone.

What i did was the following:

Created aar partitions

Created aar css's

created aar group

created route pattern and route list for aar.

Enabled AAR in service parameters  to => true

I'm testing between 2 sites (  registered to UCM ) site a & b

In 2 sites i applied AAR group to the DN's

In site XX i applied AAR to the phone itself

i point the router pattern to the partition which i've created earlier ( pt-aar)

also the route list (rl-aar)

checked ( calling party external phone numbers mask)

transform mask===> XXXXXXXXXX ( 10 dgits)

Predot ( national - isdn)

If i reduce the bandwith in the locations i receive the message on my phone ( Network congestion rerouted)
after that i receive a busy tone so thats means its not rerouting out of the pstn as a long distance call.

I've also resetted the gateways in UCM, resyncd the bandwith no success

Here is my output of the gateways:

SiteA-RTR#

Aug 16 22:02:23.827: ISDN Se0/2/0:23 Q931: TX -> SETUP pd = 8  callref = 0x0002

        Bearer Capability i = 0x8090A2

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98388

                Exclusive, Channel 8

        Display i = 'SiteA Phone 1'

        Calling Party Number i = 0x0081, '2025552001'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0xA1, '4083873002'

                Plan:ISDN, Type:National

Aug 16 22:02:23.867: ISDN Se0/2/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0x8002

        Channel ID i = 0xA98388

                Exclusive, Channel 8

Aug 16 22:02:23.923: ISDN Se0/2/0:23 Q931: RX <- DISCONNECT pd = 8  callref = 0x8002

        Cause i = 0x8281 - Unallocated/unassigned number

Aug 16 22:02:24.499: ISDN Se0/2/0:23 Q931: TX -> RELEASE pd = 8  callref = 0x0002

Aug 16 22:02:24.507: ISDN Se0/2/0:23 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x8002

SiteB-RTR#

Aug 16 22:02:23.863: ISDN Se0/2/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0085

        Bearer Capability i = 0x8090A2

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98381

                Exclusive, Channel 1

        Display i = 'SiteA Phone 1'

       Calling Party Number i = 0x2181, '2025552001'

                Plan:ISDN, Type:National

        Called Party Number i = 0xA1, '4083873002'

                Plan:ISDN, Type:National

Aug 16 22:02:23.863: ISDN Se0/2/0:23 Q931: Received SETUP  callref = 0x8085 callID = 0x0006 switch = primary-ni interface = User

Aug 16 22:02:23.879: ISDN Se0/2/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8085

        Channel ID i = 0xA98381

                Exclusive, Channel 1

Aug 16 22:02:23.883: ISDN Se0/2/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0x8085

        Cause i = 0x8081 - Unallocated/unassigned number

Aug 16 22:02:23.895: ISDN Se0/2/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x0085

Aug 16 22:02:23.895: ISDN Se0/2/0:23 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8085

2 ACCEPTED SOLUTIONS

Accepted Solutions

AAR not working " network congestion rerouted" its not rerouting

Hi,

From debug you can have a clear vision that incoming dial-peer being selected is dial-peer 1 and that dial-peer doesn't do any kind of modification.

Try to implement below solution and test.

voice-port 0/2/0:23

translation-profile incoming PSTN

exit

voice translation-rule 100

rule 1 /.*\(3...\)/ /\1/

exit

voice translation-profile PSTN

translate called 100

exit

Regards, Nishant Savalia

AAR not working " network congestion rerouted" its not rerouting

Hi,

Great that it worked.

Actualy the problem is with the lack of configuration.

As your SiteB gateway is H.323 gateway and gateway is sending call to CUCM with help of 2 voip dial-peers with destination-pattern 3... and the call coming from pstn was of 10 digit.

So to match that voip dial-peer you have to convert 10 digit to 4 digit so that required extension can be triggered.

Regards, Nishant Savalia
16 REPLIES
Hall of Fame Super Silver

AAR not working " network congestion rerouted" its not rerouting

Are you allowed to dial this 408 number as 10 digits? Did you try as 11 digits? Can you call this number from the phone?

Chris

New Member

AAR not working " network congestion rerouted" its not rerouting

Hi Chris,

I tried it,

Get the same thing busy tone but thats because i don't have an existing routepattern/dial-peer 

Hall of Fame Super Silver

AAR not working " network congestion rerouted" its not rerouting

Area code 408 requires 11 digit dialing, see:

http://www.nanpa.com/enas/area_code_query.do

so, make sure your AAR group prefixes 1 (along with off-net access code if dial-peers/route patterns have it).

Chris

New Member

AAR not working " network congestion rerouted" its not rerouting

chris,

i'm sorry but i'm not following you

forgot to mention this is for lab purposes

Hall of Fame Super Silver

Re: AAR not working " network congestion rerouted" its not rerou

You are sending the call with 10 digits instead of telco expected 11, hence the telco unallocated error, you need to prefix 1 via the AAR group.

Sent from Cisco Technical Support iPhone App

New Member

AAR not working " network congestion rerouted" its not rerouting

Chris,

Thanks for your quick reply..

I wil try this and let you know right nowe not at home.

New Member

AAR not working " network congestion rerouted" its not rerouting

Hi chris,

If i put 1 as prefix in the aar group the call doesnt even to attempt

to come in the gateway.

i"ll send some screenshot of my rp

that points to the gateway

AAR not working " network congestion rerouted" its not rerouting

Hi,

Can you please share what gateway you are using for Site A and Site B?

Because your Site B gateway receives the call from Site A via PSTN and then releases the call as " Unallocated / unassigned number".

Also if possible do share RTMT detailed trace for the same call.

Regards, Nishant Savalia
New Member

AAR not working " network congestion rerouted" its not rerouting

Hi nishant

Site A is an MGCP gateway

Site B is an H323 gateway

the routelist i've created is based on standard local route group.

The routepattern that i've created ( \+1.408387XXXX ) points to this routelist

I'm not using TEHO for this construction

specs RP:

Calling party checked ( XXXXXXXXXX) 10 digits

Called party ( Predot)

With National /ISDN

Enough info?

Hall of Fame Super Silver

AAR not working " network congestion rerouted" its not rerouting

If you are stripping preDot (+1) how are you sending the 1 to telco then? You should not strip pre dot for this call and need to ensure you have proper dial peer on the GW that matches it.

HTH,

Chris

New Member

AAR not working " network congestion rerouted" its not rerouting

still not working

9.1408387XXXX

dial-peer voice 1 pots

destination-pattern 9[1-9].........

port 0/2/0:23

forward-digits all

AAR not working " network congestion rerouted" its not rerouting

Hi,

I think the extension for SiteB Phones will be of 4 digit..right?

Where you are doing digit manipulation? I mean at router level or in CUCM?

Try to run debug voice ccapi ind 2 and debug h225 asn1 in SiteB router so that you can confirm yourself what digits you are sending towards CUCM.

Have you applied any translation-rule in Site B router? Please do share it if any

Regards, Nishant Savalia
New Member

AAR not working " network congestion rerouted" its not rerouting

Hi nishant i have some voice translation rules configured on my siteB router.

I will send you the running config.

output of debug voice ccapi and h225 doesnt give me more info

SiteB-RTR#

Aug 19 11:26:23.336: //-1/03355D9E8004/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x68B7244C, Call Info(

   Calling Number=2025552001,(Calling Name=)(TON=National, NPI=ISDN, Screening=User, Passed, Presentation=Allowed),

   Called Number=4083873002(TON=National, NPI=ISDN),

   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=1, Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1

SiteA-RTR#sh run

Building configuration...

Current configuration : 3005 bytes

!

! Last configuration change at 06:11:32 EST Mon Aug 19 2013

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SiteA-RTR

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

clock timezone EST -5

network-clock-participate wic 2

network-clock-select 1 T1 0/2/0

dot11 syslog

ip source-route

!

!

!

!

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

!

!

!

!

!        

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!        

!

!

!

controller T1 0/2/0

pri-group timeslots 1-8,24 service mgcp

!

controller T1 0/2/1

channel-group 0 timeslots 1-24

description WAN CONNECTION

!

!

!

!

!

interface Loopback0

ip address 10.10.110.1 255.255.255.255

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.101

encapsulation dot1Q 101

ip address 10.10.100.1 255.255.255.0

!

interface FastEthernet0/0.102

encapsulation dot1Q 102

ip address 10.10.200.3 255.255.255.0

ip helper-address 10.10.210.10

!

interface FastEthernet0/0.103

encapsulation dot1Q 103

ip address 10.10.210.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1/0

description network connection to SB router

ip address 10.10.111.1 255.255.255.0

encapsulation ppp

ip ospf mtu-ignore

no fair-queue

!

interface Serial0/1/1

description network connection to Branch2 router

ip address 10.10.112.1 255.255.255.0

encapsulation ppp

ip ospf mtu-ignore

!

interface Serial0/2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/2/1:0

no ip address

!

interface Serial0/3/0

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

no ip http server

ip http authentication local

no ip http secure-server

!

!

!

disable-eadi

!

!

!        

!

!

!

!

control-plane

!

!

!

voice-port 0/2/0:23

!

ccm-manager switchback immediate

ccm-manager redundant-host 10.10.210.10

ccm-manager mgcp

ccm-manager fax protocol cisco

!

mgcp

mgcp call-agent 10.10.210.11 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp bind control source-interface Loopback0

mgcp bind media source-interface Loopback0

!        

mgcp profile default

!

!

!

dial-peer voice 100 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 1 pots

destination-pattern 9[1-9].........

port 0/2/0:23

forward-digits 10

!

!

!

!

gatekeeper

zone local GK ipexpert.com 10.10.100.1

zone remote backbone ipexpert.com 10.10.100.2 1719

zone prefix backbone 011*

no shutdown

!

!

line con 0

exec-timeout 0 0

password cisco

login

line aux 0

line vty 0 4

exec-timeout 0 0

password cisco

login

transport input telnet

!

scheduler allocate 20000 1000

ntp source Loopback0

ntp master 5

ntp server 10.10.100.2

end

SiteB-RTR#sh run

Building configuration...

Current configuration : 3898 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SiteB-RTR

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

clock timezone PST -8

network-clock-participate wic 2

network-clock-select 1 T1 0/2/0

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 10.10.201.1 10.10.201.119

ip dhcp excluded-address 10.10.201.131 10.10.201.254

!

ip dhcp pool SB

   network 10.10.201.0 255.255.255.0

   default-router 10.10.201.1

   option 150 ip 10.10.210.11 10.10.210.10

!

!

ip cef

ip domain name proctorlabs.com

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

!

!        

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 /^3...$/ /408387\0/

!

voice translation-rule 7

rule 1 /^3...$/ /408387\0/

rule 2 /^2...$/ /202555\0/ type any national plan any isdn

!

!

voice translation-profile 7

translate calling 7

!

voice translation-profile strip

translate called 1

!

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!        

!

!

!

controller T1 0/2/0

pri-group timeslots 1-4,24

!

controller T1 0/2/1

channel-group 0 timeslots 1-24

description WAN CONNECTION

!

!

!

!

!

interface Loopback0

ip address 10.10.110.2 255.255.255.255

ip ospf network point-to-point

h323-gateway voip bind srcaddr 10.10.110.2

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1/0

switchport trunk native vlan 201

switchport mode trunk

switchport voice vlan 202

!

interface FastEthernet0/1/1

switchport trunk native vlan 201

switchport mode trunk

switchport voice vlan 202

!

interface FastEthernet0/1/2

switchport trunk native vlan 201

switchport mode trunk

switchport voice vlan 202

!

interface FastEthernet0/1/3

switchport trunk native vlan 201

switchport mode trunk

switchport voice vlan 202

!

interface Serial0/2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn map address ^[2-9]......$ plan unknown type unknown

isdn bchan-number-order ascending

isdn outgoing display-ie

no cdp enable

!

interface Serial0/2/1:0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

!

interface Serial0/3/0

ip address 10.10.111.2 255.255.255.0

encapsulation ppp

ip ospf mtu-ignore

no fair-queue

clock rate 2000000

!

interface Serial0/3/1

no ip address

shutdown

clock rate 2000000

!

interface Vlan1

no ip address

!

interface Vlan202

ip address 10.10.201.1 255.255.255.0

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

disable-eadi

!

!

!

!

!

!

!

control-plane

!

!

!

voice-port 0/2/0:23

!

ccm-manager fax protocol cisco

!

!

!

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 2 voip

destination-pattern 3...

voice-class codec 1

voice-class h323 1

session target ipv4:10.10.210.11

incoming called-number .

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 3 voip

destination-pattern 3...

voice-class codec 1

voice-class h323 1

session target ipv4:10.10.210.10

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 911 pots

destination-pattern 911

port 0/2/0:23

forward-digits 3

!

dial-peer voice 7 pots

translation-profile outgoing 7

destination-pattern 9[2-9]......

port 0/2/0:23

forward-digits 7

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

exec-timeout 0 0

password cisco

login

line aux 0

line vty 0 4

exec-timeout 0 0

password cisco

login

transport input telnet

!

scheduler allocate 20000 1000

ntp server 10.10.110.1

end

AAR not working " network congestion rerouted" its not rerouting

Hi,

From debug you can have a clear vision that incoming dial-peer being selected is dial-peer 1 and that dial-peer doesn't do any kind of modification.

Try to implement below solution and test.

voice-port 0/2/0:23

translation-profile incoming PSTN

exit

voice translation-rule 100

rule 1 /.*\(3...\)/ /\1/

exit

voice translation-profile PSTN

translate called 100

exit

Regards, Nishant Savalia
New Member

AAR not working " network congestion rerouted" its not rerouting

Hi nishant...

It worked!

Your awesome....

But still i don't quiet understand it well...

Was the problem in my translation rules?

AAR not working " network congestion rerouted" its not rerouting

Hi,

Great that it worked.

Actualy the problem is with the lack of configuration.

As your SiteB gateway is H.323 gateway and gateway is sending call to CUCM with help of 2 voip dial-peers with destination-pattern 3... and the call coming from pstn was of 10 digit.

So to match that voip dial-peer you have to convert 10 digit to 4 digit so that required extension can be triggered.

Regards, Nishant Savalia
753
Views
0
Helpful
16
Replies