Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

After Upgrade/Server Rebuild of CCM 7.1(5b)SU5, getting Corporate Directory Parsing Error

We upgraded from 5.x to 7.1(5b)SU5 last weekend and then did server rebuilds of 7.1(5b)SU5 due tp partition size limitations this week.  2 days after the server rebuild, it was found that on a 7942, we are getting a "error code 4, parsing error" when trying to select the corporate directory feature (we are trying to confirm if other phones of same type are experiencing the same, 1 reported but do not have model yet).  Fortunately, we only have a few of the 7942 types (I think the phone type association may be premature).  No reports for 7941s and we have several thousand.

Additionally, the user reports that the missing calls, placed calls, received calls are blank.

We use the CCM end user database (no LDAP).

Starting off, it would seem that all services in question use the internal 'IP Phone Services' which have been setup with 'Enterprise Subscription' set.

Settings:

- Enterprise Paramater 'Service Provisioning' set to 'Internal'

- All "IP Phone Services" set and enabled (Corporate Dir, Missing Calls, Recv Calls,...)

- nothing on phone for 'external directories'

Tried:

- reset/restart (not factory reset yet)

- resetting PIN (but think this is only required for Personal Directory)

     o see error code 4 that docs show as authentication related but not sure auth is required for corp directory

I am thinking 7942 firmware related only because I see other posts.  Firmware rev is SCCP42.9-2-1S.

Any guidance here would be appreciated.

Thanks

Andy

3 REPLIES
Cisco Employee

After Upgrade/Server Rebuild of CCM 7.1(5b)SU5, getting Corporat

Hi Andrew,

Answer the questions below for a better understanding of the issue you are facing,

Is this the exact error that you are getting while trying to press the Services Button "XML Error [4]. Parse Error" ?

Are you using Extension Mobility?

Can try the following Work Around :

Try setting the "Service Provisioning" to External or Both.

And the Firmware Version you are using is not a very old version, but you can try upgrading to a newer one and below is the link

http://www.cisco.com/cisco/software/release.html?mdfid=281346593&flowid=5266&softwareid=282074289&release=9.2%283%29&relind=AVAILABLE&rellifecycle=&reltype=latest

New Member

After Upgrade/Server Rebuild of CCM 7.1(5b)SU5, getting Corporat

Hello Priya -

Thanks for the quick reply.

1. Yes, that is the error we are getting. 

2. On setting the Service Provisioning to both, can I assume the 7941 phones with still continue to use the IP Phone Service (i.e. no functional impact to the majority of 7941/7961 phones)????

3. I will go on and try 9.2.3.

Thanks

Andy

New Member

After Upgrade/Server Rebuild of CCM 7.1(5b)SU5, getting Corporat

Hey Priya -

Sorry for late reply. Turns out that the phones were behind a VPN device.  Once plugged directly into internal network, all worked as expected.

Thank you for taking the time.

Andy

258
Views
0
Helpful
3
Replies
CreatePlease to create content