Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AS5300 with elastix

Hello all,

I am trying to connect elastix with AS5300 cisco gateway via sip trunk

here is router config

sip-ua

authentication username XXX password XXX

retry invite 2

retry response 2

retry bye 2

retry cancel 2

retry options 2

registrar ipv4:192.168.113.211:5060 expires 3600

sip-server ipv4:192.168.113.211:5060

dial-peer voice 113 voip

destination-pattern 67520004.

session protocol sipv2

session target ipv4:192.168.113.211:5060

dtmf-relay rtp-nte

codec g729br8

elastix sip trunk

General Settings

Trunk Description:
Outbound Caller ID:
CID Options:
Maximum Channels:
Disable Trunk:Disable
Monitor Trunk Failures:

dial peer

host=192.168.113.6

username=XXX

secret=XXX

type=peer

canredirect=no

canreinvite=no

allow=g729br8

disallow=all

user detail

secret=XXX

type=user

context=from-trunk

username=XXX

fromuser=mena

qualify=no

canreinvite=no

allow=g729br8

disallow=all

always when i try to call any number give me a circuit busy message, is any document or help to such like this configuration between elastix and as5300 cisco gateway


1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

AS5300 with elastix

No trace, no troubleshoot.

7 REPLIES
Hall of Fame Super Gold

AS5300 with elastix

Router config is incomplete, it must have at least one dial-peer pots.

New Member

AS5300 with elastix

my network configuration as following :

as5300 working as h323 voice gateway on f0/0 and i want to add a sip gateway to as5300

here is the complete configuration of the as5300 VGW


Current configuration : 4393 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname XX

!

boot-start-marker

boot system flash c5350-is-mz.124-11.T4.bin

boot system flash c5350-is-mz.123-3g.bin

no boot startup-test

boot-end-marker

!

logging monitor critical

enable secret 5 $1$QhHi$sv47RYidJJvFcyRmv5ved1

!

!

!

resource-pool disable

no aaa new-model

clock timezone utc 2

spe default-firmware spe-firmware-1

!

!

ip cef

no ip domain lookup

!

!

multilink bundle-name authenticated

isdn switch-type primary-net5

!

voice call send-alert

voice rtp send-recv

!

voice service pots

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

!

voice service voip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  h245 tunnel disable

  h245 caps mode restricted

modem passthrough nse codec g711alaw

sip

  bind control source-interface FastEthernet0/0

  bind media source-interface FastEthernet0/0

  registrar server

!

!

voice class codec 1

codec preference 1 g729br8 bytes 60

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 /^9#0/ /999/

!

!

voice translation-profile test

translate called 1

!

!

!

fax interface-type fax-mail

dial-control-mib retain-timer 1000

dial-control-mib max-size 1200

!

username x password XX

username X password XX

username X password XX

!

!

controller E1 3/0

framing NO-CRC4

pri-group timeslots 1-31

!

controller E1 3/1

framing NO-CRC4

pri-group timeslots 1-31

!

!

!

interface FastEthernet0/0

ip address 192.168.14.80 255.255.255.0

load-interval 30

duplex full

speed 100

h323-gateway voip interface

h323-gateway voip id gk-zone1 ipaddr 192.168.14.70 1719 priority 126

h323-gateway voip h323-id AlkanVGW

h323-gateway voip tech-prefix 1#

h323-gateway voip bind srcaddr 192.168.14.80

!

interface FastEthernet0/1

ip address 192.168.113.6 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial3/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn timer T310 400000

isdn incoming-voice modem

isdn sending-complete

no cdp enable

!

interface Serial3/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn timer T310 400000

isdn incoming-voice modem

isdn sending-complete

no cdp enable

!

interface Group-Async0

no ip address

encapsulation slip

group-range 1/00 1/59

!

!

ip route 0.0.0.0 0.0.0.0 192.168.14.33

ip route 10.0.0.0 255.0.0.0 192.168.14.254

ip route 10.20.1.0 255.255.255.240 192.168.14.33

no ip http server

!

!

snmp-server community xxx

!

!

!

control-plane

!

!

!

voice-port 3/0:D

cptone EG

bearer-cap Speech

!

voice-port 3/1:D

cptone EG

bearer-cap Speech

!

!

!

dial-peer voice 2 pots

destination-pattern 0.

direct-inward-dial

port 3/0:D

!

dial-peer voice 1 voip

tone ringback alert-no-PI

destination-pattern .

progress_ind setup enable 3

session target ras

codec g729br8 bytes 60

fax-relay ecm disable

fax rate 9600

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

!

dial-peer voice 3 pots

destination-pattern 0.

direct-inward-dial

port 3/1:D

!

dial-peer voice 1234 voip

destination-pattern 110.

session target ipv4:10.181.24.241

codec g729br8

!

dial-peer voice 122 voip

destination-pattern 122.

session target ipv4:10.181.28.245

codec g729br8

!

dial-peer voice 121 voip

destination-pattern 121.

session target ipv4:10.181.28.237

codec g729br8

!

dial-peer voice 113 voip

destination-pattern 67520004.

session protocol sipv2

session target ipv4:192.168.113.211:5060

dtmf-relay rtp-nte

codec g729br8

!

dial-peer voice 114 voip

!

!

gateway

timer receive-rtp 1200

!

sip-ua

authentication username xx password xx

retry invite 2

retry response 2

retry bye 2

retry cancel 2

retry options 2

registrar ipv4:192.168.113.211:5060 expires 3600

sip-server ipv4:192.168.113.211:5060

notify ignore substate

!

ss7 mtp2-variant Bellcore 0

ss7 mtp2-variant Bellcore 1

ss7 mtp2-variant Bellcore 2

ss7 mtp2-variant Bellcore 3

!

line con 0

line aux 0

line vty 0 4

password xx

login

line 1/00 1/59

modem InOut

!

scheduler allocate 10000 400

ntp clock-period 17180036

ntp server 192.168.14.33

end

i made this dial peer 113 and sip-ua in the previous code to add elstix as a sip proxy in the network and use a sip phone too beside h323

Hall of Fame Super Gold

Re: AS5300 with elastix

Your voip DPs need to have session protocol sipv2. Otherwise, they use H.323

Then you can take "debug ccsip message" with "term mon" to see what happens.

New Member

AS5300 with elastix

only i want apply sip gateway on int f0/1 to configure sip phone going out through pstn. and i configured session protocol in dial-peer 113 and the outage call (PSTN) should went out throurgh dial-peer 2 so should i configure sip session protocol in dial-peer 2

Thank you very match for your interest

Hall of Fame Super Gold

AS5300 with elastix

No trace, no troubleshoot.

New Member

AS5300 with elastix

realy, thank you for your interest, i had a doubt that it will work. Can you further recommend me sip proxy or server working with as5300 and has a good billing system.

but any way thanks alot  for your help.

New Member

AS5300 with elastix

Hi Mena,

could you please describe what hardware are you using with the AS5300? E1 card/ VoIP card/ DSPs?

Thanks a lot.

Regards

1613
Views
0
Helpful
7
Replies
CreatePlease login to create content