Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ATA 187 and Konica 2900/3900 Fax Issues

We have Konica 2900/3900 fax machines and we are unable to receive faxes.  We are able to send out faxes. The fax machine is connected to an ATA 187.  We use MGCP on our voice router and the calls come in on the serial interface T1 (PRI) line.

CUCM version: 8.5.1.10000-26

I can see the calls come in on the voice router (gateway) and when an analog phone is connected it works fine.  Seems like the destination fax machine (the one connected to the ATA) answers when i call but the transmission does not complete and a "NG" error is printed out on the source fax machine.

ATA.PNG

ATA2.PNG

Here is my config:

***** show run *****

boot-start-marker

boot system flash0 c2951-universalk9-mz.SPA.151-3.T.bin

boot-end-marker

!

card type t1 0 0

logging snmp-authfail

no logging queue-limit

logging buffered 30000

no logging rate-limit

!

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

!

no ipv6 cef

no ip source-route

ip cef

!

no ip bootp server

no ip domain lookup

ip domain name xxxxxxxxxxxxxxxxxxxxxxxx.com

!

multilink bundle-name authenticated

!

!

isdn switch-type primary-ni

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice service voip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

no fax-relay sg3-to-g3

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

voice iec syslog

!

!

hw-module pvdm 0/0

!

!

archive

log config

  hidekeys

!

redundancy

!

!

controller T1 0/0/0

cablelength long 0db

pri-group timeslots 1-24 service mgcp

description XO CID: XO xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

!

controller T1 0/0/1

cablelength long 0db

pri-group timeslots 1-24 service mgcp

description XO CID: XO xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

!

ip tcp path-mtu-discovery

!

!

interface GigabitEthernet0/0

description **Connection to xxxxxxxxxxxxxxxxxxxxxxx**

ip address x.x.x.x

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

description XO xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/0/1:23

description XO xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip forward-protocol nd

!

no ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 x.x.x.x

!

!

!

!

nls resp-timeout 1

cpd cr-id 1

!

control-plane

!

!

voice-port 0/0/0:23

echo-cancel coverage 64

!

voice-port 0/0/1:23

echo-cancel coverage 64

!

ccm-manager fallback-mgcp

ccm-manager redundant-host x.x.x.x x.x.x.x

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server x.x.x.x

ccm-manager config

!

mgcp

mgcp call-agent x.x.x.x 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/0

mgcp bind media source-interface GigabitEthernet0/0

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm x.x.x.x identifier 2 version 7.0

sccp ccm x.x.x.x identifier 1 version 7.0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/0

associate ccm 1 priority 1

associate profile 2 register XXXXXXXXXXXXXXXX

associate profile 1 register XXXXXXXXXXXXXXXX

!

dspfarm profile 1 transcode 

description TRANSCODER

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 25

associate application SCCP

!

dspfarm profile 2 conference 

description Conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 20

associate application SCCP

!

dial-peer voice 911 pots

destination-pattern 911

direct-inward-dial

port 0/0/0:23

forward-digits 5

!

dial-peer voice 9911 pots

destination-pattern 9911

direct-inward-dial

port 0/0/0:23

forward-digits 5

!

dial-peer voice 929 pots

destination-pattern 9[2-9]..[2-9]......

direct-inward-dial

port 0/0/0:23

!

dial-peer voice 9129 pots

destination-pattern 91[2-9]..[2-9]......

direct-inward-dial

port 0/0/0:23

prefix 1

!

dial-peer voice 9011 pots

destination-pattern 9011T

direct-inward-dial

port 0/0/0:23

prefix 011

!

!

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

max-conferences 30 gain -6

transfer-system full-blind

ip source-address x.x.x.x port 2000 strict-match

max-ephones 250

max-dn 500

!

!

***** show ver *****

Cisco IOS Software, C2951 Software (C2951-UNIVERSALK9-M), Version 15.1(3)T, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Mon 15-Nov-10 23:12 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M6, RELEASE SOFTWARE (fc1)

CB-VA01-GWL004 uptime is 30 weeks, 1 hour, 11 minutes

System returned to ROM by power-on

System restarted at 14:08:02 EDT Thu May 5 2011

System image file is "flash0:c2951-universalk9-mz.SPA.151-3.T.bin"

Last reload type: Normal Reload

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco CISCO2951/K9 (revision 1.1) with 483328K/40960K bytes of memory.

Processor board ID FTX1509AJ21

3 Gigabit Ethernet interfaces

48 Serial interfaces

2 Channelized T1/PRI ports

1 Virtual Private Network (VPN) Module

DRAM configuration is 72 bits wide with parity enabled.

255K bytes of non-volatile configuration memory.

254464K bytes of ATA System CompactFlash 0 (Read/Write)

License Info:

License UDI:

-------------------------------------------------

Device#            PID                              SN

-------------------------------------------------

*0              CISCO2951/K9          FTX1509AJ21    

Technology Package License Information for Module:'c2951'

----------------------------------------------------------------

Technology    Technology-package          Technology-package

              Current       Type          Next reboot 

-----------------------------------------------------------------

ipbase        ipbasek9      Permanent     ipbasek9

security      securityk9    Permanent     securityk9

uc            uck9          Permanent     uck9

data          None          None          None

Configuration register is 0x2102

---------------------------------------------------------------------------------------------------------------------------------------------------------------

What is the best way to troubleshoot this?

Thanks,

Kamil

Everyone's tags (4)
1 REPLY
Cisco Employee

ATA 187 and Konica 2900/3900 Fax Issues

the only PRIs on this gateway are MGCP not H.323.  Therefore, you need to enable T.38 in the MGCP configuration.

mgcp package-capability fxr-package

no mgcp fax t38 inhibit

no mgcp

mgcp

1475
Views
0
Helpful
1
Replies