Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ATA switch port issue

Hi,

I have a trouble with 2 or more ATA voice gateways connected to several Fast Ethernet switch ports of a Cisco 3560 PoE switch. The FXS ports of those ATA gateways are connected to dataphone devices used for electronic transactions over data calls. The trouble is that the switch port connected to those ATA gateways are showing an unexpected behavior, the output traffic showed at the port is to large:

  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 2302000 bits/sec, 207 packets/sec

Even I could see traffic over 10 Mbps. Sometimes the voice calls done over the FXS ports present robot voice and I have seen a lot of unregistering events with those devices.

I have a cluster of CUCM version 7.1(3b) and I have one ATA configured with "auto qos voip cisco-phone" and another port with the "mls qos trust dscp" line at the switch port configuration. Can you help me with suggestion for this case? What could be the recommended switch port configuration for those ports?

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: ATA switch port issue

You can try to identify what type of traffic is generated from your ATA.
You can use a SPAN port and Wireshark to capture and analize packets.

To activate SPAN port use these commands:

C3560#configure terminal
C3560(config)#monitor session 1 source interface fastethernet 1/0/2

!--- This configures interface Fast Ethernet 1/0/2 as source port.

C3560(config)#monitor session 1 destination interface fastethernet 1/0/3

!--- This configures interface Fast Ethernet 1/0/3 as destination port.


C3560#show monitor session 1
Session 1
---------
Source Ports:
RX Only:       None
TX Only:       None
Both:          Fa1/0/2
Destination Ports: Fa1/0/3



This is the port configuration use in my network:

interface FastEthernet1/0/2
description ***
switchport access vlan ***
switchport mode access
priority-queue out
spanning-tree portfast
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
service-policy input voip




Best regards.

3 REPLIES

Re: ATA switch port issue

You can try to identify what type of traffic is generated from your ATA.
You can use a SPAN port and Wireshark to capture and analize packets.

To activate SPAN port use these commands:

C3560#configure terminal
C3560(config)#monitor session 1 source interface fastethernet 1/0/2

!--- This configures interface Fast Ethernet 1/0/2 as source port.

C3560(config)#monitor session 1 destination interface fastethernet 1/0/3

!--- This configures interface Fast Ethernet 1/0/3 as destination port.


C3560#show monitor session 1
Session 1
---------
Source Ports:
RX Only:       None
TX Only:       None
Both:          Fa1/0/2
Destination Ports: Fa1/0/3



This is the port configuration use in my network:

interface FastEthernet1/0/2
description ***
switchport access vlan ***
switchport mode access
priority-queue out
spanning-tree portfast
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
service-policy input voip




Best regards.

New Member

Re: ATA switch port issue

Hi Giordano,

I took a sniffer capture and I could see some data vlan traffic going to the phone IP address.

I had the next switch port configuration:

interface FastEthernet0/x
switchport access vlan 195
switchport mode access
switchport voice vlan 368
switchport port-security maximum 5
switchport port-security
switchport port-security aging time 2
switchport port-security aging type inactivity
speed 10
duplex half
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust device cisco-phone
mls qos trust cos
macro description cisco-phone
auto qos voip cisco-phone
storm-control broadcast level 10.00
storm-control multicast level 10.00
spanning-tree portfast
spanning-tree bpdufilter enable

spanning-tree bpduguard enable

In my case I deleted the access vlan, QoS and security lines and left the voice vlan lines only and then the unnecessary traffic dissapeer. Thanks for your help. I'm checking if the phone registration is stable and I tell you.

Now If I want to add some QoS configuration lines to the switch port what lines do you suggest me to add?

Re: ATA switch port issue

I use this configuration on global level:

errdisable recovery cause all

mls qos srr-queue input priority-queue 2 bandwidth 20
mls qos srr-queue input cos-map queue 1 threshold 3  0 1 2 3 4
mls qos srr-queue input cos-map queue 2 threshold 3  5 6 7
mls qos srr-queue output cos-map queue 1 threshold 3  5 6 7
mls qos srr-queue output cos-map queue 2 threshold 3  4
mls qos srr-queue output cos-map queue 3 threshold 3  2 3
mls qos srr-queue output cos-map queue 4 threshold 3  0 1
mls qos

and this on interface level:

priority-queue out

but I don't remeber if 3560 supports this option.

Just a little consideration. If you can, set duplex to full mode. This modality prevents "collision" phenomenas.

The rest of your config is OK.

Best regards.

1192
Views
4
Helpful
3
Replies
CreatePlease login to create content