Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Avaya 8700 and Cisco 2960 Switch compatibility issues

A bit of a lengthy one...

We have recently installed a new Avaya PABX system (S8700 server and G650 Media Gateways). This connects to a Cisco 2960-48T ...C2960 Software (C2960-LANBASEK9-M), Version 12.2(37)SE....

The problem is when we enable trunking (Avaya insists) on all ports connecting to the S8700 and G650 there is no connectivity on the server control interface NIC and IPSI. I had no problem seeing the Medpro and the CLAN. This basically just renders the VoIP solution useless as you can not enable VLAN tagging on the Avaya System.

Avaya has now setup a testbench with similar setup and getting same result.

Avaya engineer's diagnosis is a bit concerning.... quote

"The steps I took are as follows:

- enabled VLAN tagging whilst the Avaya gear is connected to our lab Cajun switch (this worked fine)

- turned off VLAN tagging and moved all connections to your Cisco 2960 switch to ports bound to default VLAN (no connectivity)

- moved the connections from your Cisco (2960) switch to another Cisco switch (2950) that we have and I was able to get layer 2 connectivity (saw all the MAC addresses of the connected devices).

I have heard that certain IOS releases on some Cisco switches has some interoperability issues. Please note the software versions below.

Cisco IOS (tm) C2950 Software (C2950-I6K2L2Q4-M), Version 12.1(22)EA10

Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(37)SE " end of quote.

First concern is that where does this leave the (Cisco) customer with future IOS releases and devices reaching EOL.(which I pointed out that his 2950 has already reached).

Secondly... how do we get this working? There must be similar systems out there or were we sold a dud.

Any comments/suggestions welcome.

Will

2 REPLIES
Bronze

Re: Avaya 8700 and Cisco 2960 Switch compatibility issues

Why is Avaya suggesting you configure the ports connected to the S8700 and G650 be configured for trunking?

The S8700 and G650 should be attached to a port that is configured for access and that should be the voice VLAN. The Avaya IP phones should be connected to ports that has a voice vlan and access vlan.

Here are some example switch port configurations that will work on a 2960,2970,3560 and 3750 with a Cisco voice or Avaya voice solution.

interface range FastEthernet 0/1 - 4

description <== Connection to voice equipment ==>

switchport access vlan $VVOICE

switchport mode access

speed 100

duplex full

queue-set 1

priority-queue out

mls qos trust dscp

power inline never

cdp enable

!AVAYA no cdp enable

spanning-tree portfast

!

interface range FastEthernet 0/5 - 8

description <== Connection to data servers ==>

switchport access vlan $VDATA

switchport mode access

queue-set 1

priority-queue out

mls qos trust dscp

power inline never

no cdp enable

spanning-tree portfast

!

interface range FastEthernet 0/9 - $FPORTS

description <== Connection to IP phone or workstation ==>

switchport access vlan $VDATA

switchport mode access

switchport voice vlan $VVOICE

queue-set 1

priority-queue out

mls qos trust device cisco-phone

!AVAYA mls qos trust dscp

!POWER power inline consumption 7700

cdp enable

!AVAYA no cdp enable

spanning-tree portfast

This is how we configured for switches for an Avaya National Platinum partner I previously worked for. Worked for both solutions.

HTH

Thank you,

Jon Nelson

New Member

Re: Avaya 8700 and Cisco 2960 Switch compatibility issues

Hi Jon,

Thanks for response. A brief history on this..

Initially we set up 2 sites (main office with 800 staff and secondary office with 150) with a dedicated 2MB Metro Ethernet link for this "Voice" traffic. Within a week the system crashed at around 12 concurrent calls at the secondary site...main site had no problem as all call setup and signalling was done at main site servers. Avaya insisted we have qos enabled even though the link was dedicated for Avaya "Voice" traffic only.

We then proceeded to enable qos on all our switches and routers between sites.... this then resolved the system crash issue and up to 25 concurrent calls could be taken before jitter/voice degredation was detected. No IP handsets are being used at this point and the old digital phones are still used. When Avaya then wanted to enable qos/tagging on the servers and gateways, the server crashed. It was then recommended to do trunking due to Avaya equipment which has default VLAN 0, they suspected VLAN mismatch which caused the crash. This is the point when trunking was suggested on the ports connected to Avaya equipment which resulted in the connectivity issues.

We now want to implement a 3rd site but the voice traffic will be carried over the existing data link and qos is essential to have it working. Naturally we are a bit reluctant untill the Avaya system has qos enabled and working at the other 2 sites.

Cheers

Will

1306
Views
0
Helpful
2
Replies
CreatePlease to create content