Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Basic IP Telephony requirements

Hi Everyone,

I hope you guys are doing well.

I have a very basic question related to IP telephony. I am trying to make a lab to practice my voice certification. To be honest, i have very limited knowledge in voice domain since i have been in routing and switching and security mostly.

I have the following equipment with which i have to set up the lab:

1- Cisco 2801 with IOS - c2801-adventerprisek9-mz.124-3b.bin                         Qty:1

2- Cisco 3560 PoE switch                                                                             Qty:1

3- CP-6921 IP phones                                                                                   Qty: 2

What i would like to know are the following:

1- Which IOS is suitable to run IP telephony commands on the router?

2- Which CME version should i use with the recommended IOS?

3- Will that CME support 6921 IP phones?

I would be really grateful if anyone can help me out with this matter. Kindly mention from where can i download the IOS and the CME

Thanks!

13 REPLIES

Re: Basic IP Telephony requirements

1. The current ios version will support cme 3 , to support higher version you need to upgrade your ios . Here is the link which will give version ios compatibility matrix with cme.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm

2. You can check by enabling telephony service.
Config t
Telephony service
Cntrl + z
Show telephony service

You can see the version right there . I think it will be 3.

3. 6921 supported till the latest version i.e 10.



If this helps please rate.

New Member

Basic IP Telephony requirements

Hi!

Thank you so much for the reply, i upgraded my IOS to 12.4(11)T and did the show telephony-service command and it says i have Cisco Unified Call Manager express 4.0

Now, i have configured my router with telephony services and DHCP pools and the voice vlan, i connect my phone (6921) to the PoE switch but it says "phone not registered" if i go into the settings and check the IP , its getting the correct IP from the pool.

So it means, the DHCP is working fine but the phone is not getting the rest of the settings from the router.

Re: Basic IP Telephony requirements

And one more important point cme is an ios feature. There is no separate installation for this , like call-manager. Here is one link which help you to configure call manager express on ios router.

http://www.cisco.com/en/US/products/sw/voicesw/ps5520/products_configuration_example09186a008037f2a9.shtml


If this helps please rate.


Hall of Fame Super Silver

Basic IP Telephony requirements

If you have enough RAM and Flash in your router you can go up to IOS 15.1.4M7 which is the latest supported version on 28XX, all newer versions require 29XX routers.

Chris

New Member

Basic IP Telephony requirements

Hello,

i have 64mb of ram, don't think that's a good idea! but i am sure ip telephony should work on this IOS with CME 4.0, the only issue is why is my 6921 not able to get the settings.

New Member

Basic IP Telephony requirements

one more thing, i read in a forum that we have to use the "load" command with the phone's model# in order for it to load the firmware. When i type this command, it shows alot of 7900 series phones but not 6900 series. Also, the 6921 i have has a firmware of 9.1

Kindly help me out ! thanks!

Re: Basic IP Telephony requirements

Send across your cme router config.


Rate all the helpful post.

New Member

Basic IP Telephony requirements

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$I088$UEnsCeUgIVB./alTJeO0i0

enable password gulf

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool voice50

   network 192.168.100.96 255.255.255.240

   default-router 192.168.100.97

   option 150 ip 192.168.100.97

!

ip dhcp pool voice60

   network 192.168.100.112 255.255.255.240

   default-router 192.168.100.113

   option 150 ip 192.168.100.113

!

ip dhcp pool voice70

   network 192.168.100.128 255.255.255.240

   default-router 192.168.100.129

   option 150 ip 192.168.100.129

!

ip dhcp pool voice80

   network 192.168.100.144 255.255.255.240

   default-router 192.168.100.145

   option 150 ip 192.168.100.145

!

!

!

!

voice-card 0

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

!

!

!

!

!

!

!

!

!

!

!

!

crypto pki trustpoint TP-self-signed-3799126488

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3799126488

revocation-check none

rsakeypair TP-self-signed-3799126488

!

!

crypto pki certificate chain TP-self-signed-3799126488

certificate self-signed 01

  3082023A 308201A3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33373939 31323634 3838301E 170D3133 31323132 30363534

  32315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 37393931

  32363438 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100D3C7 5E77FC97 4A57E3F3 AC7FE970 2BD397B0 C61D70DD 67A7EB0B 51F18C91

  A36CA830 0F0A34C6 ABACF746 CEC06588 F9437472 2B1F5D2E 9B4EDB76 240C1B67

  73153137 01CE794B C1739937 0F0A01FA FF532B20 396B5608 D82AE0DF 24229DAB

  7FEF8F70 5797C58B 203C646F E802802A 8C5C53B3 ACBDB207 76F4DD25 E39C3BCE

  A0C70203 010001A3 62306030 0F060355 1D130101 FF040530 030101FF 300D0603

  551D1104 06300482 02523130 1F060355 1D230418 30168014 E64FC658 BB1C2F65

  01A181E5 656F2549 DA925029 301D0603 551D0E04 160414E6 4FC658BB 1C2F6501

  A181E565 6F2549DA 92502930 0D06092A 864886F7 0D010104 05000381 8100A21D

  C67824D5 6AF1B237 970F8A6D 53FDC95C F0688865 9D63AC8E 4CCFBD98 290AC176

  5C6D6116 A2A2194E 67F57642 44F5F21B C710568A 6FBE4DCC D213C057 A1D16EE9

  4DEA235E 243F7D3C E61B9350 AE2313D0 5C2E0752 824D55DB 7FCEFF40 5F6093C4

  52EF185E FF990143 4D69F650 74EC6676 BCBD8BF3 529D3F12 48D22E8A ADD2

  quit

username admin privilege 15 secret 5 $1$yYnD$7pF5FJAdZi1jH4ydpn5Lo/

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.100.33 255.255.255.240

ip helper-address 192.168.100.2

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.100.49 255.255.255.240

ip helper-address 192.168.100.2

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 192.168.100.65 255.255.255.240

ip helper-address 192.168.100.2

!

interface FastEthernet0/0.40

encapsulation dot1Q 40

ip address 192.168.100.81 255.255.255.240

ip helper-address 192.168.100.2

!

interface FastEthernet0/0.50

encapsulation dot1Q 50

ip address 192.168.100.97 255.255.255.240

!

interface FastEthernet0/0.60

encapsulation dot1Q 60

ip address 192.168.100.113 255.255.255.240

!

interface FastEthernet0/0.70

encapsulation dot1Q 70

ip address 192.168.100.129 255.255.255.240

!

interface FastEthernet0/0.80

encapsulation dot1Q 80

ip address 192.168.100.145 255.255.255.240

!

interface FastEthernet0/1

ip address 192.168.100.1 255.255.255.240

duplex auto

speed auto

!

interface Serial0/1/0

no ip address

shutdown

clock rate 125000

!

interface Serial0/1/1

no ip address

shutdown

clock rate 125000

!

router rip

network 192.168.100.0

!

!

!

ip http server

ip http authentication local

ip http secure-server

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

telephony-service

max-ephones 4

max-dn 4

ip source-address 192.168.100.1 port 2000

auto assign 1 to 4

date-format dd-mm-yy

max-conferences 4 gain -6

!

!

ephone-dn  1

number 23456

call-forward all 1

call-forward busy 1

call-forward noan 1 timeout 3

!

!

ephone-dn  2

number 87954

call-forward all 2

call-forward busy 2

call-forward noan 2 timeout 3

!

!

ephone-dn  3

number 96432

!

!

ephone-dn  4

number 43210

!

!

ephone  1

mac-address 649E.F3B1.5930

button  1:1

!

!

!

ephone  2

mac-address 649E.F3B1.54FD

button  1:2

!

!

!

line con 0

password sam325$

login

line aux 0

line vty 0 4

password 325$

login

!

scheduler allocate 20000 1000

end

PS: The vlans are made on the switch just for testing purpose.

Re: Basic IP Telephony requirements

Run command " create cnf" under telephony service. See if the phone can register with its flash firmware .

If this doesn't resolve then load phone firmware on ios router flash for cme 4 through tftp and then define the firmware through "load"command under telephony service.

And make sure the phone is able to access 192.168.100.1.

Rate all the helpful post.


Sent from Cisco Technical Support iPhone App

Hall of Fame Super Gold

Basic IP Telephony requirements

I have a very basic question related to IP telephony. I am trying to make a lab to practice my voice certification. To be honest, i have very limited knowledge in voice domain since i have been in routing and switching and security mostly.

I have the following equipment with which i have to set up the lab:

1- Cisco 2801 with IOS - c2801-adventerprisek9-mz.124-3b.bin                         Qty:1

2- Cisco 3560 PoE switch                                                                             Qty:1

3- CP-6921 IP phones                                                                                   Qty: 2

Hold on.  There's one think missing:  Where is your DSP module?

Hall of Fame Super Silver

Basic IP Telephony requirements

Leo, it does not look like he has any PSTN trunks, so DSP are not necessary.

Your ephone configuration is missing phone types, 69XX are not supported until CME 8.8:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeadm/cmeroad.html

Chris

New Member

Basic IP Telephony requirements

ok so i upgraded my IOS to 12.4(15) T9 and the CME version shows 4.1. So i researched a bit and it supports CP-7945 IP phones, i got hold of one 7945G, made it as ephone 3 and tried it with the same configuration, just changed the configuration of ephone3 and ephone-dn 3. i also, gave the command "load 7945".

The problem stays the same, its getting the IP address and just keep saying "registering"

Basic IP Telephony requirements

Neither your dhcp pool containing 192.168.100.1 as option 150 ip .That command is used to define the IP address of the TFTP server to download the phone configuration files. And did you created configuration file by running "create cnf" under telephony service ?

Rate all the helpful post.

360
Views
0
Helpful
13
Replies
CreatePlease login to create content