Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

BAT errors when adding phones

When adding phones using the BAT, I get errors and all insers failed. The validation was fine. The error code is -2147219966 - CDBLException Dump: [Item not valid]

Any suggestions for help?

4 REPLIES

Re: BAT errors when adding phones

I recommend you to uninstall BAT, reboot the server, reinstall BAT, reboot the server. I have seen this error when BAT is corrupted. Please give it a try.

Community Member

Re: BAT errors when adding phones

I would also recommend renaming the C:\CiscoWebs\BAT directory to C:\CiscoWebs\BATOLD\ after the removal of BAT and before reinstalling BAT.

Otherwise you could have the same problems.

Once BAT has been reinstalled, you could copy back your templates from the C:\CiscoWebs\BATOLD\Template directory if required.

Good Luck

Community Member

Re: BAT errors when adding phones

I'm having a similar problem where all of my Phones with User records will validate but when an insert is attempted, I get the error: -2147467259 Method '~' of object '~' failed

Tried to uninstall BAT, deleted the BATFiles and CiscoWeb\BAT folders, rebooted, then re-installed. But I get the same result even after the template is re-created.

When I look in CCMAdmin, I see the phone has imported, but the line shows up in the route plan report as an 'unassigned DN'. All of the users get imported too.

Anyone have any ideas?

Community Member

Re: BAT errors when adding phones

Well, I found the answer to my own question. My template had a couple of services - My FastDials and My Address Book of which parameters were not included in the CSV for import.

I unsubscribed from those services and everything else imported ok.

134
Views
5
Helpful
4
Replies
CreatePlease to create content