Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Block incoming calls that is private or unknown on UC520

Hi Guys,

 

I am having difficulty blocking calls on the UC520 that shows up as uknown number or private call.

I have work thru the forums and tried all possible translation rules but none seem to block a call.

 

I have a UC520 with an FXO card.

I get the following from my telco:

 

May 16 06:42:28.488: htsp_ephone_start_caller_id_tx calling num= calling name = called num=1122 orig called num=
May 16 06:42:28.488: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=, Peer Info Type=DIALPEER_INFO_SPEECH
May 16 06:42:28.488: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)

 

How do I block calling num= either on my incoming dial-peer or my voice-port?

Voice CCIE #37771
4 REPLIES

Hi.Try thisvoice translation

Hi.

Try this

voice translation-rule 1

rule 1 reject /[^0-9]$/

voice translation-profile call-block

translate calling 1

 

dial-peer voice XX pots (your incoming DP)

incoming called-number .T

call-block translation-profile incoming call-block

 

 

HTH

 

Regards

 

Carlo

 

Please rate all helpful posts "The more you help the more you learn"

Hi, I have tried this before

Hi,

 

I have tried this before no luck.

Any other suggestions ideas?

This is what I get when doing a debug voice ccapi inout

May 16 13:35:38.307: //-1/CD110D0180E3/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x885E9CF8, Call Info(
   Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Restricted),
   Called Number=1122(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=2, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=FALSE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
May 16 13:35:38.311: //-1/CD110D0180E3/CCAPI/ccCheckClipClir:

 

Voice CCIE #37771

Hi.With "Calling Translated

Hi.

With "Calling Translated=FALSE" your gateway is not matching the right DP or translation profile has been not applied as call-block on DP.

Can you please share your runn and a complete debug ccapi inout during an incoming call.

 

Thanks

 

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"

Here is the running config:I

Here is the running config:

I do not see anything wrong here.


!
no aaa new-model
!
clock timezone ZA 2 0
network-clock-participate wic 1
crypto pki token default removal timeout 0
!         
!

!
no ip domain lookup
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!         
!
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 sip
  bind control source-interface Loopback0
  bind media source-interface Loopback0
  registrar server
!
!
voice register global
 mode cme
 source-address 172.25.185.100 port 5060
 max-dn 56
 max-pool 14
 authenticate register
 authenticate realm herman
 tftp-path flash:
 file text
 create profile sync 0221166027520177
!
voice register dn  1
 number 1122
 name Herman Janse van Vuuren
 label Herman Janse van Vuuren
!
voice register pool  1
 registration-timer max 720 min 660
 id mac 1CE6.2B4D.D052
 session-transport tcp
 type CiscoMobile-iOS
 number 1 dn 1
 dtmf-relay sip-notify
 username herman password herman
 codec g711ulaw
!
!
!
voice translation-rule 1
 rule 1 reject /[^0-9]$/
!         
!
voice translation-profile BLOCK_NUMBER
 translate calling 1
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
!

!
!
!
!
!
!
!         
interface Loopback0
 ip address 172.25.185.100 255.255.255.192
!
interface FastEthernet0/0
 ip address 172.25.185.1 255.255.255.192
 duplex auto
 speed auto
!
interface Integrated-Service-Engine0/0
 ip unnumbered Loopback0
 service-module ip address 172.25.185.101 255.255.255.192
 service-module ip default-gateway 172.25.185.100
!
interface FastEthernet0/1/0
 switchport voice vlan 1
 no ip address
!
interface FastEthernet0/1/1
 switchport voice vlan 1
 no ip address
!
interface FastEthernet0/1/2
 switchport voice vlan 1
 no ip address
!
interface FastEthernet0/1/3
 switchport voice vlan 1
 no ip address
!
interface FastEthernet0/1/4
 switchport voice vlan 1
 no ip address
!
interface FastEthernet0/1/5
 switchport voice vlan 1
 no ip address
!
interface FastEthernet0/1/6
 switchport voice vlan 1
 no ip address
!
interface FastEthernet0/1/7
 switchport voice vlan 1
 no ip address
!
interface FastEthernet0/1/8
 switchport voice vlan 1
 no ip address
!
interface BRI0/1/0
 no ip address
!
interface BRI0/1/1
 no ip address
!
interface Vlan1
 no ip address
!
router rip
 network 172.25.0.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 172.25.185.2
ip route 172.25.185.101 255.255.255.255 Integrated-Service-Engine0/0
!
cdp timer 5
!
!         
!
!
!
control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/0
 supervisory disconnect dualtone mid-call
 cptone ZA
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar opx 1122
 impedance complex1
 caller-id enable
!
voice-port 0/2/1
!
voice-port 0/4/0
 auto-cut-through
 signal immediate
 input gain auto-control
 description Music On Hold Port
!
!
dial-peer voice 1 pots
 translation-profile incoming BLOCK_NUMBER
 call-block translation-profile incoming BLOCK_NUMBER
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 2 pots
 call-block translation-profile incoming BLOCK_NUMBER
 destination-pattern 0[1-9][1-9].......
 port 0/2/0
 forward-digits 10
!         
dial-peer voice 8000 voip
 destination-pattern 800.
 session protocol sipv2
 session target ipv4:172.25.185.101
 incoming called-number 800.
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 3 pots
 destination-pattern 00T
 port 0/2/0
!
dial-peer voice 4 pots
 destination-pattern 102..
 port 0/2/0
!
!
sip-ua
 mwi-server ipv4:172.25.185.101 expires 3600 port 5060 transport udp unsolicited
!
!
!
telephony-service
 em logout 0:0 0:0 0:0
 max-ephones 14
 max-dn 56
 ip source-address 172.25.185.1 port 2000
 time-format 24
 date-format dd-mm-yy
 voicemail 8000
 max-conferences 4 gain -6
 call-forward pattern .T
 moh music-on-hold.au
 web admin system name administrator password ccievoice
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern .T
 create cnf-files version-stamp 7960 May 10 2014 14:06:03
!
!
ephone-dn-template  1
 call-forward busy 8000
 call-forward noan 8000 timeout 20
 huntstop channel 1
!
!         
ephone-dn  1  dual-line
 number 1123
 label huis 1
 description 1122
 name 1122
!
!
ephone-dn  2  dual-line
 number 1124
 label huis 2
 description 1122
 name 1122
!
!
ephone-dn  3  octo-line
 number 1122
 label huis 3
 description 1122
 name 1122
 ephone-dn-template 1
!
!
ephone  1
 device-security-mode none
 mac-address 000D.288E.49D4
 max-calls-per-button 2
 type 7920
 button  1:2
!
!
!
ephone  2
 device-security-mode none
 mac-address 0015.F941.C4CB
 max-calls-per-button 2
 type 7920
 button  1:3
!
!
!
ephone  3
 device-security-mode none
 mac-address 0022.55D4.B31C
 max-calls-per-button 4
 type 7921
 button  1:3
!
!         
!
ephone  4
 device-security-mode none
 mac-address 0015.F941.C4CD
 max-calls-per-button 2
 type 7920
 button  1:3
!
!
!
ephone  5
 device-security-mode none
 mac-address 0090.F5E3.A833
 type CIPC
 button  1:1 2:2 3:3
!
!
!
ephone  6
 device-security-mode none
 mac-address 0015.F941.C4CA
 max-calls-per-button 2
 type 7920
 button  1:3
!
!
ephone-hunt 1 sequential
 pilot 1122
 list 1122, 1123, 1124
 max-timeout 35
 timeout 10, 10, 10
!
!
!
line con 0
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
line vty 0 4
 login
 transport input all
!
ntp master
ntp peer 172.25.185.1
ntp server 146.64.24.58
end

UC520#

 

Here is the debug voice ccapi inout:

 


UC520#debug voice ccapi inout
voip ccapi inout debugging is on
UC520#
May 17 08:47:19.799: //-1/B0C3FFF380F3/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=1
   cisco-anisi=0
   dest=1122
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=0
   cisco-rdnsi=0
   cisco-redirectreason=0   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

May 17 08:47:19.803: //-1/B0C3FFF380F3/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x885E9CF8, Call Info(
   Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Restricted),
   Called Number=1122(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=2, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=FALSE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
May 17 08:47:19.803: //-1/B0C3FFF380F3/CCAPI/ccCheckClipClir:
   In: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Restricted)
May 17 08:47:19.803: //-1/B0C3FFF380F3/CCAPI/ccCheckClipClir:
   Out: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Restricted)
May 17 08:47:19.803: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
May 17 08:47:19.803: :cc_get_feature_vsa malloc success
May 17 08:47:19.803: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
May 17 08:47:19.803:  cc_get_feature_vsa count is 1
May 17 08:47:19.803: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
May 17 08:47:19.803: :FEATURE_VSA attributes are: feature_name:0,feature_time:2270435512,feature_id:102
May 17 08:47:19.803: //103/B0C3FFF380F3/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Restricted),
   Called Number=1122(TON=Unknown, NPI=Unknown))
May 17 08:47:19.803: //103/B0C3FFF380F3/CCAPI/cc_process_call_setup_ind:
   Event=0x885671A8
May 17 08:47:19.803: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
   Try with the demoted called number 1122
May 17 08:47:19.807: //103/B0C3FFF380F3/CCAPI/ccCallSetContext:
   Context=0x8A19B9A0
May 17 08:47:19.807: //103/B0C3FFF380F3/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 103 with tag 2 to app "_ManagedAppProcess_Default"
May 17 08:47:19.807: //103/B0C3FFF380F3/CCAPI/ccCallProceeding:
   Progress Indication=NULL(0)
May 17 08:47:19.811: //103/B0C3FFF380F3/CCAPI/ccCallSetupRequest:
   Destination=, Calling IE Present=FALSE, Mode=0,
   Outgoing Dial-peer=20003, Params=0x8A19E370, Progress Indication=ORIGINATING SIDE IS NON ISDN(3)
May 17 08:47:19.811: //103/B0C3FFF380F3/CCAPI/ccCheckClipClir:
   In: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Restricted)
May 17 08:47:19.811: //103/B0C3FFF380F3/CCAPI/ccCheckClipClir:
   Out: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Restricted)
May 17 08:47:19.811: //103/B0C3FFF380F3/CCAPI/ccCallSetupRequest:
   Destination Pattern=1122$, Called Number=1122, Digit Strip=TRUE
May 17 08:47:19.811: //103/B0C3FFF380F3/CCAPI/ccCallSetupRequest:
   Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Restricted),
   Called Number=1122(TON=Unknown, NPI=Unknown),
   Redirect Number=, Display Info=
   Account Number=, Final Destination Flag=TRUE,
   Guid=B0C3FFF3-DCD6-11E3-80F3-A8BF4E8D841D, Outgoing Dial-peer=20003
May 17 08:47:19.811: //103/B0C3FFF380F3/CCAPI/cc_api_display_ie_subfields:
   ccCallSetupRequest:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=1
   cisco-anisi=0
   dest=1122
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=0
   cisco-rdnsi=0
   cisco-redirectreason=0   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

May 17 08:47:19.811: //103/B0C3FFF380F3/CCAPI/ccIFCallSetupRequestPrivate:
   Interface=0x89A8EEAC, Interface Type=6, Destination=, Mode=0x0,
   Call Params(Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Restricted),
   Called Number=1122(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
   Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE, Outgoing Dial-peer=20003, Call Count On=FALSE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)
May 17 08:47:19.811: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
May 17 08:47:19.811: :cc_get_feature_vsa malloc success
May 17 08:47:19.811: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
May 17 08:47:19.811:  cc_get_feature_vsa count is 2
May 17 08:47:19.811: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
May 17 08:47:19.811: :FEATURE_VSA attributes are: feature_name:0,feature_time:2270435736,feature_id:103
May 17 08:47:19.811: //104/B0C3FFF380F3/CCAPI/ccIFCallSetupRequestPrivate:
   SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1
May 17 08:47:19.811: //104/B0C3FFF380F3/CCAPI/ccCallSetContext:
   Context=0x8A19E320
May 17 08:47:19.815: //103/B0C3FFF380F3/CCAPI/ccSaveDialpeerTag:
   Outgoing Dial-peer=20003
May 17 08:47:19.815: //104/B0C3FFF380F3/CCAPI/cc_api_update_call_info:
   Interface=0x89A8EEAC, Call Id=0x68
May 17 08:47:19.819: //104/B0C3FFF380F3/CCAPI/cc_api_call_proceeding:
   Interface=0x89A8EEAC, Progress Indication=NULL(0)
May 17 08:47:19.823: //104/B0C3FFF380F3/CCAPI/cc_api_call_alert:
   Interface=0x89A8EEAC, Progress Indication=NULL(0), Signal Indication=SIGNAL RINGBACK(1)
May 17 08:47:19.823: //104/B0C3FFF380F3/CCAPI/cc_api_call_alert:
   Call Entry(Retry Count=0, Responsed=TRUE)
May 17 08:47:19.823: //103/B0C3FFF380F3/CCAPI/ccCallAlert:
   Progress Indication=NULL(0), Signal Indication=SIGNAL RINGBACK(1)
May 17 08:47:19.823: //103/B0C3FFF380F3/CCAPI/ccCallAlert:
   Call Entry(Responsed=TRUE, Alert Sent=TRUE)
May 17 08:47:27.415: //103/B0C3FFF380F3/CCAPI/cc_api_call_disconnected:
   Cause Value=17, Interface=0x885E9CF8, Call Id=103
May 17 08:47:27.415: //103/B0C3FFF380F3/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=TRUE, Cause Value=17, Retry Count=0)
May 17 08:47:27.415: //103/B0C3FFF380F3/CCAPI/ccGenerateToneInfo:
   Stop Tone On Digit=FALSE, Tone=Null,
   Tone Direction=Network, Params=0x0, Call Id=103
May 17 08:47:27.415: //104/B0C3FFF380F3/CCAPI/ccCallDisconnect:
   Cause Value=17, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
May 17 08:47:27.415: //104/B0C3FFF380F3/CCAPI/ccCallDisconnect:
   Cause Value=17, Call Entry(Responsed=TRUE, Cause Value=17)
May 17 08:47:27.415: //104/B0C3FFF380F3/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
May 17 08:47:27.415: //103/B0C3FFF380F3/CCAPI/ccCallDisconnect:
   Cause Value=17, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=17)
May 17 08:47:27.419: //103/B0C3FFF380F3/CCAPI/ccCallDisconnect:
   Cause Value=17, Call Entry(Responsed=TRUE, Cause Value=17)
May 17 08:47:27.419: //103/B0C3FFF380F3/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
May 17 08:47:27.427: //104/B0C3FFF380F3/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x89A8EEAC, Tag=0x0, Call Id=104,
   Call Entry(Disconnect Cause=17, Voice Class Cause Code=0, Retry Count=0)
May 17 08:47:27.427: //104/B0C3FFF380F3/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
May 17 08:47:27.427: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
May 17 08:47:27.427: :cc_free_feature_vsa freeing 87541990
May 17 08:47:27.427: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
May 17 08:47:27.427:  vsacount in free is 1
May 17 08:47:27.427: //103/B0C3FFF380F3/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x885E9CF8, Tag=0x0, Call Id=103,
   Call Entry(Disconnect Cause=17, Voice Class Cause Code=0, Retry Count=0)
May 17 08:47:27.427: //103/B0C3FFF380F3/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
May 17 08:47:27.427: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
May 17 08:47:27.431: :cc_free_feature_vsa freeing 875418B0
May 17 08:47:27.431: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
May 17 08:47:27.431:  vsacount in free is 0

Voice CCIE #37771
125
Views
5
Helpful
4
Replies
CreatePlease to create content