Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

both voice and data vlan does not work on the same port

I have a home lab with the following setup:

vlan 5->data

vlan 10->voice

CME Router Cisco 1760 has been configured as a DHCP server to assign IP for both for data and voice vlan.

CME Router1760 configuration:

int f0/0.10

ip address 192.168.10.1

encap trunk dot1q 10

int f0/0.5

ip address 192.168.5.1

encap trunk dot1q 5

Switch3524 configuration

int f0/1

switchport access vlan 5

switchport voice vlan 10

int f0/2

switchport access vlan 10

int f0/24

switchport mode trunk

switchport trunk encap dot1q

switchport trunk allowed vlan 1,5,10

int vlan 1

no ip address

int vlan 5

ip address 192.168.5.4 255.255.255.0

I get request time out when I ping 192.168.5.4

IP phone works in VLAN 10 when I plug it to f0/2.

Computer gets IP address from data Vlan when I plug into f0/1.

My question is how can I make both data and vocie vlan work at the same port.I also tried with setting the trunk port in f0/1 but it does not work.

I will appreciate any thoughts....

Thanks in advance.

2 REPLIES
Bronze

Re: both voice and data vlan does not work on the same port

Hi friend, as a suggest, I have this configuration in all my switches and it work good:

interface FastEthernet0/1

switchport access vlan 460

switchport mode access

switchport voice vlan 461

mls qos trust dscp

spanning-tree portfast

Also make sure that the voice vlan is UP (show interface vlan X)

hth

David

Bronze

Re: both voice and data vlan does not work on the same port

Hi Arjun,

if you're going to use this method in your lab try configuring f0/1 like this

int f0/1

switchport trunk encap dot1q

switchport mode trunk

switchport trunk native vlan 5

switchport voice vlan 10

that should get you up and running,

regards,

Paul

418
Views
4
Helpful
2
Replies