Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Bringing a Dinosaur back...well breathing some life into it at least - no digit stripping

Being a first time install, it's been both inspirational and sleep depriving....

It's a 3750 running CME 4.5 and not quite sure why it is doing what it is doing. I still have the ancient Partner system running and have eavesdropped the line when the CME has dialed. It is clearly not stripping the 9. I've removed all dial-peers and only created the most simple of them. It has to be something else in the config causing the problem. I though I stripped everything down, but perhaps I'm missing something.

Any help would be MOST appreciated!

Here is the current config file (pardon the NO's as they are just to comment out what was there).

Thanks in advance,

Shawn

Current configuration : 12083 bytes
!
! Last configuration change at 23:11:24 DST Wed Aug 15 2012
! NVRAM config last updated at 23:11:26 DST Wed Aug 15 2012
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxxxxxxxxxxxxxxxxxxx
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
no aaa new-model
clock timezone Eastern -5
clock summer-time DST recurring
no network-clock-participate slot 2
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.15.1 192.168.15.10
!
ip dhcp pool Voice
network 192.168.15.0 255.255.255.0
option 150 ip 192.168.15.1
default-router 192.168.15.1
dns-server 4.2.2.1
!
!
ip name-server 4.2.2.1
ip name-server 4.2.2.2
ip name-server 8.8.8.8
!
multilink bundle-name authenticated
!
voice-card 2
no dspfarm
!
!
!
!
voice service voip
allow-connections sip to sip
!
!
voice class codec 1
codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
!
!
!
voice register global
mode cme
max-dn 56
max-pool 22
!
!
no voice translation-rule 9
no rule 1 /^911$/ /911/
no rule 2 /^9\(.*\)/ /\1/
!
!
!
crypto pki trustpoint TP-self-signed-1538406835
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1538406835
revocation-check none
rsakeypair TP-self-signed-1538406835
!
!
crypto pki certificate chain TP-self-signed-1538406835
certificate self-signed 01
30820244 308201AD A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 31353338 34303638 3335301E 170D3132 30383135 30343139
31305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35333834
30363833 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100E675 EBB20F83 EA0DDF7A C6DE7B07 294F1F7E D2509933 BCE4B2D5 D701CC32
F3BE088B DA896381 F544B50D 05FD8213 8D076539 8A33BCBE 2530BB54 172AE878
4C027712 FE32D02A 9F131C8C EF17D69D 30E79252 4421F3FE 44747419 69A6AA8C
DD2063F6 760E6688 EBC3A24F 689ABCD8 9EB6DD42 C888A598 DC0974A3 0267F2BF
49B50203 010001A3 6C306A30 0F060355 1D130101 FF040530 030101FF 30170603
551D1104 10300E82 0C476172 77796E52 6F757465 72301F06 03551D23 04183016
80145A0E F05CB722 C5FCB540 2642CADE 6A661A55 C77A301D 0603551D 0E041604
145A0EF0 5CB722C5 FCB54026 42CADE6A 661A55C7 7A300D06 092A8648 86F70D01
01040500 03818100 C35DABC9 19B737A8 8DF9BDEF A7485975 C8CDCCD2 BB7DB713
D5472598 4DE9B647 F59983DD 3644513C 9F79D1A2 867ED559 91A139C9 DA1320DA
5DE22EA1 D690395F C23784E7 FA17F7E9 5C618ED0 70BD2F08 083AB9C7 F30F50AB
78FC801F 38B9D82F 8E583C4C F6CD02F8 8FFE443D 707F626D 7F039CFB 42DD1E13
0C91FFAF D3F51F44
quit
!
!
username xxxxxxxxxxx privilege xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
archive
log config
hidekeys
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex full
speed 100
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.15.1 255.255.255.0
no ip redirects
!
interface FastEthernet0/1
ip address 192.168.4.20 255.255.255.0
duplex auto
speed auto
!
interface Async1
no ip address
encapsulation slip
!
interface Async2
no ip address
encapsulation slip
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.4.1
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:/gui
!
!
!
!
!
!
tftp-server flash:/phone/7940-7960/P00308000400.bin alias P00308000400.bin
tftp-server flash:/phone/7940-7960/P00308000400.loads alias P00308000400.loads
tftp-server flash:/phone/7940-7960/P00308000400.sb2 alias P00308000400.sb2
tftp-server flash:/phone/7940-7960/P00308000400.sbn alias P00308000400.sbn
tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/RingList.xml alias RingList.xml
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:Desktops/320x212x12/NantucketFlowers.png
tftp-server flash:Desktops/320x212x12/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x12/Fountain.png
tftp-server flash:Desktops/320x212x12/TN-Fountain.png
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x212x12/CampusNight.png
tftp-server flash:Desktops/320x212x12/TN-CampusNight.png
tftp-server flash:Desktops/320x212x12/CiscoFountain.png
tftp-server flash:Desktops/320x212x12/TN-CiscoFountain.png
tftp-server flash:Desktops/320x212x12/MorroRock.png
tftp-server flash:Desktops/320x212x12/TN-MorroRock.png
tftp-server flash:CTLSEP00141CBCE2B8.tlv
tftp-server flash:MGCDefault.cnf
!
control-plane
!
!
!
voice-port 2/0/0
connection plar 5011
!
voice-port 2/0/1
connection plar 5012
!
voice-port 2/0/2
connection plar 5013
!
voice-port 2/0/3
connection plar 5014
!
!
!
!
dial-peer voice 1 pots
destination-pattern 9[2-9]..........
port 2/0/0
prefix 9

dial-peer voice 1 pots
description TEST
preference 1
destination-pattern 1[2-9].........
port 2/0/0
prefix 9,

no dial-peer voice 1 pots
description Long Distance Outbound
preference 1
destination-pattern 1[2-9].........
port 2/0/0
prefix 9,
!
no dial-peer voice 2 pots
description Local 10-Digit outbound
preference 1
destination-pattern [2-9].........
port 2/0/0
prefix 9,
!
no dial-peer voice 7 pots
description Long Distance Outbound
preference 3
destination-pattern 1[2-9].........
port 2/0/2
prefix 9,
!
no dial-peer voice 3 pots
description 911 outbound
preference 1
destination-pattern 911
port 2/0/0
prefix 911
!
no dial-peer voice 4 pots
description Long Distance Outbound
preference 2
destination-pattern 1[2-9].........
port 2/0/1
prefix 9
!
no dial-peer voice 5 pots
description Local 10-Digit outbound
preference 2
destination-pattern [2-9].........
port 2/0/1
prefix 9
!
no dial-peer voice 6 pots
description 911 outbound
preference 2
destination-pattern 911
port 2/0/1
prefix 911
!
no dial-peer voice 8 pots
description Local 10-Digit outbound
preference 3
destination-pattern [2-9].........
port 2/0/2
prefix 9
!
no dial-peer voice 9 pots
description 911 outbound
preference 3
destination-pattern 911
port 2/0/2
prefix 911
!
no dial-peer voice 10 pots
description Long Distance Outbound
preference 4
destination-pattern 1[2-9].........
port 2/0/3
prefix 9
no dial-peer voice 11 pots
description Local 10-Digit outbound
preference 4
destination-pattern [2-9].........
port 2/0/3
prefix 9
!
no dial-peer voice 12 pots
description 911 outbound
preference 4
destination-pattern 911
port 2/0/3
prefix 911
!
no dial-peer voice 13 pots
description incoming
incoming called-number .%
!
no dial-peer voice 14 pots
description incoming
incoming called-number .%
!
no dial-peer voice 15 pots
description incoming
incoming called-number .%
!
no dial-peer voice 16 pots
description incoming
incoming called-number .%
!
!
dial-peer outbound status-check pots
!
!
telephony-service
fxo hook-flash
load 7960-7940 P00308000400
max-ephones 100
max-dn 100
ip source-address 192.168.15.1 port 2000
no auto assign 1 to 100
no auto-reg ephone
calling-number initiator
service phone displayOnWhenIncomingCall 1
service phone settingsAccess 1
service phone displayOnTime 18:00
service phone displayOnDuration 16:00
system message Barenburg Garwyn
cnf-file location flash:
cnf-file perphone
time-zone 13
max-conferences 8 gain -6
call-park system redirect
call-forward system redirecting-expanded
dn-webedit
time-webedit
transfer-system full-consult
secondary-dialtone 9
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-template 1
softkeys idle Pickup Redial Newcall
softkeys connected Park Hold Trnsfer Endcall
!
!
ephone-dn 1 dual-line
number 5001
pickup-group 1
label 5001
description 5001
!
!
ephone-dn 2 dual-line
pickup-group 1
number 5002
label 5002
description 5002
!
!
ephone-dn 3 dual-line
pickup-group 1
number 5003
label 5003
description 5003
!
!
ephone-dn 4 dual-line
pickup-group 1
number 5004
label 5004
description 5004
!
!
ephone-dn 5 dual-line
number 5005
label 5005
description 5005
!
!
ephone-dn 6 dual-line
number 5006
!
!
ephone-dn 7 dual-line
number 5007
!
!
ephone-dn 8 dual-line
number 5008
!
!
ephone-dn 9 dual-line
number 5009
!
!
ephone-dn 10 dual-line
number 5010
!
!
ephone-dn 11 dual-line
number 5011
label 4103622020
name 4103622020
trunk A0
!
!
ephone-dn 12
number 5012
label 4103622021
name 4103622021
trunk A1
!
!
ephone-dn 13
number 5013
label 4106247660
name 4106247660
trunk A2
!
!
ephone-dn 14
number 5014
label 4106247661
name 4106247661
trunk A3
!
!
ephone-dn 15
number 5015
!
!
ephone-dn 16
number 333
park-slot
!
!
ephone-dn 31
number 131
label 5001
description intercom 5001
name 5001
intercom 5001
!
!
ephone-dn 32
number 132
label 5002
description intercom 5002
name 5002
intercom 5002
!
!
ephone-dn 33
number 133
label 5003
description intercom 5003
name 5103
intercom 5003
!
!
ephone-dn 34
number 134
label 5004
description intercom 5004
name 5004
intercom 5004
!
!
ephone-dn 35
number 135
label 5005
description intercom 5005
name 5005
intercom 5005
!
!
ephone 1
device-security-mode none
mac-address 000E.D748.5522
ephone-template 1
type 7960
button 1o1,11,12,13,14 2:32 3:33 4:34
button 5:35
!
!
!
ephone 2
device-security-mode none
mac-address 0014.1CBC.E16D
ephone-template 1
type 7960
button 1o2,11,12,13,14 2:31 3:33 4:34
button 5:35
!
!
!
ephone 3
device-security-mode none
mac-address 0014.6A87.8248
ephone-template 1
type 7960
button 1o3,11,12,13,14 2:31 3:32 4:34
button 5:35
!
!
!
ephone 4
device-security-mode none
mac-address 0014.1CBC.E2B8
ephone-template 1
type 7960
button 1o4,11,12,13,14 2:31 3:32 4:33
button 5:35
!
!
!
ephone 5
device-security-mode none
mac-address 0014.A9AE.11B7
ephone-template 1
type 7960
button 1o5,11,12,13,14 2:31 3:32 4:33
button 5:34
!
!
banner login ^CBarenburg Eye Garwyn^C
alias exec s show ip int br
alias exec sr show run
!
line con 0
exec-timeout 600 0
password xxxxxxxxxxxxxx
logging synchronous
login
line 1 2
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
privilege level 15
password xxxxxxxxxxxxx

login local
transport input telnet ssh
line vty 5 15
privilege level 15
password xxxxxxxxxxxxx
login local
transport input telnet ssh
!
ntp clock-period 17180947
ntp server 198.38.16.2 source FastEthernet0/1 prefer
!
end

  • IP Telephony
Everyone's tags (3)
6 REPLIES
Super Bronze

Bringing a Dinosaur back...well breathing some life into it at l

Hi Shawn

Firstly not sure what you need to stick in 'no's for, editing the config before you post in will just confuse the issue. Post the actual running config.

Secondly, it probably isn't a 3750, as that's a switch that has no telephony capabilities.

Your CME dial-peers all have 'prefix' commands. Basically the matched portion of a 'destination-pattern' is stripped, and a prefix is then applied afterwards before the digits go out.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Bringing a Dinosaur back...well breathing some life into it at l

I agree the NO's are confusing, it was just a way for me to comment it out.

What is the best way to get the cfg file out?  I just captured log on putty.

As far as prefixes, don't you need that to capture the line?

Thanks,


Shawn

Super Bronze

Bringing a Dinosaur back...well breathing some life into it at l

Hi

Prefixes are number manipulation, so if whatever system is connected to the ports needs to see the 9, then you need the prefix to restore it after the dial-peer has been matched. I you don't want 9 reinserting, don't have the prefix bit.

Perhaps clarify what you are asking in this thread - in your original post you suggest you think CME shouldn't be inserting 9s which is why I mention the prefix. Also what are the telephony circuits of this CME attached to?

Typically to capture a config I would log with putty then:

ter length 0

sh run

ter lengh 24

Just makes it squirt the whole thing without tapping keys.

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Bringing a Dinosaur back...well breathing some life into it at l

Ok...so the real issue are these "9's"!

When I removed from prefix I don't get an outside line from the overlayed DN's.  I have to be doing something wrong here.  I don't need the 9 at all to dial.  I thought they were necessary to grab the line??

Oh and it is a 3725 (sorry 'bout that)

Current config is:

Building configuration...


Current configuration : 10021 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GarwynRouter
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
no aaa new-model
clock timezone Eastern -5
clock summer-time DST recurring
no network-clock-participate slot 2
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.15.1 192.168.15.10
!
ip dhcp pool Voice
   network 192.168.15.0 255.255.255.0
   option 150 ip 192.168.15.1
   default-router 192.168.15.1
   dns-server 4.2.2.1
!
!
ip name-server 4.2.2.1
ip name-server 4.2.2.2
ip name-server 8.8.8.8
!
multilink bundle-name authenticated
!
voice-card 2
no dspfarm
!
!
!
!
voice service voip
allow-connections sip to sip
!
!
voice class codec 1
codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
!
!
!
voice register global
mode cme
max-dn 56
max-pool 22
!
!
!
!
crypto pki trustpoint TP-self-signed-1538406835
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1538406835
revocation-check none
rsakeypair TP-self-signed-1538406835
!
!
crypto pki certificate chain TP-self-signed-1538406835
certificate self-signed 01
  30820244 308201AD A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31353338 34303638 3335301E 170D3132 30383136 30363338
  35385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35333834
  30363833 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100E675 EBB20F83 EA0DDF7A C6DE7B07 294F1F7E D2509933 BCE4B2D5 D701CC32
  F3BE088B DA896381 F544B50D 05FD8213 8D076539 8A33BCBE 2530BB54 172AE878
  4C027712 FE32D02A 9F131C8C EF17D69D 30E79252 4421F3FE 44747419 69A6AA8C
  DD2063F6 760E6688 EBC3A24F 689ABCD8 9EB6DD42 C888A598 DC0974A3 0267F2BF
  49B50203 010001A3 6C306A30 0F060355 1D130101 FF040530 030101FF 30170603
  551D1104 10300E82 0C476172 77796E52 6F757465 72301F06 03551D23 04183016
  80145A0E F05CB722 C5FCB540 2642CADE 6A661A55 C77A301D 0603551D 0E041604
  145A0EF0 5CB722C5 FCB54026 42CADE6A 661A55C7 7A300D06 092A8648 86F70D01
  01040500 03818100 44698EF8 67103BD3 CD43D19E 5254394B 493158DD EDA49940
  F5E5A9D4 8BFF37E9 D1FDD1E2 9F502942 23EFE4C7 1C722AFD 8C503F7A 83AC8004
  F16090F3 CE6DEA4E E64E0F9A 253AEFFF 01686539 57F40F51 81838589 7954C945
  7AC178E6 F8424E73 09657731 F8C54A28 3F7130D8 CF7F93AB 56005CE3 34094635
  8C184BD4 924403F7
   quit
!
!
username xxxxxxxxxxx privilege 15 secret 5 xxxxxxxxxxxxxxxxxx

archive
log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.15.1 255.255.255.0
no ip redirects
!
interface FastEthernet0/1
ip address 192.168.4.20 255.255.255.0
duplex auto
speed auto
!
interface Async1
no ip address
encapsulation slip
!
interface Async2
no ip address
encapsulation slip
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.4.1
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
!
!
!
!
!
!
tftp-server flash:/phone/7940-7960/P00308000400.bin alias P00308000400.bin
tftp-server flash:/phone/7940-7960/P00308000400.loads alias P00308000400.loads
tftp-server flash:/phone/7940-7960/P00308000400.sb2 alias P00308000400.sb2
tftp-server flash:/phone/7940-7960/P00308000400.sbn alias P00308000400.sbn
tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/RingList.xml alias RingList.xml
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:Desktops/320x212x12/NantucketFlowers.png
tftp-server flash:Desktops/320x212x12/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x12/Fountain.png
tftp-server flash:Desktops/320x212x12/TN-Fountain.png
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x212x12/CampusNight.png
tftp-server flash:Desktops/320x212x12/TN-CampusNight.png
tftp-server flash:Desktops/320x212x12/CiscoFountain.png
tftp-server flash:Desktops/320x212x12/TN-CiscoFountain.png
tftp-server flash:Desktops/320x212x12/MorroRock.png
tftp-server flash:Desktops/320x212x12/TN-MorroRock.png
tftp-server flash:CTLSEP00141CBCE2B8.tlv
tftp-server flash:MGCDefault.cnf
!
control-plane
!
!
!
voice-port 2/0/0
connection plar 5011
!
voice-port 2/0/1
connection plar 5012
!
voice-port 2/0/2
connection plar 5013
!
voice-port 2/0/3
connection plar 5014
!
!
!
!
!
dial-peer voice 1 pots
description TEST
preference 1
destination-pattern 1[2-9].........
port 2/0/0
!
!
!
!
telephony-service
no auto-reg-ephone
fxo hook-flash
load 7960-7940 P00308000400
max-ephones 100
max-dn 100
ip source-address 192.168.15.1 port 2000
calling-number initiator
service phone displayOnWhenIncomingCall 1
service phone settingsAccess 1
service phone displayOnTime 18:00
service phone displayOnDuration 16:00
system message Barenburg Garwyn
cnf-file location flash:
cnf-file perphone
time-zone 13
max-conferences 8 gain -6
call-park system redirect
call-forward system redirecting-expanded
dn-webedit
time-webedit
transfer-system full-consult
secondary-dialtone 9
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-template  1
softkeys idle  Pickup Redial Newcall
softkeys connected  Park Hold Trnsfer Endcall
!
!
ephone-dn  1  dual-line
number 5001
pickup-group 1
label 5001
description 5001
!
!
ephone-dn  2  dual-line
number 5002
pickup-group 1
label 5002
description 5002
!
!
ephone-dn  3  dual-line
number 5003
pickup-group 1
label 5003
description 5003
!
!
ephone-dn  4  dual-line
number 5004
pickup-group 1
label 5004
description 5004
!
!
ephone-dn  5  dual-line
number 5005
label 5005
description 5005
!
!
ephone-dn  6  dual-line
number 5006
!
!
ephone-dn  7  dual-line
number 5007
!
!
ephone-dn  8  dual-line
number 5008
!
!
ephone-dn  9  dual-line
number 5009
!
!
ephone-dn  10  dual-line
number 5010
!
!
ephone-dn  11  dual-line
number 5011
label 4103622020
name 4103622020
trunk A0
!
!
ephone-dn  12
number 5012
label 4103622021
name 4103622021
trunk A1
!
!
ephone-dn  13
number 5013
label 4106247660
name 4106247660
trunk A2
!
!
ephone-dn  14
number 5014
label 4106247661
name 4106247661
trunk A3
!
!
ephone-dn  15
number 5015
!
!
ephone-dn  16
number 333
park-slot
!
!
ephone-dn  31
number 131
label 5001
description intercom 5001
name 5001
intercom 5001 no-mute
!
!
ephone-dn  32
number 132
label 5002
description intercom 5002
name 5002
intercom 5002 no-mute
!
!
ephone-dn  33
number 133
label 5003
description intercom 5003
name 5103
intercom 5003 no-mute
!
!
ephone-dn  34
number 134
label 5004
description intercom 5004
name 5004
intercom 5004 no-mute
!
!
ephone-dn  35
number 135
label 5005
description intercom 5005
name 5005
intercom 5005 no-mute
!
!
ephone  1
device-security-mode none
mac-address 000E.D748.5522
ephone-template 1
type 7960
button  1o1,11,12,13,14 2:32 3:33 4:34
button  5:35
!
!
!
ephone  2
device-security-mode none
mac-address 0014.1CBC.E16D
ephone-template 1
type 7960
button  1o2,11,12,13,14 2:31 3:33 4:34
button  5:35
!
!
!
ephone  3
device-security-mode none
mac-address 0014.6A87.8248
ephone-template 1
type 7960
button  1o3,11,12,13,14 2:31 3:32 4:34
button  5:35
!
!
!
ephone  4
device-security-mode none
mac-address 0014.1CBC.E2B8
ephone-template 1
type 7960
button  1o4,11,12,13,14 2:31 3:32 4:33
button  5:35
!
!
!
ephone  5
device-security-mode none
mac-address 0014.A9AE.11B7
ephone-template 1
type 7960
button  1o5,11,12,13,14 2:31 3:32 4:33
button  5:34
!
!
banner login ^CCBarenburg Eye Garwyn^C
alias exec s show ip int br
alias exec sr show run
!
line con 0
exec-timeout 600 0
logging synchronous
login
line 1 2
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
ntp clock-period 17180947
!
end

New Member

Bringing a Dinosaur back...well breathing some life into it at l

Aaron,

Sorry missed the bit about the lines...they are just 4 pots lines.  Nothing fancy...

New Member

Bringing a Dinosaur back...well breathing some life into it at l

So with that being said...the real answer is how do I make this setup do the following:

1) Have all the phones ring with incoming call (used overlays) and anyone can answer

2) Have the ability to dnd when in the exam room

3) pick up handset and make outgoing calls from the available lines

Perhaps I'm a little fried at the moment and can't put this together.

Thanks in advance!

Shawn

731
Views
5
Helpful
6
Replies