Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Call-forward to VoiceMail fails from PSTN, Internal works fine

Hi.

I have just installed a Contact Centre at a client's place. The setup is as follows.

HQ:

     2x CUCM (Pub and Sub) v8.5

     2x CCX    (Pub and Sub) v8.5

     1x WFO   (Recording and Monitoring) v8.5

     1x MGCP Gateway c2911 v15.(?)

          E1 Slot with PVDM3-64

     1x ISM with CUE

     Agents and IP Phones

Remote Site:

     1x MGCP Gateway c2811 v15.(?)

          half-E1 line with PVDM2-16

I cannot have a transcoder at the remote site since the E1 uses all available channels.

Transcoding of all calls is being dones at the HQ only.

Telco sends 4 digits while extensions are 3 digits. Translation-Patterns are in place to cater for the 4-to-3/3-to-4 digit translation during inbound/outbound calls.

Calls enter the remote site and go through the WAN to HQ. There, it is received by a Contact Centre agent and routed to where appropriate.

Everything is working perfectly as intended upto this point.

However, at after business hours, the IVR asks the caller to press "1" for more to reach a helpdesk (this gets correctly transferred to another extension/hunt group)

                                                                                      press "2" to leave a message.

At this point, I have created a DN in CUCM (without assigning it to a phone) and call-forwarded all calls to VoiceMail.

While testing, all the calls are correctly routed to the DN in CUCM internally.

Though trying back from the PSTN, I reach only upto the lady saying press "2". Afterwards, I get dead air.

I have tried to perform a "sh ccn ccm-manager status" on CUE  after pressing "2"

The result is that I see the status as "in-use"

Though I can still not hear any prompt.

I suspect a problem is transcoding.

Read this doc http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_configuration_example09186a00803f8950.shtml
and tried playing with device pools, regions and the menu under media resources with result that I messed with MoH. Some time later I could hear the

CUE prompt from PSTN, but then when I tested again, MoH had stopped to work giving way to ToH .

Now I have everything reverted back to the former state, that is, CUE prompt cannot be heard from PSTN.

Please have a look and advise

Thanks in advance

Everyone's tags (4)
3 REPLIES
Hall of Fame Super Gold

Call-forward to VoiceMail fails from PSTN, Internal works fine

Is g729 really necessary? Often is not. You will find that with G.711 you have less config, less resources taken, less trouble, but more quality. All that for a little bit of more bandwith, it's worth it.

Call-forward to VoiceMail fails from PSTN, Internal works fine

Hi Paolo.

I agree with you. g729 is not necessary for me, but the client is a bank.

They have all kinds of policies. And if g729 was not among them, they'd quickly make a new policy lol

Anyways, let's just say we can't do help but abide by the client's demands.

By the way, this is the largest of the client's links and has 8Mbps SHDSL.

Other sites have as low as 128kbps for voice and data.

We have to go with the g729

Call-forward to VoiceMail fails from PSTN, Internal works fine

This issue is ok now.

We messed up with regions and locations config earlier.

All clear

740
Views
0
Helpful
3
Replies
CreatePlease login to create content