Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

call forwarding problem

hi! recently i have an issue with our call forwarding in cisco call manager. It can forward the call successfully, but the caller id was not displayed in the forwarded number (external mobile number). Instead of displaying the caller id, the ISDN main line was displayed. It works fine when the caller is an internal number I see the issue when the caller is an external number.

I checked the gateway, i can see the orignial caller id, and called number. I can also see the orignial caller id with the forwarded number there.

What should i check and how should i trouble shoot the issue?

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

call forwarding problem

You should check on the trunk if SIP or on the PRI and ensure the Calling Party Selection on outbound calls or set to First Redirect Number (External) and test. 

Also if you can attach some debugs from the voice gateway that would be great to determine if the issue is with the telco or the Call Manager

8 REPLIES

call forwarding problem

Hi dave,

Which gateway you are using?

Regards,

Nishant Savalia   

Regards, Nishant Savalia
New Member

call forwarding problem

hi! it;s a cisco gateway.

Cisco Employee

call forwarding problem

Most likely there's nothing to troubleshoot here, in many cases the telco won't allow you to send anything beyond the DID range you own as calling party and will overwrite it with the main/billing DID if you do so.

If you see the right info when debugging the call on the GW, but still get nothing but the main DID when the calling party does not belong to your range, then you need to call telco and see if they can change that.

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

call forwarding problem

hi! This was working all the while. Only recently that the issue occured. So, i don't think the issue is from the telco.

Here's the log i see when i turn the isdn debug. i guessed it's showing the correct info. Just that the forwarded receiver is not seeing the Original caller id, but the main line number instead. Thanks.

Feb  6 14:49:49.617: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0576

        Sending Complete

        Bearer Capability i = 0x9090A3

                Standard = CCITT

                Transfer Capability = 3.1kHz Audio

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA1839A

                Preferred, Channel 26

        Progress Ind i = 0x8283 - Origination address is non-ISDN 

        Calling Party Number i = 0x4183, '78844515' <--------------------------Original Caller ID

                Plan:ISDN, Type:Subscriber(local)

        Called Party Number i = 0x80, '68814433' <-------------------------------Called number

                Plan:Unknown, Type:Unknown

Feb  6 14:49:49.669: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x8576

        Channel ID i = 0xA9839A

                Exclusive, Channel 26

Feb  6 14:49:49.669: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x1217

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98381

                Exclusive, Channel 1

        Progress Ind i = 0x8283 - Origination address is non-ISDN 

        Calling Party Number i = 0x4183, '78844515' <------------------------------Original Caller ID

                Plan:ISDN, Type:Subscriber(local)

        Called Party Number i = 0x80, '91202222' <-----------------------------------Forwarded number

                Plan:Unknown, Type:Unknown

Feb  6 14:49:49.725: ISDN Se0/0/0:15 Q931: RX <- CALL_PROC pd = 8  callref = 0x9217

        Channel ID i = 0xA98381

                Exclusive, Channel 1

Feb  6 14:49:54.425: ISDN Se0/0/0:15 Q931: RX <- ALERTING pd = 8  callref = 0x9217

        Progress Ind i = 0x8288 - In-band info or appropriate now available

Feb  6 14:49:54.429: ISDN Se0/0/0:15 Q931: TX -> ALERTING pd = 8  callref = 0x8576

        Progress Ind i = 0x8288 - In-band info or appropriate now available

Feb  6 14:50:01.773: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x0576

        Cause i = 0x829000000000 - Normal call clearing

Feb  6 14:50:01.789: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x1217

        Cause i = 0x8290 - Normal call clearing

Feb  6 14:50:01.821: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x8576

Feb  6 14:50:01.933: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x9217

Feb  6 14:50:01.937: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x0576

Feb  6 14:50:01.973: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x1217Feb  6 14:49:49.617:

Cisco Employee

call forwarding problem

The last point over which you have control of this, is that SETUP message, if the information for the call is what you expect in that message, then that's all you can do. If the called party doesn't receive the same info, it's not something you can fix, someone in the middle is doing that, and that someone in the middle, is your telco, and depending on the call flow, maybe other telcos.

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

call forwarding problem

You should check on the trunk if SIP or on the PRI and ensure the Calling Party Selection on outbound calls or set to First Redirect Number (External) and test. 

Also if you can attach some debugs from the voice gateway that would be great to determine if the issue is with the telco or the Call Manager

New Member

call forwarding problem

hi! sorry, the issue hsa not been resolved. I accidentally clicked on the correct answer.

what should i check on the outbound calls portion? Currently it's set as originator. It has been working with this setting.

what debug mode should i use to troubleshoot this issue? and what shd i lookout for?

call forwarding problem

Hi dave,

From the debug it is clear that the forwarded number is sent out of your PRI i.e. towards Telco. Am i right?

Please try below command under s0/0/0:15

int s0/0/0:15

isdn outgoing ie redirecting-number

exit


Regards,
Nishant Savalia

Regards, Nishant Savalia
216
Views
0
Helpful
8
Replies
CreatePlease login to create content