Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Call hits Intercom!! How??!!

I setup an intercom attachment to an FXS port.  This morning, one of my users placed a phone call and we heard the whole thing over the intercomm...Is it my setup?

The 2801 with FXS is in H323 mode, here's the portion for the intercom code (we want people to dial *34 for the intercom):

dial-peer voice 55 pots
description Paging for Fire
destination-pattern *34
port 0/2/0
forward-digits all

Now the strange part is, (and obviously I am changing #s a bit here to protect the innocent), my user was calling someone's cell phone and the # is sort of 686-9003, so no sign of the pattern there.   Now the first time she did this and we heard the message she was leaving over our intercom, we called her and told her what had happened.  So she figured the call did not get delivered, so she called the cell again.  And again this time, we heard her call over the intercom!  So we had her try other calls to other cell lines and POTS lines and none of those came over the intercom.  So I am thinking the cell phone subscriber must have their phone setup to forward to a speed dial like *34, and somehow we see that and turn the intercom on...what is weird is that you now have 2 calls going, one to the cell phone and one to the FXS port.

Other than a FAC, any good ways to prevent this from happening?  I have done lots of these setups and never had anything like this happen!

Would love any insight!

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Call hits Intercom!! How??!!

Well, when you can - if it's a dedicated interface (usually is for paging), I think it's better to have a dedicate route group and route list. The pattern you choose to access the OH system is then just pointed at that single RL. No potential confusion there. The FAC is up to you. When everyone has access to dial the paging system - FAC doesn't really amount to much (IMO) but I have customers that prefer to go that route anyway.

Hailey

Please rate helpful posts!

6 REPLIES

Re: Call hits Intercom!! How??!!

Out of curiousity, did you set up a separate Route Group and Route List for the Intercom?  If not, I would check to see if this gateway was inadvertently added in a priority order on a Route List associated with PSTN dialing.  Worth a look.

Hailey

Please rate helpful posts!

Community Member

Re: Call hits Intercom!! How??!!

I did not setup a separate Group or List.  The 2801 has tow POTS lines and is the main VGW with the ISDN line as well.

I can set one up, but we want everyone to continue to have access to this intercom code.  I am wondering if a FAC is just easier!!

Re: Call hits Intercom!! How??!!

Well, when you can - if it's a dedicated interface (usually is for paging), I think it's better to have a dedicate route group and route list. The pattern you choose to access the OH system is then just pointed at that single RL. No potential confusion there. The FAC is up to you. When everyone has access to dial the paging system - FAC doesn't really amount to much (IMO) but I have customers that prefer to go that route anyway.

Hailey

Please rate helpful posts!

Community Member

Re: Call hits Intercom!! How??!!

I agree with David. The FAC isn't going to do much for you. I think you need to turn on some debugs to figure out how a call to your ISDN circuit is being sent to the FXS interface.

Re: Call hits Intercom!! How??!!

Do you have another dial-peer that specifies that port?  Can you share the full config of your 2801, with 'debug voice ccapi inout' during one of these calls?

Also, is it only effecting this user to this one number?  What if someone else call that cell phone?

Community Member

Re: Call hits Intercom!! How??!!

No, no other dial peer specifies that port.

I just placed the call to the cell phone user, and the cell phone user answered, so I cannot duplicate the issue.

My end user describes this morning's event like this:

She goes to dial the cell phone person.  Presses 9 so she can have an outbound line.  The person's cell is fairly innocuous, no 3 and 4 together, in fact there is no 4 in the number.  Once she dials the # she gets  this sort of automated voice that says "Per this subscriber's request this phone cannot accept any incoming calls.  Reference # MA95285".  She then hears a beep.  Thinking this is the answering machine of the cell phone, she starts talking, and that's when it starts going over the intercom.

I have to believe that it is the cell phone that (perhaps since it won't accept any incoming calls) is being forwarded or is itself dialing a *34 code, and we pick it up.

My 2801 config (edited to remove sensitive info):

!

! Last configuration change at 10:51:37 edt Fri Apr 23 2010
! NVRAM config last updated at 10:51:55 edt Fri Apr 23 2010
!
version 12.4
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
service sequence-numbers
!
hostname noname-2801
!
boot-start-marker
boot system flash:c2801-spservicesk9-mz.124-22.T.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 4096 informational
enable secret 5 $1$rDeJ$wQbhfjKKM2KiBeHquZr51
!
no aaa new-model
clock timezone est -5
clock summer-time edt recurring
network-clock-participate wic 1
network-clock-select 1 T1 0/1/0
dot11 syslog
ip source-route
!
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
isdn switch-type primary-ni
!
voice class codec 100
codec preference 1 g711ulaw
codec preference 2 g729br8
codec preference 3 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
h225 display-ie ccm-compatible
!
voice-card 0
!
!
archive
log config
  hidekeys
!
!
controller T1 0/1/0
pri-group timeslots 9-24
!
interface Vif1
no ip address
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.6.229 255.255.255.0
speed 100
full-duplex
!
interface Serial0/1/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn supp-service name calling
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.6.210
ip http server
no ip http secure-server
!
!
snmp-server community hiddentext RO
disable-eadi
!
control-plane
!
voice-port 0/0/0
connection plar 2002
description 111-222-3223
caller-id enable
!
voice-port 0/0/1
connection plar 4074
description 111-222-3333
caller-id enable
!
voice-port 0/0/2
echo-cancel coverage 48
timing hookflash-out 500
!
voice-port 0/0/3
echo-cancel coverage 48
timing hookflash-out 500
!
voice-port 0/1/0:23
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/2/2
!
voice-port 0/2/3
!
no ccm-manager fax protocol cisco
!
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp fax t38 ecm
!
dial-peer voice 7 voip
preference 1
destination-pattern 1...
progress_ind setup enable 3
voice-class codec 100
voice-class h323 1
session target ipv4:192.168.6.1
incoming called-number .
dtmf-relay h245-alphanumeric
ip qos dscp cs5 media
no vad
!
dial-peer voice 8 voip
preference 1
destination-pattern 8...
progress_ind setup enable 3
voice-class codec 100
voice-class h323 1
session target ipv4:192.168.6.1
incoming called-number .
dtmf-relay h245-alphanumeric
ip qos dscp cs5 media
no vad
!
dial-peer voice 9 voip
preference 1
destination-pattern 4...
progress_ind setup enable 3
voice-class codec 100
voice-class h323 1
session target ipv4:192.168.6.1
incoming called-number .
dtmf-relay h245-alphanumeric
ip qos dscp cs5 media
no vad
!
dial-peer voice 10 voip
preference 1
destination-pattern 2...
progress_ind setup enable 3
voice-class codec 100
voice-class h323 1
session target ipv4:192.168.6.1
incoming called-number .
dtmf-relay h245-alphanumeric
ip qos dscp cs5 media
no vad
!
dial-peer voice 100 pots
preference 1
destination-pattern 9T
direct-inward-dial
port 0/1/0:23
!
dial-peer voice 101 pots
preference 2
destination-pattern 9T
port 0/2/0
!
dial-peer voice 102 pots
preference 3
destination-pattern 9T
port 0/2/1
!
dial-peer voice 911 pots
preference 1
destination-pattern 9911
port 0/0/0
prefix 911
!
dial-peer voice 913 pots
preference 4
destination-pattern 9911
direct-inward-dial
port 0/1/0:23
prefix 911
!
dial-peer voice 912 pots
preference 3
destination-pattern 9911
port 0/0/1
prefix 911
!
dial-peer voice 17 voip
preference 1
destination-pattern 6...
progress_ind setup enable 3
voice-class codec 100
voice-class h323 1
session target ipv4:192.168.6.1
incoming called-number .
dtmf-relay h245-alphanumeric
ip qos dscp cs5 media
no vad
!
dial-peer voice 11 voip
preference 1
destination-pattern 3...
progress_ind setup enable 3
voice-class codec 100
voice-class h323 1
session target ipv4:192.168.6.1
incoming called-number .
dtmf-relay h245-alphanumeric
ip qos dscp cs5 media
no vad
!
dial-peer voice 55 pots
description Paging for Fire
destination-pattern *34
port 0/2/0
forward-digits all
!
!
num-exp 8581 4071
num-exp 8812 1752
!
line con 0
password 7 045A081206
login
line aux 0
line vty 0 4
password 7 1416111F05
login
line vty 5 15
password 7 070E225847
login
!
scheduler allocate 20000 1000
ntp server 192.168.6.1
end
l

296
Views
8
Helpful
6
Replies
CreatePlease to create content