Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Call Manager Express ntp Server

Dear Support,

I need to implement a ip telephony with call manager express with voice, voicemail, video etc etc.

i will use cisco router 2951 with Cisco Unity Express with 50 Ip phones.

i will also 1 3750 switch and others Switch 2960 for access devices

My question is i don't have ntp server in my organisation,

What can i do? it's the core switch (3750) can be ntp server for all others switches and router?

Where can i found the peer server to sync my CUCM router?

Thanks in advance.

3 ACCEPTED SOLUTIONS

Accepted Solutions
Super Bronze

Call Manager Express ntp Server

Hi

You can set up an internal NTP service by installing NTP on a server in your org. I've used this before : http://www.meinberg.de/english/sw/ntp.htm

Alternatively you can permit your CME router to reach NTP servers on the net and point it at a pool of NTP servers (e.g. from here : http://www.pool.ntp.org/en/).

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Call Manager Express ntp Server

If there is no where to pull time from at all, and you don't want to use your PC as a timeserver then all you can do is set the clock and timezone in the call manager to whatever time it is and do Router(config)# ntp master 1. This will make your call manager router the master ntp timeserver, but again, it's not clocked off of anything but itself, so never shut it off..

New Member

Call Manager Express ntp Server

Correct. Once the CME is ntp master then you can peer other devices off of it by the ip address of one of the interfaces on the CME. No need to do anything under "telephony-service" as far as ntp. The CME will also set the times on the phones as well.

22 REPLIES
Super Bronze

Call Manager Express ntp Server

Hi

You can set up an internal NTP service by installing NTP on a server in your org. I've used this before : http://www.meinberg.de/english/sw/ntp.htm

Alternatively you can permit your CME router to reach NTP servers on the net and point it at a pool of NTP servers (e.g. from here : http://www.pool.ntp.org/en/).

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Call Manager Express ntp Server

Hi Aaron,

If i permit my cme to reach ntp server, what will be the configuration of ntp section  while configuring ip telephony;

i read that when configuring ip telephony you need to declare the ntp server on the cme.

The ntp server will be the router itself?

Regards

New Member

Call Manager Express ntp Server

I have a little Cisco 1605r router acting as my NTP server for ll of my routers getting its clock from an ethernet port (192.168.6.170) connected to a linksys router thats connected to the internet.The other ethernet port on my 1605r (192.168.2.50) goes to a catalyst switch that my laptop (192.168.2.5) is hooked up to for telnet to my router. I also have an ethernet wic card in my CME 1760 (192.168.2.10) that goes to this switch just for telnet as well. Here is the config for the 1605r as an NTP server.

clock timezone EST -4

ip name-server 4.2.2.2

ntp master 1
ntp peer 66.228.35.252

In my CME I have this in able to get the time from the 1605r, using the common ethernet connections on the 192.168.2.x subnet.

ntp peer 192.168.2.50

New Member

Call Manager Express ntp Server

Deat Ted,

Thanks, what to do if in the organisation, there is no other router instead of the cme router?

I have Level 3 switch for inter-vlan routing.

I have only the cme routing for ipbx, no other router for ntp.

how can i configure the ntp section on my cme router?

Regards

New Member

Call Manager Express ntp Server

If there is no where to pull time from at all, and you don't want to use your PC as a timeserver then all you can do is set the clock and timezone in the call manager to whatever time it is and do Router(config)# ntp master 1. This will make your call manager router the master ntp timeserver, but again, it's not clocked off of anything but itself, so never shut it off..

New Member

Call Manager Express ntp Server

Thanks Ted,

But with this where the call manger is the ntp master 1.

When i configured the telephony-service on the router, do i need to again specify the ntp with this command.

Router(config)# ntp server 192.168.1.1 where 192.168.1.1 is the router itself ip address?

Regars

New Member

Call Manager Express ntp Server

I'm not quite understanding what you want to accomplish here. You do not configure any ntp settings under the "telephony-service" section. Once you apply the "ntp master 1" command in the general "config t" part of the router, the router then becomes the master ntp server. You then "peer" other devices to the router that is setup as the ntp master so the other routers can get their time for the ntp master and be in sync with it.

New Member

Call Manager Express ntp Server

Thanks Ted,

my concern is that once i declare the  as cme ntp master,

it's not necessary to configure again the ntp on the router itself. (not under telephony-services option).

Regards

New Member

Call Manager Express ntp Server

Correct. Once the CME is ntp master then you can peer other devices off of it by the ip address of one of the interfaces on the CME. No need to do anything under "telephony-service" as far as ntp. The CME will also set the times on the phones as well.

New Member

Call Manager Express ntp Server

Thanks Ted,

Ca you please help me again regarding another point

i cannot create cn-files

when i write the command, i have an error

ROUTER(config-telephony)#create cnf-files
CNF file creation is already On
Updating CNF files

%Error deleting flash:SEPDEFAULT.cnf (File not found)
%Error deleting flash:XMLDefault.cnf.xml (File not found)
CNF files update complete

ROUTER(config-telephony)#

and on the flash: there is no SEPDEFAULT.cnf and XMLDefault.cnf.xml files

below is the  flash:

Directory of flash:/

    1  -rw-    32153740  May 26 2012 15:00:02 +01:00  c3845-ipvoicek9-mz.124-18.bin
    2  drw-           0  May 26 2012 15:02:38 +01:00  bacdprompts
   14  -rw-       22224  May 26 2012 15:02:42 +01:00  CME43-full-readme-v.2.0.txt
   15  drw-           0  May 26 2012 15:02:44 +01:00  Desktops
   28  drw-           0  May 26 2012 15:02:46 +01:00  gui
   46  -rw-      496521  May 26 2012 15:02:52 +01:00  music-on-hold.au
   47  drw-           0  May 26 2012 15:02:54 +01:00  phone
  128  drw-           0  May 26 2012 15:04:46 +01:00  ringtones

127897600 bytes total (27074560 bytes free)
ROUTER#

ROUTER#sh version
Cisco IOS Software, 3800 Software (C3845-IPVOICEK9-M), Version 12.4(18), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Fri 30-Nov-07 23:50 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T10, RELEASE SOFTWARE (fc1)

New Member

Call Manager Express ntp Server

Please post your complete router conifg from show running-config. When I do a dir flash: from my CME, it looks like this. I'm not an expert by any means, I'm still learning, but I don't know why your dir flash: looks the way it does on your CME.

My dir flash: output

c1700-ipvoicek9-mz.124-15.T7.bin

bacdprompts/app-b-acd-2.1.2.2-ReadMe.txt

bacdprompts/app-b-acd-2.1.2.2.tcl

bacdprompts/app-b-acd-aa-2.1.2.2.tcl

bacdprompts/en_bacd_allagentsbusy.au

bacdprompts/en_bacd_disconnect.au

bacdprompts/en_bacd_enter_dest.au

bacdprompts/en_bacd_invalidoption.au

bacdprompts/en_bacd_music_on_hold.au

bacdprompts/en_bacd_options_menu.au

bacdprompts/en_bacd_welcome.au

bacdprompts/en_bacd_xferto_operator.au

CME41-full-readme.txt

Desktops/320x212x12/List.xml

Desktops/320x212x12/MorroRock.png

Desktops/320x212x12/TN-CiscoFountain.png

Desktops/320x212x12/CiscoFountain.png

gui/admin_user.html

gui/admin_user.js

gui/CiscoLogo.gif

gui/CME_GUI_README.TXT

gui/Delete.gif

gui/dom.js

gui/downarrow.gif

gui/ephone_admin.html

gui/logohome.gif

gui/normal_user.html

gui/normal_user.js

gui/Plus.gif

gui/sxiconad.gif

gui/Tab.gif

gui/telephony_service.html

gui/uparrow.gif

gui/xml-test.html

gui/xml.template

phone/7912/CP7912080001SCCP051117A.sbin

ringtones/Classic2.raw

ringtones/Classic1.raw

ringtones/Analog2.raw

ringtones/Ring2.raw

ringtones/Ring1.raw

ringtones/Pulse1.raw

ringtones/Analog1.raw

ringtones/DistinctiveRingList.xml

ringtones/RingList.xml

music-on-hold.au

New Member

Call Manager Express ntp Server

Thanks Ted,

its seems that these files are located on system/its/

Directory of system:/its/

   18  -rw-           0                      ATADefault.cnf.xml
   20  drwx           0                      austria
   22  drwx           0                      canada
   24  drwx           0                      denmark
   31  drwx           0                      france
   38  drwx           0                      germany
   45  drwx           0                      italy
  106  drwx           0                      japan
   52  drwx           0                      netherlands
   59  drwx           0                      norway
   66  drwx           0                      portugal
   73  drwx           0                      russia
   19  -rw-          60   Jun 8 2012 17:11:36 +01:00  SEPDEFAULT.cnf
   81  drwx           0                      spain
   88  drwx           0                      sweden
   95  drwx           0                      switzerland
   97  drwx           0                      united_kingdom
   99  drwx           0                      united_states
   15  -rw-           0                      XMLDefault-1.cnf.xml
   16  -rw-           0                      XMLDefault-2.cnf.xml
   14  -rw-           0                      XMLDefault.cnf.xml
    6  -rw-           0                      XMLDefault7902.cnf.xml
    4  -rw-           0                      XMLDefault7905.cnf.xml
    3  -rw-           0                      XMLDefault7910.cnf.xml
    5  -rw-           0                      XMLDefault7912.cnf.xml
   12  -rw-           0                      XMLDefault7920.cnf.xml
   17  -rw-           0                      XMLDefault7935.cnf.xml
    7  -rw-           0                      XMLDefault7936.cnf.xml
   13  -rw-           0                      XMLDefault7960.cnf.xml
   11  -rw-           0                      XMLDefault7961.cnf.xml
    8  -rw-           0                      XMLDefault7970.cnf.xml
    9  -rw-           0                      XMLDefault7971.cnf.xml
   10  -rw-           0                      XMLDefaultCIPC.cnf.xml

No space information available
ROUTER#

New Member

Call Manager Express ntp Server

Ok. Now post the entire running-config so we can see whats exactly going on here..

New Member

Call Manager Express ntp Server

Hi Ted,

find the entire run conf

ROUTER#sh running-config
Building configuration...

Current configuration : 8223 bytes
!
! Last configuration change at 17:26:36 WST Fri Jun 8 2012
! NVRAM config last updated at 17:26:59 WST Fri Jun 8 2012
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ROUTER
!
boot-start-marker
boot system flash:c3845-ipvoicek9-mz.124-18.bin
boot-end-marker
!
enable password cisco
!
no aaa new-model
memory-size iomem 10
clock timezone WST 1
clock calendar-valid
ip cef   
!
!
no ip dhcp use vrf connected
!
ip dhcp pool ITS
   network 172.16.100.0 255.255.255.0
   default-router 172.16.100.1
   option 150 ip 172.16.100.1
!
!
no ip domain lookup
voice-card 0
no dspfarm
!
!
!
!
voice service voip
sip
!
!
!
!        
!
!
!
!
!
!
!
!
!
!
ip ftp username roland
ip ftp password roland
!
class-map match-all L3-to-L2_VoIP-Cntrl
match ip dscp af31
class-map match-all L3-to-L2_VoIP-RTP
match ip dscp ef
!
!
policy-map output-L3-to-L2
class L3-to-L2_VoIP-RTP
  priority 8
class L3-to-L2_VoIP-Cntrl
!
!
!
!
interface GigabitEthernet0/0
ip address 172.16.100.1 255.255.255.0
load-interval 30
duplex full
speed auto
media-type rj45
service-policy output output-L3-to-L2
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/gui
!
!
!
tftp-server flash:Desktops/320x212x12/CampusNight.png
tftp-server flash:Desktops/320x212x12/CiscoFountain.png
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x212x12/MorroRock.png
tftp-server flash:Desktops/320x212x12/NantucketFlowers.png
tftp-server flash:Desktops/320x212x12/TN-CampusNight.png
tftp-server flash:Desktops/320x212x12/TN-CiscoFountain.png
tftp-server flash:Desktops/320x212x12/TN-Fountain.png
tftp-server flash:Desktops/320x212x12/TN-MorroRock.png
tftp-server flash:Desktops/320x212x12/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x12/Fountain.png
tftp-server flash:gui/admin_user.html
tftp-server flash:gui/admin_user.js
tftp-server flash:gui/CiscoLogo.gif
tftp-server flash:gui/Delete.gif
tftp-server flash:gui/dom.js
tftp-server flash:gui/downarrow.gif
tftp-server flash:gui/ephone_admin.html
tftp-server flash:gui/logohome.gif
tftp-server flash:gui/normal_user.html
tftp-server flash:gui/normal_user.js
tftp-server flash:gui/Plus.gif
tftp-server flash:gui/sxiconad.gif
tftp-server flash:gui/Tab.gif
tftp-server flash:gui/telephony_service.html
tftp-server flash:gui/uparrow.gif
tftp-server flash:gui/xml-test.html
tftp-server flash:gui/xml.template
tftp-server flash:phone/7945-7965/apps45.8-3-2-27.sbn alias apps45.8-3-2-27.sbn
tftp-server flash:phone/7945-7965/cnu45.8-3-2-27.sbn alias cnu45.8-3-2-27.sbn
tftp-server flash:phone/7945-7965/cvm45sccp.8-3-2-27.sbn alias cvm45sccp.8-3-2-27.sbn
tftp-server flash:phone/7945-7965/dsp45.8-3-2-27.sbn alias dsp45.8-3-2-27.sbn
tftp-server flash:phone/7945-7965/jar45sccp.8-3-2-27.sbn alias jar45sccp.8-3-2-27.sbn
tftp-server flash:phone/7945-7965/SCCP45.8-3-3S.loads alias SCCP45.8-3-3S.loads
tftp-server flash:phone/7945-7965/term45.default.loads alias term45.default.loads
tftp-server flash:phone/7945-7965/term65.default.loads alias term65.default.loads
tftp-server flash:phone/7906-7911/apps11.8-3-2-27.sbn alias apps11.8-3-2-27.sbn
tftp-server flash:phone/7906-7911/cnu11.8-3-2-27.sbn alias cnu11.8-3-2-27.sbn
tftp-server flash:phone/7906-7911/cvm11sccp.8-3-2-27.sbn alias cvm11sccp.8-3-2-27.sbn
tftp-server flash:phone/7906-7911/dsp11.8-3-2-27.sbn alias dsp11.8-3-2-27.sbn
tftp-server flash:phone/7906-7911/jar11sccp.8-3-2-27.sbn alias jar11sccp.8-3-2-27.sbn
tftp-server flash:phone/7906-7911/SCCP11.8-3-3S.loads alias SCCP11.8-3-3S.loads
tftp-server flash:phone/7906-7911/term06.default.loads alias term06.default.loads
tftp-server flash:phone/7906-7911/term11.default.loads alias term11.default.loads
tftp-server flash:phone/7914/S00105000300.sbn alias S00105000300.sbn
tftp-server flash:phone/7920/cmterm_7920.4.0-03-02.bin alias cmterm_7920.4.0-03-02.bin
tftp-server flash:phone/7921/APPS-1.1.1.SBN alias APPS-1.1.1.SBN
tftp-server flash:phone/7921/CP7921G-1.1.1.LOADS alias CP7921G-1.1.1.LOADS
tftp-server flash:phone/7921/GUI-1.1.1.SBN alias GUI-1.1.1.SBN
tftp-server flash:phone/7921/SYS-1.1.1.SBN alias SYS-1.1.1.SBN
tftp-server flash:phone/7921/TNUX-1.1.1.SBN alias TNUX-1.1.1.SBN
tftp-server flash:phone/7921/TNUXR-1.1.1.SBN alias TNUXR-1.1.1.SBN
tftp-server flash:phone/7921/WLAN-1.1.1.SBN alias WLAN-1.1.1.SBN
tftp-server flash:phone/7931/apps31.8-3-2-27.sbn alias apps31.8-3-2-27.sbn
tftp-server flash:phone/7931/cnu31.8-3-2-27.sbn alias cnu31.8-3-2-27.sbn
tftp-server flash:phone/7931/cvm31sccp.8-3-2-27.sbn alias cvm31sccp.8-3-2-27.sbn
tftp-server flash:phone/7931/dsp31.8-3-2-27.sbn alias dsp31.8-3-2-27.sbn
tftp-server flash:phone/7931/jar31sccp.8-3-2-27.sbn alias jar31sccp.8-3-2-27.sbn
tftp-server flash:phone/7931/SCCP31.8-3-3S.loads alias SCCP31.8-3-3S.loads
tftp-server flash:phone/7931/term31.default.loads alias term31.default.loads
tftp-server flash:phone/7937/apps37sccp.1-1-1-1.bin alias apps37sccp.1-1-1-1.bin
tftp-server flash:phone/7940-7960/P00308000500.bin alias P00308000500.bin
tftp-server flash:phone/7940-7960/P00308000500.loads alias P00308000500.loads
tftp-server flash:phone/7940-7960/P00308000500.sb2 alias P00308000500.sb2
tftp-server f942-7962/jar42sccp.8-3-2-27.sbn alias jar42sccp.8-3-2-27.sbn
tftp-server 5/apps75.8-3-n alias cnu75.8-3-2-27.sbn
tftp-server flash:phone/7975/cvm75sccp.8-3-2-27.sbn alias cvm75sccp.8-3-2-27.sbn
tftp-server flash:phone/7975/dsp75.8-3-2-27.sbn alias dsp75.8-3-2-27.sbn
tftp-server flash:phone/7975/jar75sccp.8-3-2
tftp-server flash:ringtones/Classic2.raw
tftp-server flash:ringtones/ClockShop.raw
tftp-server flash:ringtones/DistinctiveRingList.xml
tftp-server flash:ringtones/Drums1.raw
tftp-server flash:ringtones/Drums2.raw
tftp-server flash:ringtones/FilmScore.raw
tftp-server flash:ringtones/HarpSynth.raw
tftp-server flash:ringtones/Jamaica.raw
tftp-server flash:ringtones/KotoEffect.raw
tftp-server flash:ringtones/MusicBox.raw
tftp-server flash:ringtones/Piano1.raw
tftp-server flash:ringtones/Piano2.raw
tftp-server flash:ringtones/Pop.raw
tftp-server flash:ringtones/Pulse1.raw
tftp-server flash:ringtones/Ring1.raw
tftp-server flash:ringtones/Ring2.raw
tftp-server flash:ringtones/Ring3.raw
tftp-server flash:ringtones/Ring4.raw
tftp-server flash:ringtones/Ring5.raw
tftp-server flash:ringtones/Ring6.raw
tftp-server flash:ringtones/Ring7.raw
tftp-server flash:ringtones/RingList.xml
tftp-server flash:ringtones/Sax1.raw
tftp-server flash:ringtones/Sax2.raw
tftp-server flash:ringtones/Vibe.raw
tftp-server flash:apps11.8-3-2-27.sbn
tftp-server flash::phone/7906-7911/apps11.8-3-2-27.sbn
tftp-server flash:/phone/7906-7911/apps11.8-3-2-27.sbn
tftp-server flash:/phone/7906-7911/cnu11.8-3-2-27.sbn
tftp-server flash:/phone/7906-7911/cvm11sccp.8-3-2-27.sbn
tftp-server flash:/phone/7906-7911/dsp11.8-3-2-27.sbn
tftp-server flash:/phone/7906-7911/jar11sccp.8-3-2-27.sbn
tftp-server flash:/phone/7906-7911/SCCP11.8-3-3S.loads
tftp-server flash:/phone/7906-7911/term06.default.loads
tftp-server flash:/phone/7906-7911/term11.default.loads
tftp-server flash:phone/7940-7960/P00308000500.sb2 alias P00308000500.sbn
!
control-plane
!
!
!
!
!
!
!
!
telephony-service
load 7910 P004E302
load 7960-7940 P00308000500
load 7914 S00105000300
load 7920 cmterm_7920.4.0-03-02
load 7961 SCCP41.8-3-3S
load 7971 SCCP70.8-3-3S
load 7970 SCCP70.8-3-3S
max-ephones 10
max-dn 20
ip source-address 172.16.100.1 port 2000
system message IPNET-SERVICES
time-zone 21
time-format 24
max-conferences 10 gain -6
web admin system name cisco password cisco
time-webedit
transfer-system full-consult
!
!
ephone-dn  1
number 100
!
!
ephone-dn  2
number 101
!
!
ephone-dn  3
number 102
!
!        
ephone-dn  4
number 104
!
!
ephone  1
mac-address 2893.FE13.8750
button  1:1
!
!
!
ephone  2
mac-address 2893.FE13.81EC
button  1:2
!
!
!
ephone  3
mac-address 001A.2F33.6D26
button  1:3
!
!
!
ephone  4
mac-address 0022.644A.E6C9
button  1:4
!
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
ntp master 1
!
end

ROUTER#

New Member

Call Manager Express ntp Server

Does any of this work so far? I see that you have a 2951 CME router from your top post but your running an IOS (c3845-ipvoicek9-mz.124-18.bin) from a 3845 router on it. When I checked the Cisco site for that c3845 IOS, it doesn't show the 2951 model as one that it works on. Am I wrong?

New Member

Call Manager Express ntp Server

Hi Ted,

Now i'm at home making a lab with a cisco 3845 router, 2951 is for the near future for a client.

New Member

Call Manager Express ntp Server

Can't you try to put these two files back on the flash exactly where they are supposed to be so that when you create the CNF again it will be able to delete them? If they were already on the flash you can recover them if you havn't "squeezed" the flash to permanatly delete them.

Error deleting flash:SEPDEFAULT.cnf (File not found)

%Error deleting flash:XMLDefault.cnf.xml (File not found)

New Member

Call Manager Express ntp Server

I copied the both files from system:/its to flash:

when i created the cn-files, no error message, but the systeme delete them from the flash:

New Member

Call Manager Express ntp Server

So will that work for you now? I'm just curious, what are you doing for a dial plan? Are you still building the config?

New Member

Call Manager Express ntp Server

Hi,

The config work, i have 3 ip phones numbers 100, 101 and 102, i call any extensions without problems

Only the cn-files that are not in the flash:

when i copy these files from systeme:/its to flash:, when the router reboot, thses files disapeared.

Regars

New Member

Call Manager Express ntp Server

I sent you a private message that might help you out. Check it out..

New Member

Call Manager Express ntp Server

Thanks,

how and where to see the private message

4869
Views
0
Helpful
22
Replies