Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Call Manager Upgrade/Install

Trying to upgrade CCM Pub and sub with new hardware and new CCM version. Existing CCM installation running on 7845's with OS 2000.2.7sr8 and CCM 4.0.(2a)sr2c. Built new hardware server using new 7845, installed OS 2000.2.7sr8 then installed CCM 4.0.1 (Only CD available), don't have the 4.0.2a disks), then upgraded to 4.0(2a)downloaded from CCO. Upgraded that to CCM 4.0(2a)sr2c (from CCO). Publisher is now up and working. Attempted same upgrade plan with the Sub, i.e. install OS 2000.2.7sr8, which worked ok. Now trying to install CCM 4.0(1) from disk, and the install wizard is complaining that the CCM Pub is not at the same version. Tried to install the CCO copy of CCM 4.0(2a)sr2c, but that warns that it is to be used for upgrades only and not new installs. Cannot find a way to downgrade CCM Pub to 4.0(1), which is what it seems to want. It seems to me that the only way out is to start completely over and re-load the pub from scratch, and stop at 4.0(1) then bring up a subscriber, before going to 4.0(2a). That seems crazy to me, anybody have a better path??

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Call Manager Upgrade/Install

Thats correct. The pub and sub need to be at same version. What you should have done is to install pub and sub at 4.0(1) first and then upgrade both to 4.02a and sr2c (both boxes). At this point you should have a blank pub and sub database at verison 4.02asr2c. Then you should restore the database on the pub. The sub should automatically get the config after database replication. You can additionally force a replication.

While doing upgrades like this, i typically take backup images of the last known good configuration (in your case you should have taken a system backup of 4.01 publisher).

You can use system backup software such as Veritas backup, Acronis, Ghost etc.

HTH

Sankar

PS: please remember to rate posts!

3 REPLIES

Re: Call Manager Upgrade/Install

Thats correct. The pub and sub need to be at same version. What you should have done is to install pub and sub at 4.0(1) first and then upgrade both to 4.02a and sr2c (both boxes). At this point you should have a blank pub and sub database at verison 4.02asr2c. Then you should restore the database on the pub. The sub should automatically get the config after database replication. You can additionally force a replication.

While doing upgrades like this, i typically take backup images of the last known good configuration (in your case you should have taken a system backup of 4.01 publisher).

You can use system backup software such as Veritas backup, Acronis, Ghost etc.

HTH

Sankar

PS: please remember to rate posts!

New Member

Re: Call Manager Upgrade/Install

Sankar

Thanks very much for the reply. I guess the good news is that my assumptions were correct. The bad news is my original upgrade plan was incorrect. I never considered having to build the Sub at 4.01 before proceeding. By the way, one thing I didn't mention was that eventually, these new servers will end up with CCM 4.1.3, but my assumption was that the BARS backup from the old 4.02a servers needs to be applied to a new server at that same rev level (4.02a), and should not be restored to a 4.1.3 server. Is that correct, or could I have restored directly to the new 4.1.3 servers? I have the 4.1.3 CD's but didn't think that was a valid path. Thanks again for the prompt advice.

Tom

Re: Call Manager Upgrade/Install

Tom,

Your first assumption is correct. YOu cannot restore a BARS backup tar file for 4.02a on a 4.13 server. YOu have to match the version on the target server with the backed up database tar file.

HTH

Sankar.

145
Views
0
Helpful
3
Replies